aboutsummaryrefslogtreecommitdiff
path: root/math/sdpa
diff options
context:
space:
mode:
authorMaho Nakata <maho@FreeBSD.org>2007-01-16 04:37:14 +0000
committerMaho Nakata <maho@FreeBSD.org>2007-01-16 04:37:14 +0000
commit2277b8f479e58cb55e351d536e1f2a8189794186 (patch)
tree8b816ea878962e94adc2aab0b96f7ad2b90909b1 /math/sdpa
parent2167c9e89170e345ffd84915c48fb0af1a2c1a68 (diff)
downloadports-2277b8f479e58cb55e351d536e1f2a8189794186.tar.gz
ports-2277b8f479e58cb55e351d536e1f2a8189794186.zip
Fix build.
Submitted by: kris via pointyhat.
Notes
Notes: svn path=/head/; revision=182484
Diffstat (limited to 'math/sdpa')
-rw-r--r--math/sdpa/Makefile11
1 files changed, 7 insertions, 4 deletions
diff --git a/math/sdpa/Makefile b/math/sdpa/Makefile
index 8fba8218606e..85a0ca809b2f 100644
--- a/math/sdpa/Makefile
+++ b/math/sdpa/Makefile
@@ -23,7 +23,7 @@ MAINTAINER= maho@FreeBSD.org
COMMENT= SDPA(SemiDefinite Programming Algorithm) Very efficent SDP Solver
.if defined(WITH_ICC)
-BUILD_DEPENDS= ${LOCALBASE}/intel_cc_80/bin/icc:${PORTSDIR}/lang/icc
+BUILD_DEPENDS+= ${LOCALBASE}/intel_cc_80/bin/icc:${PORTSDIR}/lang/icc
.endif
WANT_FORTRAN=yes #dummy but future use
@@ -35,11 +35,16 @@ USE_GMAKE= yes
WRKSRC= ${WRKDIR}/${PORTNAME}
#for f2c.h
-BUILD_DEPENDS= ${LOCALBASE}/lib/libf2c.a:${PORTSDIR}/lang/f2c
+BUILD_DEPENDS+= ${LOCALBASE}/lib/libf2c.a:${PORTSDIR}/lang/f2c
+
+.include <bsd.port.pre.mk>
+
+#always needs atlas for lapack.h and blas.h
#.if exists(${LOCALBASE}/lib/libatlas_r.so) && !defined(WITH_BLAS)
WITH_ATLAS= yes
#.endif
.if defined(WITH_ATLAS)
+LIB_DEPENDS+= atlas.2:${PORTSDIR}/math/atlas
BLAS= -lcblas -lf77blas -latlas
LAPACK= -lalapack
CXXFLAGS+= -DNON_ATLAS_SDPA=0
@@ -57,8 +62,6 @@ PLIST_SUB+= PORTVERSION="${PORTVERSION}"
#WITH_SMP= yes
#WITH_ICC= yes
-.include <bsd.port.pre.mk>
-
.if defined(WITH_OPTIMIZED_FLAGS)
.if ${ARCH} == "amd64"
CFLAGS+= -pipe -O3 -ffast-math -funroll-all-loops -fpeel-loops -ftracer -funswitch-loops -funit-at-a-time