aboutsummaryrefslogtreecommitdiff
path: root/math/suitesparse
diff options
context:
space:
mode:
authorMaho Nakata <maho@FreeBSD.org>2008-02-27 05:20:25 +0000
committerMaho Nakata <maho@FreeBSD.org>2008-02-27 05:20:25 +0000
commit4d14be4216f7c8e0de4d2257866da6418527c233 (patch)
treecf85a63cbd1a21bcc07e86ab13cf55db6cc8b489 /math/suitesparse
parentd6249806f2614fe5761d628d67a3118bd8343e33 (diff)
downloadports-4d14be4216f7c8e0de4d2257866da6418527c233.tar.gz
ports-4d14be4216f7c8e0de4d2257866da6418527c233.zip
Build fix on amd64. I fixed differently, though.
Submitted by: Dominic Fandrey PR: 120985
Notes
Notes: svn path=/head/; revision=207978
Diffstat (limited to 'math/suitesparse')
-rw-r--r--math/suitesparse/Makefile12
-rw-r--r--math/suitesparse/files/patch-CSparse+Lib+Makefile11
-rw-r--r--math/suitesparse/files/patch-CXSparse+Lib+Makefile11
3 files changed, 32 insertions, 2 deletions
diff --git a/math/suitesparse/Makefile b/math/suitesparse/Makefile
index 7874909bb1c9..74e49ad54a54 100644
--- a/math/suitesparse/Makefile
+++ b/math/suitesparse/Makefile
@@ -86,15 +86,23 @@ post-patch:
-e 's,%%METIS%%,${METIS},g' \
-e 's,%%CHOLMOD_CONFIG%%,${CHOLMOD_CONFIG},g' \
${WRKSRC}/UFconfig/UFconfig.mk \
- ${WRKSRC_SHARED}/UFconfig/UFconfig.mk
+ ${WRKSRC_SHARED}/UFconfig/UFconfig.mk\
+ ${WRKSRC}/CSparse/Lib/Makefile \
+ ${WRKSRC_SHARED}/CSparse/Lib/Makefile \
+ ${WRKSRC}/CXSparse/Lib/Makefile \
+ ${WRKSRC_SHARED}/CXSparse/Lib/Makefile
@${REINPLACE_CMD} -e 's,%%CFLAGS%%,${CFLAGS},g' \
-e 's,%%FFLAGS%%,${FFLAGS},g' \
${WRKSRC}/UFconfig/UFconfig.mk \
+ ${WRKSRC}/CSparse/Lib/Makefile \
+ ${WRKSRC}/CXSparse/Lib/Makefile
@${REINPLACE_CMD} -e 's,%%CFLAGS%%,${CFLAGS_SHARED},g' \
-e 's,%%FFLAGS%%,${FFLAGS_SHARED},g' \
- ${WRKSRC_SHARED}/UFconfig/UFconfig.mk
+ ${WRKSRC_SHARED}/UFconfig/UFconfig.mk \
+ ${WRKSRC_SHARED}/CSparse/Lib/Makefile \
+ ${WRKSRC_SHARED}/CXSparse/Lib/Makefile
do-build:
cd ${WRKSRC} ; ${GMAKE}
diff --git a/math/suitesparse/files/patch-CSparse+Lib+Makefile b/math/suitesparse/files/patch-CSparse+Lib+Makefile
new file mode 100644
index 000000000000..c47ce63dab72
--- /dev/null
+++ b/math/suitesparse/files/patch-CSparse+Lib+Makefile
@@ -0,0 +1,11 @@
+--- CSparse/Lib/Makefile~ Wed Feb 27 11:41:43 2008
++++ CSparse/Lib/Makefile Wed Feb 27 11:50:50 2008
+@@ -1,6 +1,6 @@
+ # Modify the "-O" optimization option for best performance (-O3 on Linux):
+-CC = cc
+-CFLAGS = -O -I../Include
++CC = %%CC%%
++CFLAGS = %%CFLAGS%% -I../Include
+
+ AR = ar cr
+ RANLIB = ranlib
diff --git a/math/suitesparse/files/patch-CXSparse+Lib+Makefile b/math/suitesparse/files/patch-CXSparse+Lib+Makefile
new file mode 100644
index 000000000000..780cc4bcc442
--- /dev/null
+++ b/math/suitesparse/files/patch-CXSparse+Lib+Makefile
@@ -0,0 +1,11 @@
+--- CXSparse/Lib/Makefile~ Sun May 6 06:03:41 2007
++++ CXSparse/Lib/Makefile Wed Feb 27 11:59:17 2008
+@@ -1,6 +1,6 @@
+ # Modify the "-O" optimization option for best performance (-O3 on Linux):
+-CC = cc
+-CFLAGS = -O
++CC = %%CC%%
++CFLAGS = %%CFLAGS%%
+ I = -I../../UFconfig -I../Include
+
+ AR = ar cr