aboutsummaryrefslogtreecommitdiff
path: root/math/superlu/Makefile
diff options
context:
space:
mode:
authorThierry Thomas <thierry@FreeBSD.org>2004-09-27 07:31:01 +0000
committerThierry Thomas <thierry@FreeBSD.org>2004-09-27 07:31:01 +0000
commitf11bb0d97f2674fc1617be4feeff7e01386978cd (patch)
tree5187d6728a4b69eb6c02873ab0d2131abdeeb5e9 /math/superlu/Makefile
parent34ffd0aab6108b9e00ca5cdd73c1f02e6b97a9bf (diff)
downloadports-f11bb0d97f2674fc1617be4feeff7e01386978cd.tar.gz
ports-f11bb0d97f2674fc1617be4feeff7e01386978cd.zip
make replaced the defined command by our ${ARCH}.
Approved by: portmgr (marcus).
Notes
Notes: svn path=/head/; revision=118456
Diffstat (limited to 'math/superlu/Makefile')
-rw-r--r--math/superlu/Makefile13
1 files changed, 7 insertions, 6 deletions
diff --git a/math/superlu/Makefile b/math/superlu/Makefile
index c774a1b86712..d8250be65b5f 100644
--- a/math/superlu/Makefile
+++ b/math/superlu/Makefile
@@ -28,11 +28,8 @@ ALL_TARGET= superlulib
BLAS_LIBS= ${LOCALBASE}/lib/libf77blas.a ${LOCALBASE}/lib/libatlas.a
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} >= 502126
-BROKEN= "Broken by changes to make(1) on FreeBSD >= 5.x"
-.endif
+ARCH2FIX= SRC/Makefile TESTING/MATGEN/Makefile CBLAS/Makefile make.inc \
+ MAKE_INC/make.alpha MAKE_INC/make.inc
post-patch:
@${REINPLACE_CMD} -e 's+%%BLAS_LIBS%%+${BLAS_LIBS}+' \
@@ -45,6 +42,10 @@ post-patch:
${WRKSRC}/make.inc
@${REINPLACE_CMD} -e 's+%%FFLAGS%%+${FFLAGS}+' \
${WRKSRC}/make.inc
+.for fmk in ${ARCH2FIX}
+ @${REINPLACE_CMD} -e 's|^ARCH *.= ar|ARCMD = ar| ; \
+ s|\$$(ARCH)|$$(ARCMD)|' ${WRKSRC}/${fmk}
+.endfor
do-install:
${INSTALL_DATA} ${WRKSRC}/libsuperlu.* ${PREFIX}/lib
@@ -57,4 +58,4 @@ do-install:
${INSTALL_DATA} ${DISTDIR}/${DIST_SUBDIR}/superlu_ug.ps.gz ${DOCSDIR}
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>