aboutsummaryrefslogtreecommitdiff
path: root/math/vowpal_wabbit/Makefile
diff options
context:
space:
mode:
authorDmitry Sivachenko <demon@FreeBSD.org>2015-01-15 13:00:58 +0000
committerDmitry Sivachenko <demon@FreeBSD.org>2015-01-15 13:00:58 +0000
commit761e09d280cdf2cb1fdd0f80e8eef4b603736c47 (patch)
treea0df8e81014ea6429829bae81dfbbbd6b2cfcca3 /math/vowpal_wabbit/Makefile
parentac7c2bc7f8110ab2388834b24084478553d4d3e5 (diff)
downloadports-761e09d280cdf2cb1fdd0f80e8eef4b603736c47.tar.gz
ports-761e09d280cdf2cb1fdd0f80e8eef4b603736c47.zip
New port: vowpal_wabbit.
The Vowpal Wabbit (VW) project is a fast out-of-core learning system sponsored by Microsoft Research and (previously) Yahoo! Research. There are two ways to have a fast learning algorithm: (a) start with a slow algorithm and speed it up, or (b) build an intrinsically fast learning algorithm. This project is about approach (b), and it's reached a state where it may be useful to others as a platform for research and experimentation. There are several optimization algorithms available with the baseline being sparse gradient descent (GD) on a loss function (several are available). WWW: https://github.com/JohnLangford/vowpal_wabbit/wiki
Notes
Notes: svn path=/head/; revision=377088
Diffstat (limited to 'math/vowpal_wabbit/Makefile')
-rw-r--r--math/vowpal_wabbit/Makefile22
1 files changed, 22 insertions, 0 deletions
diff --git a/math/vowpal_wabbit/Makefile b/math/vowpal_wabbit/Makefile
new file mode 100644
index 000000000000..6eec527ee280
--- /dev/null
+++ b/math/vowpal_wabbit/Makefile
@@ -0,0 +1,22 @@
+# Created by: Dmitry Sivachenko <demon@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= vowpal_wabbit
+PORTVERSION= 7.9
+CATEGORIES= math
+MASTER_SITES= http://github.com/JohnLangford/vowpal_wabbit/archive/
+DISTFILES= ${PORTVERSION}${EXTRACT_SUFX}
+DIST_SUBDIR= ${PORTNAME}
+
+MAINTAINER= demon@FreeBSD.org
+COMMENT= Fast out-of-core learning system
+
+LIB_DEPENDS= libboost_thread.so:${PORTSDIR}/devel/boost-libs
+
+USES= libtool
+GNU_CONFIGURE= yes
+USE_LDCONFIG= yes
+
+CONFIGURE_ARGS= --enable-shared=no --with-boost=${LOCALBASE}
+
+.include <bsd.port.mk>