aboutsummaryrefslogtreecommitdiff
path: root/math/xppaut/Makefile
diff options
context:
space:
mode:
authorThierry Thomas <thierry@FreeBSD.org>2004-12-06 23:08:46 +0000
committerThierry Thomas <thierry@FreeBSD.org>2004-12-06 23:08:46 +0000
commit1da202f56d004f96493d34da48c63987afcc7877 (patch)
treee0e12d6dacff0f6b4e32617c87b44b87dbbbdffc /math/xppaut/Makefile
parent9ebc7d93aeb6275b3eb2d5fec5c5aad0110630c9 (diff)
downloadports-1da202f56d004f96493d34da48c63987afcc7877.tar.gz
ports-1da202f56d004f96493d34da48c63987afcc7877.zip
Add xppaut 5.85, graphical tool for solving differential equations, etc.
PR: 74254 Submitted by: Stephen Montgomery-Smith
Notes
Notes: svn path=/head/; revision=123347
Diffstat (limited to 'math/xppaut/Makefile')
-rw-r--r--math/xppaut/Makefile31
1 files changed, 31 insertions, 0 deletions
diff --git a/math/xppaut/Makefile b/math/xppaut/Makefile
new file mode 100644
index 000000000000..b6660541a778
--- /dev/null
+++ b/math/xppaut/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: xppaut
+# Date created: 3 September 2004
+# Whom: Stephen Montgomery-Smith <stephen@math.missouri.edu>
+#
+# $FreeBSD$
+#
+
+PORTNAME= xppaut
+PORTVERSION= 5.85
+CATEGORIES= math graphics
+MASTER_SITES= http://www.math.pitt.edu/~bard/bardware/
+DISTNAME= ${PORTNAME}${PORTVERSION}
+
+MAINTAINER= stephen@math.missouri.edu
+COMMENT= Graphical tool for solving differential equations, etc
+
+MAN1= xppaut.1
+USE_X_PREFIX= yes
+USE_REINPLACE= yes
+
+WRKSRC= ${WRKDIR}
+
+post-build:
+ ${CHMOD} a+r ${WRKSRC}/xppaut.1
+
+pre-configure:
+.if !defined(NOPORTDOCS)
+ @${REINPLACE_CMD} -e "s|# PORTDOCS||" ${WRKSRC}/Makefile
+.endif
+
+.include <bsd.port.mk>