aboutsummaryrefslogtreecommitdiff
path: root/math/xppaut/Makefile
diff options
context:
space:
mode:
authorStephen Montgomery-Smith <stephen@FreeBSD.org>2011-06-21 02:05:38 +0000
committerStephen Montgomery-Smith <stephen@FreeBSD.org>2011-06-21 02:05:38 +0000
commitae21113d167e56468c28bda56f57260150904f1e (patch)
tree395f090165acdbbbb2678b70b2005ec8829774b1 /math/xppaut/Makefile
parent9302dab78d14aa638d89a4bdc16be0884994dcee (diff)
downloadports-ae21113d167e56468c28bda56f57260150904f1e.tar.gz
ports-ae21113d167e56468c28bda56f57260150904f1e.zip
- Fix build with clang, and respect cflags
- portlint Approved by: maho (mentor)
Notes
Notes: svn path=/head/; revision=275957
Diffstat (limited to 'math/xppaut/Makefile')
-rw-r--r--math/xppaut/Makefile5
1 files changed, 2 insertions, 3 deletions
diff --git a/math/xppaut/Makefile b/math/xppaut/Makefile
index 45615164e09c..11d5afc4820f 100644
--- a/math/xppaut/Makefile
+++ b/math/xppaut/Makefile
@@ -16,8 +16,7 @@ COMMENT= Graphical tool for solving differential equations, etc
MAN1= xppaut.1
USE_XORG= xbitmaps x11 xproto
-MAKE_ARGS= CC="${CC}"
-
+CFLAGS+= -w -Wno-return-type
WRKSRC= ${WRKDIR}
post-build:
@@ -29,6 +28,6 @@ pre-configure:
.endif
post-patch:
- @(cd ${WRKSRC} && ${REINPLACE_CMD} -e "s|gcc|${CC}|" Makefile libI77/Makefile cvodesrc/Makefile mkavi/Makefile)
+ @(cd ${WRKSRC} && ${REINPLACE_CMD} -e "s|gcc|${CC}|" -e "s|CFLAGS=|CFLAGS= ${CFLAGS}|" Makefile libI77/Makefile cvodesrc/Makefile mkavi/Makefile)
.include <bsd.port.mk>