aboutsummaryrefslogtreecommitdiff
path: root/math
diff options
context:
space:
mode:
authorRaphael Kubo da Costa <rakuco@FreeBSD.org>2014-06-20 14:32:10 +0000
committerRaphael Kubo da Costa <rakuco@FreeBSD.org>2014-06-20 14:32:10 +0000
commit503986e68b434db6ab0fb016a506ef76d8c52f47 (patch)
treedfaf9a2bee32b17420b9757a6a9a6a4045a7df47 /math
parentacf6d6d4590be19a412ac494ad77d10d5d20c702 (diff)
downloadports-503986e68b434db6ab0fb016a506ef76d8c52f47.tar.gz
ports-503986e68b434db6ab0fb016a506ef76d8c52f47.zip
Update to 3.4.2.
Includes staging support and updates to the LIB_DEPENDS syntax. PR: 191060 Submitted by: phd_kimberlite@yahoo.co.jp (maintainer)
Notes
Notes: svn path=/head/; revision=358577
Diffstat (limited to 'math')
-rw-r--r--math/lapacke/Makefile44
-rw-r--r--math/lapacke/distinfo6
-rw-r--r--math/lapacke/files/Makefile.lib4
-rw-r--r--math/lapacke/files/patch-include+lapacke.h20
-rw-r--r--math/lapacke/files/patch-make.inc31
-rw-r--r--math/lapacke/files/patch-testing+Makefile16
-rw-r--r--math/lapacke/files/patch-testing+interface+Makefile34
7 files changed, 16 insertions, 139 deletions
diff --git a/math/lapacke/Makefile b/math/lapacke/Makefile
index 1af8839f9a13..5081f6b90c7c 100644
--- a/math/lapacke/Makefile
+++ b/math/lapacke/Makefile
@@ -2,13 +2,12 @@
# $FreeBSD$
PORTNAME= lapacke
-PORTVERSION= 3.4.0
-PORTREVISION= 2
+PORTVERSION= 3.4.2
CATEGORIES= math
MASTER_SITES= NL
MASTER_SITE_SUBDIR= lapack
DISTNAME= lapack-${PORTVERSION}
-DISTFILES= ${DISTNAME}.tgz lapacke.tgz
+EXTRACT_SUFX= .tgz
DIST_SUBDIR= lapack
MAINTAINER= phd_kimberlite@yahoo.co.jp
@@ -24,8 +23,7 @@ OPTIONS_DEFINE= PROFILE XLAPACKE
PROFILE_DESC= Build a profiling library
XLAPACKE_DESC= Install interfaces to XLAPACK
-NO_STAGE= yes
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
LAPACKE_SVERSION= 1
LAPACKE_LIBNAME= lapacke
@@ -50,25 +48,25 @@ WITH_BLAS?= reference
.endif
.if ${WITH_BLAS} == "reference"
-LIB_DEPENDS+= blas.2:${PORTSDIR}/math/blas \
- lapack.4:${PORTSDIR}/math/lapack
+LIB_DEPENDS+= libblas.so:${PORTSDIR}/math/blas \
+ liblapack.so:${PORTSDIR}/math/lapack
BLAS= -lblas
LAPACK= -llapack
.elif ${WITH_BLAS} == "gotoblas"
CFLAGS+= ${PTHREAD_CFLAGS}
LDFLAGS+= ${PTHREAD_LIBS}
-LIB_DEPENDS+= goto2p.1:${PORTSDIR}/math/gotoblas
+LIB_DEPENDS+= libgoto2p.so:${PORTSDIR}/math/gotoblas
BLAS= -lgoto2p
LAPACK= -lgoto2p
.elif ${WITH_BLAS} == "atlas"
CFLAGS+= ${PTHREAD_CFLAGS}
LDFLAGS+= ${PTHREAD_LIBS}
-LIB_DEPENDS+= atlas.2:${PORTSDIR}/math/atlas
+LIB_DEPENDS+= libatlas.so:${PORTSDIR}/math/atlas
BLAS= -lptf77blas
LAPACK= -lalapack -lptcblas
.endif
.if ${PORT_OPTIONS:MXLAPACKE}
-LIB_DEPENDS+= xlapack.4:${PORTSDIR}/math/xlapack
+LIB_DEPENDS+= libxlapack.so:${PORTSDIR}/math/xlapack
.endif
LDFLAGS+= -L${LOCALBASE}/lib
@@ -107,23 +105,12 @@ PLIST_FILES+= lib/lib${XLAPACKE_LIBNAME}_p.a
MAKE_ENV+= NO_PROFILE=
.endif
-post-extract:
- @${CP} -r ${WRKSRC_LEGACY}/testing ${WRKSRC}/.
-
post-patch:
@${FIND} ${WRKSRC} -name "Makefile*" -type f |\
${XARGS} ${REINPLACE_CMD} -e 's;$$(ARCH);$$(ARCH_);g'
- @${REINPLACE_CMD} -e 's;%%CC%%;${CC};g' \
- -e 's;%%CFLAGS%%;${CFLAGS};g' \
- -e 's;%%LDFLAGS%%;${LDFLAGS};g' \
- -e 's;%%AR%%;${AR};g' \
- -e 's;%%RANLIB%%;${RANLIB};g' \
- -e 's;%%BLAS%%;${BLAS};g' \
- -e 's;%%LAPACK%%;${LAPACK};g' \
- -e 's;%%LAPACKE_LIBNAME%%;${LAPACKE_LIBNAME};g' \
- ${WRKSRC}/make.inc
@${MV} ${WRKSRC}/Makefile ${WRKSRC}/Makefile.dist
@${CP} ${FILESDIR}/Makefile ${WRKSRC}/Makefile
+ @${CP} ${WRKSRC}/include//lapacke_mangling_with_flags.h ${WRKSRC}/include//lapacke_mangling.h
@${MKDIR} ${WRKSRC}/lib
@${CP} ${FILESDIR}/Makefile.lib ${WRKSRC}/lib/Makefile
@${MKDIR} ${WRKSRC}/libtmg
@@ -146,15 +133,8 @@ post-patch:
post-install:
.if ${PORT_OPTIONS:MDOCS}
- @${MKDIR} ${DOCSDIR}
- @(cd ${WRKSRC}/ && ${INSTALL_DATA} ${PORTDOCS} ${DOCSDIR})
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ @(cd ${WRKSRC}/ && ${INSTALL_DATA} ${PORTDOCS} ${STAGEDIR}${DOCSDIR})
.endif
-check regression-test test: build
- @${CP} ${WRKSRC}/lib/lib${LAPACKE_LIBNAME}.a ${WRKSRC}/.
- @${ECHO_CMD} "Testing static lapacke library"
- @(cd ${WRKSRC}/testing; ${SETENV} ${MAKE_ENV} \
- ${MAKE} ${MAKE_FLAGS} ${MAKEFILE} ${_MAKE_JOBS} ${MAKE_ARGS})
- @${CAT} ${WRKSRC}/testing/interface/*.out
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/math/lapacke/distinfo b/math/lapacke/distinfo
index 4094666fef58..56cd2908b74f 100644
--- a/math/lapacke/distinfo
+++ b/math/lapacke/distinfo
@@ -1,4 +1,2 @@
-SHA256 (lapack/lapack-3.4.0.tgz) = a7139ef97004d0e3c4c30f1c52d508fd7ae84b5fbaf0dd8e792c167dc306c3e9
-SIZE (lapack/lapack-3.4.0.tgz) = 6127787
-SHA256 (lapack/lapacke.tgz) = 7f992bd1f143251ddd03b99ef935942c17caf43652ae94a251601e00dce258e3
-SIZE (lapack/lapacke.tgz) = 840233
+SHA256 (lapack/lapack-3.4.2.tgz) = 60a65daaf16ec315034675942618a2230521ea7adf85eea788ee54841072faf0
+SIZE (lapack/lapack-3.4.2.tgz) = 6168281
diff --git a/math/lapacke/files/Makefile.lib b/math/lapacke/files/Makefile.lib
index 8b907e4d90e1..19f986a2b234 100644
--- a/math/lapacke/files/Makefile.lib
+++ b/math/lapacke/files/Makefile.lib
@@ -1119,7 +1119,7 @@ UTILS_SRCS=\
lapacke_ztr_nancheck.c lapacke_ztr_trans.c
%%XLAPACKE%%beforeinstall:
-%%XLAPACKE%% ${BSD_INSTALL_DATA} ${.CURDIR}/../include/lapacke.h ${PREFIX}/include
-%%XLAPACKE%% ${BSD_INSTALL_DATA} ${.CURDIR}/../include/lapacke_utils.h ${PREFIX}/include
+%%XLAPACKE%% ${BSD_INSTALL_DATA} ${.CURDIR}/../include/lapacke.h ${DESTDIR}${PREFIX}/include
+%%XLAPACKE%% ${BSD_INSTALL_DATA} ${.CURDIR}/../include/lapacke_utils.h ${DESTDIR}${PREFIX}/include
.include <bsd.lib.mk>
diff --git a/math/lapacke/files/patch-include+lapacke.h b/math/lapacke/files/patch-include+lapacke.h
deleted file mode 100644
index 9c37f0029534..000000000000
--- a/math/lapacke/files/patch-include+lapacke.h
+++ /dev/null
@@ -1,20 +0,0 @@
---- include/lapacke.h.orig 2010-12-03 20:56:19.000000000 +0900
-+++ include/lapacke.h 2010-12-03 20:56:59.000000000 +0900
-@@ -84,7 +84,7 @@
- #endif
-
- #ifndef lapack_complex_float_imag
--#define lapack_complex_float_imag(z) (imag(z))
-+#define lapack_complex_float_imag(z) (cimag(z))
- #endif
-
- lapack_complex_float lapack_make_complex_float( float re, float im );
-@@ -100,7 +100,7 @@
- #endif
-
- #ifndef lapack_complex_double_imag
--#define lapack_complex_double_imag(z) (imag(z))
-+#define lapack_complex_double_imag(z) (cimag(z))
- #endif
-
- lapack_complex_double lapack_make_complex_double( double re, double im );
diff --git a/math/lapacke/files/patch-make.inc b/math/lapacke/files/patch-make.inc
deleted file mode 100644
index 30f9d54a6e8e..000000000000
--- a/math/lapacke/files/patch-make.inc
+++ /dev/null
@@ -1,31 +0,0 @@
---- make.inc.orig 2011-11-10 07:56:15.000000000 +0900
-+++ make.inc 2011-12-03 20:22:18.000000000 +0900
-@@ -47,20 +47,19 @@
- # LDFLAGS = -nofor-main
- # - gfortran, set: LINKER = gfortran
- #
--CC = gcc
--CFLAGS =
--LINKER = gfortran
--LDFLAGS =
-+CC = %%CC%%
-+CFLAGS = %%CFLAGS%%
-+LINKER = $(CC)
-+LDFLAGS = %%LDFLAGS%%
- #
- # The name of the libraries to be created/linked to
- # Ensure that the libraries have the same data model (LP64/ILP64).
- #
--LAPACKE = lapacke.a
--LIBS = /Users/julie/Documents/Boulot/lapack-dev/lapack/trunk/lapack_LINUX.a \
-- /Users/julie/Documents/Boulot/lapack-dev/lapack/trunk/blas_LINUX.a -lm
-+LAPACKE = ./lib%%LAPACKE_LIBNAME%%.a
-+LIBS = %%LAPACK%% %%BLAS%%
- # The archiver and the flag(s) to use when building archive (library)
- # If your system has no ranlib, set RANLIB = echo.
- #
--ARCH = ar
-+ARCH_ = %%AR%%
- ARCHFLAGS = cr
--RANLIB = ranlib
-+RANLIB = %%RANLIB%%
diff --git a/math/lapacke/files/patch-testing+Makefile b/math/lapacke/files/patch-testing+Makefile
deleted file mode 100644
index fab617b08eb3..000000000000
--- a/math/lapacke/files/patch-testing+Makefile
+++ /dev/null
@@ -1,16 +0,0 @@
---- ./testing/Makefile.orig 2010-10-01 17:17:25.000000000 +0900
-+++ ./testing/Makefile 2011-09-30 19:38:00.000000000 +0900
-@@ -35,9 +35,9 @@
- include ../make.inc
-
- all:
-- cd utils && $(MAKE)
-- cd interface && $(MAKE)
-+ cd ${.CURDIR}/utils && $(MAKE)
-+ cd ${.CURDIR}/interface && $(MAKE)
-
- clean:
-- cd utils && $(MAKE) clean
-- cd interface && $(MAKE) clean
-+ cd ${.CURDIR}/utils && $(MAKE) clean
-+ cd ${.CURDIR}/interface && $(MAKE) clean
diff --git a/math/lapacke/files/patch-testing+interface+Makefile b/math/lapacke/files/patch-testing+interface+Makefile
deleted file mode 100644
index a5ce372bba59..000000000000
--- a/math/lapacke/files/patch-testing+interface+Makefile
+++ /dev/null
@@ -1,34 +0,0 @@
---- testing/interface/Makefile.orig 2010-12-06 20:30:08.000000000 +0900
-+++ testing/interface/Makefile 2010-12-06 20:38:46.000000000 +0900
-@@ -497,9 +497,9 @@
- zupgtr_1 \
- zupmtr_1
-
--OBJ = $(TST:%=%.o)
--EXE = $(TST:%=x%)
--OUT = $(TST:%=%.out)
-+OBJ = ${TST:N*.h:R:S/$/.o/}
-+EXE = ${TST}
-+OUT = ${TST:N*.h:R:S/$/.out/}
-
- AUX = ../utils/compare_complex_doubles.o \
- ../utils/compare_complex_floats.o \
-@@ -510,14 +510,10 @@
-
- tst: $(OUT)
-
--%.out : x%
-- ./$< > $@
--
--x% : %.o
-- $(LINKER) $(LDFLAGS) $< -o $@ $(AUX) ../../$(LAPACKE) $(LIBS)
--
--%.o : %.c
-- $(CC) -c $(CFLAGS) -I ../include -I ../../include -o $@ $<
-+.c.out :
-+ $(CC) -c $(CFLAGS) -I ../include -I ../../include $<
-+ $(LINKER) $(LDFLAGS) $*.o -o $* $(AUX) ../../$(LAPACKE) $(LIBS)
-+ ./$* > $@
-
- clean:
- rm -f $(EXE) $(OBJ)