aboutsummaryrefslogtreecommitdiff
path: root/math
diff options
context:
space:
mode:
authorSteve Price <steve@FreeBSD.org>2000-09-18 00:43:30 +0000
committerSteve Price <steve@FreeBSD.org>2000-09-18 00:43:30 +0000
commit516bfa948a505dbbdfca3a0178108750d665b4fd (patch)
tree99eca17afd91e7b13e09795b1976a59b37361f41 /math
parente8dbbb9d588122d46573c10c51aa694475c316b7 (diff)
downloadports-516bfa948a505dbbdfca3a0178108750d665b4fd.tar.gz
ports-516bfa948a505dbbdfca3a0178108750d665b4fd.zip
Adding thx_1138 version 1.0.5.
A calculator that includes plotting capabilities. PR: 19291 Submitted by: Mario S F Ferreira <lioux@linf.unb.br>
Notes
Notes: svn path=/head/; revision=32792
Diffstat (limited to 'math')
-rw-r--r--math/Makefile1
-rw-r--r--math/thx_1138/Makefile106
-rw-r--r--math/thx_1138/distinfo1
-rw-r--r--math/thx_1138/files/patch-aa28
-rw-r--r--math/thx_1138/files/patch-ab29
-rw-r--r--math/thx_1138/pkg-comment1
-rw-r--r--math/thx_1138/pkg-descr17
-rw-r--r--math/thx_1138/pkg-plist4
8 files changed, 187 insertions, 0 deletions
diff --git a/math/Makefile b/math/Makefile
index bee6591b18f9..a11f5545b92a 100644
--- a/math/Makefile
+++ b/math/Makefile
@@ -63,6 +63,7 @@
SUBDIR += spin
SUBDIR += ss
SUBDIR += superlu
+ SUBDIR += thx_1138
SUBDIR += topaz
SUBDIR += umatrix
SUBDIR += umfpack
diff --git a/math/thx_1138/Makefile b/math/thx_1138/Makefile
new file mode 100644
index 000000000000..f466a5df994e
--- /dev/null
+++ b/math/thx_1138/Makefile
@@ -0,0 +1,106 @@
+# New ports collection makefile for: thx-1138
+# Date created: 14 June 2000
+# Whom: Mario S F Ferreira <lioux@linf.unb.br> et al.
+#
+# $FreeBSD$
+#
+
+PORTNAME= thx_1138
+PORTVERSION= 1.0.5
+CATEGORIES= math
+MASTER_SITES= ftp://ftp.newplanetsoftware.com/pub/thx/source/
+DISTNAME= ${PORTNAME:S,_,-,}_source-${PORTVERSION}
+
+MAINTAINER= lioux@linf.unb.br
+
+BUILD_DEPENDS= nonexistent:${JXPORT}:configure \
+ makemake:${JXPORT}
+LIB_DEPENDS= jx-1_5_3.1:${JXPORT} \
+ j2dplot-0_6_5.0:${PORTSDIR}/x11-toolkits/libj2dplot \
+ jparser-1_1_8.1:${PORTSDIR}/x11-toolkits/libjparser
+
+WRKSRC= ${WRKDIR}/JX-1.5.3
+
+USE_XLIB= yes
+USE_GMAKE= yes
+MAKE_ARGS= CC="${CC}" CXX="${CXX}" \
+ CFLAGS="${CFLAGS}" CXXFLAGS="${CXXFLAGS}"
+MAKE_ENV= JX_INSTALL_ROOT="${X11BASE}/bin" \
+ JX_LIB_ROOT="${X11BASE}/lib"
+PLIST_SUB= PORTNAME="${PORTNAME:S,_,-,}"
+
+# Make environment
+PORTINCLUDES= -I${X11BASE}/include/jx \
+ -I${X11BASE}/include/jcore \
+ -I${X11BASE}/include/j2dplot \
+ -I${X11BASE}/include/jparser \
+ -I${X11BASE}/include
+
+# Installs dir with proper permissions
+INSTALL_DATA_DIR= ${INSTALL} -d -o ${SHAREOWN} -g ${SHAREGRP} -m 755
+# program files
+PROGRAMFILES= thx-1138/thx-1138
+# documents
+DOCFILES= LICENSE README.binary
+DOCDIR_PREFIX= ${PREFIX}/share/doc/${PORTNAME:S,_,-,}
+# additional configuration and header files
+EXTRALIB_PREFIX= ${X11BASE}/lib/jx
+EXTRALIBFILES_MAKE_WRKSRC= include/make
+# main jx distribution files needed for building
+COPY_JXDIRS= include
+COPY_JXFILES= Makefile
+# main jx distribution port wrksrc
+JXPORT= ${PORTSDIR}/x11-toolkits/jx
+JXPORT_WRKSRC= ${JXPORT}/work/JX-1.5.3
+JX_MAKE_CONSTANTS= j2dplot_constants jparser_constants
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 300000
+ALL_TARGET= freebsd3.x
+.else
+ALL_TARGET= freebsd2.x
+.endif
+
+.if defined(NOPORTDOCS)
+PLIST_SUB+= PORTDOCS:="@comment "
+.else
+PLIST_SUB+= PORTDOCS:=
+.endif # !defined(NOPORTDOCS)
+
+post-extract:
+.for i in ${COPY_JXDIRS}
+ @${CP} -Rp ${JXPORT_WRKSRC}/${i} ${WRKSRC}
+.endfor
+.for i in ${COPY_JXFILES}
+ @${CP} -p ${JXPORT_WRKSRC}/${i} ${WRKSRC}
+.endfor
+
+post-patch:
+ @${ECHO} "SEARCHDIRS += ${PORTINCLUDES}" >> \
+ ${WRKSRC}/${EXTRALIBFILES_MAKE_WRKSRC}/jx_constants
+
+pre-build:
+.for i in ${JX_MAKE_CONSTANTS}
+ @${LN} -sf ${EXTRALIB_PREFIX}/make/${i} ${WRKSRC}/include/make
+.endfor
+
+post-build:
+ @cd ${WRKSRC}/programs/${PORTNAME:S,_,-,}; ${SETENV} ${MAKE_ENV} makemake; \
+ ${SETENV} ${MAKE_ENV} ${GMAKE} ${MAKE_FLAGS} \
+ ${MAKEFILE} ${MAKE_ARGS}
+
+do-install:
+.if !defined(NOPORTDOCS)
+# Install all documentation
+ @${INSTALL_DATA_DIR} ${DOCDIR_PREFIX}
+.for i in ${DOCFILES}
+ @${INSTALL_DATA} ${WRKSRC}/programs/${PORTNAME:S,_,-,}/${i} ${DOCDIR_PREFIX}
+.endfor
+.endif # !defined(NOPORTDOCS)
+# Install all programs
+.for i in ${PROGRAMFILES}
+ @${INSTALL_PROGRAM} ${WRKSRC}/programs/${i} ${PREFIX}/bin
+.endfor
+
+.include <bsd.port.post.mk>
diff --git a/math/thx_1138/distinfo b/math/thx_1138/distinfo
new file mode 100644
index 000000000000..7ba54bc1eb99
--- /dev/null
+++ b/math/thx_1138/distinfo
@@ -0,0 +1 @@
+MD5 (thx-1138_source-1.0.5.tar.gz) = a0b87c02def611b7399717e144820333
diff --git a/math/thx_1138/files/patch-aa b/math/thx_1138/files/patch-aa
new file mode 100644
index 000000000000..18be5d2d2db3
--- /dev/null
+++ b/math/thx_1138/files/patch-aa
@@ -0,0 +1,28 @@
+--- Makefile.orig Sat Sep 11 17:44:38 1999
++++ Makefile Wed Jun 14 01:07:15 2000
+@@ -262,25 +262,11 @@
+ freebsd2.x: prep
+ @ln -s sys/FreeBSD-2.x_g++ \
+ include/make/jx_config
+- @ln -s ../../include/missing_proto/jMissingProto_empty.h \
+- include/jcore/jMissingProto.h
+- @ln -s config-freebsd.h \
+- ACE/ACE_wrappers/ace/config.h
+- @ln -s platform_freebsd.GNU \
+- ACE/ACE_wrappers/include/makeinclude/platform_macros.GNU
+- @${INSTALL_CMD}
+
+ .PHONY : freebsd3.x
+ freebsd3.x: prep
+ @ln -s sys/FreeBSD-3.x_g++ \
+ include/make/jx_config
+- @ln -s ../../include/missing_proto/jMissingProto_empty.h \
+- include/jcore/jMissingProto.h
+- @ln -s config-freebsd-pthread.h \
+- ACE/ACE_wrappers/ace/config.h
+- @ln -s platform_freebsd_pthread.GNU \
+- ACE/ACE_wrappers/include/makeinclude/platform_macros.GNU
+- @${INSTALL_CMD}
+
+ #
+ # SunOS 4.x
diff --git a/math/thx_1138/files/patch-ab b/math/thx_1138/files/patch-ab
new file mode 100644
index 000000000000..ece2573e263d
--- /dev/null
+++ b/math/thx_1138/files/patch-ab
@@ -0,0 +1,29 @@
+--- programs/thx-1138/Make.header.orig Thu Jun 15 00:07:41 2000
++++ programs/thx-1138/Make.header Thu Jun 15 00:08:06 2000
+@@ -47,17 +47,6 @@
+
+ # library dependencies
+
+-ifdef J_BUILD_SHARED_LIB
+- LIB_DEPS := ${JLIBDIR}/libjcore-${JX_LIB_VERSION}.so \
+- ${JLIBDIR}/libjx-${JX_LIB_VERSION}.so \
+- ${JLIBDIR}/libjparser-${JPARSER_LIB_VERSION}.so \
+- ${JLIBDIR}/libj2dplot-${J2DPLOT_LIB_VERSION}.so
+-else
+- LIB_DEPS := ${JLIBDIR}/libjcore-${JX_LIB_VERSION}.a \
+- ${JLIBDIR}/libjx-${JX_LIB_VERSION}.a \
+- ${JLIBDIR}/libjparser-${JPARSER_LIB_VERSION}.a \
+- ${JLIBDIR}/libj2dplot-${J2DPLOT_LIB_VERSION}.a
+-endif
+
+ # make variables
+
+@@ -68,7 +57,7 @@
+ #####
+
+ .PHONY : default
+-default: libs thx-1138
++default: thx-1138
+
+ .PHONY : Makefiles
+ Makefiles:
diff --git a/math/thx_1138/pkg-comment b/math/thx_1138/pkg-comment
new file mode 100644
index 000000000000..9e5484e3ef8b
--- /dev/null
+++ b/math/thx_1138/pkg-comment
@@ -0,0 +1 @@
+Electronic Paper for Calculations and Graphs
diff --git a/math/thx_1138/pkg-descr b/math/thx_1138/pkg-descr
new file mode 100644
index 000000000000..a9d06bb4aab9
--- /dev/null
+++ b/math/thx_1138/pkg-descr
@@ -0,0 +1,17 @@
+THX-1138
+
+From the software readme:
+
+THX-1138 is the calculator you've always wanted, short of handwriting
+recognition.
+
+THX-1138 (pronounced "thex") provides a calculator and the ability
+to plot functions.
+
+I chose the name as a tribute to the character in George Lucas'
+movie. Free software and old SF movies do not compete, and I
+encourage everybody to rent the movie, but if anybody still wants
+to sue me, please remember that I don't have enough money to make
+it worth the trouble, so just notify me, and I'll change the name.
+
+WWW: http://www.newplanetsoftware.com/thx/
diff --git a/math/thx_1138/pkg-plist b/math/thx_1138/pkg-plist
new file mode 100644
index 000000000000..d632fe9d66e9
--- /dev/null
+++ b/math/thx_1138/pkg-plist
@@ -0,0 +1,4 @@
+bin/thx-1138
+%%PORTDOCS:%%share/doc/%%PORTNAME%%/LICENSE
+%%PORTDOCS:%%share/doc/%%PORTNAME%%/README.binary
+%%PORTDOCS:%%@dirrm share/doc/%%PORTNAME%%