aboutsummaryrefslogtreecommitdiff
path: root/math
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2006-01-03 04:37:24 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2006-01-03 04:37:24 +0000
commitf0ac2b0eed66cd5fc16e38a187c74f28eec296e3 (patch)
tree22c9e4d49dfe523027fbcc7feaa552973b7f9de9 /math
parentefe276b7140eb56300c6a098100619ffd3f1839e (diff)
downloadports-f0ac2b0eed66cd5fc16e38a187c74f28eec296e3.tar.gz
ports-f0ac2b0eed66cd5fc16e38a187c74f28eec296e3.zip
Make math/arpack depend less on math/atlas
Atlas is great in the platforms where it's available, however it is not being packaged (for good reasons) anymore. arpack originally used blas for testing and since we are not really linking any version of blas in the package it doesn't make any difference what we use. It seems better idea to use blas for testing since it's faster to build and because this also means we can package arpack without building ATLAS, The resulting package will work with BLAs or ATLAS just the same and in any case the BLAS_LIBS variable can now be overridden to test with atlas if it's so desired. This change doesn't change the package so I think we should leave the PORTVERSION untouched. PR: ports/91251 Submitted by: Pedro F. Giffuni <giffunip@asme.org>
Notes
Notes: svn path=/head/; revision=152643
Diffstat (limited to 'math')
-rw-r--r--math/arpack/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/math/arpack/Makefile b/math/arpack/Makefile
index 1524c8d0a2f4..790a2bde5238 100644
--- a/math/arpack/Makefile
+++ b/math/arpack/Makefile
@@ -22,12 +22,12 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= Argand Library: large eigenvalue subroutines (serial version)
BUILD_DEPENDS= ${LOCALBASE}/bin/f2c:${PORTSDIR}/lang/f2c \
- ${LOCALBASE}/lib/libf77blas.a:${PORTSDIR}/math/atlas
+ ${LOCALBASE}/lib/libblas.a:${PORTSDIR}/math/blas
WRKSRC= ${WRKDIR}/ARPACK
ALL_TARGET= lib
-BLAS_LIBS= ${LOCALBASE}/lib/libf77blas.a ${LOCALBASE}/lib/libatlas.a
+BLAS_LIBS?= ${LOCALBASE}/lib/libblas.a
INSTALLS_SHLIB= yes
USE_REINPLACE= yes