aboutsummaryrefslogtreecommitdiff
path: root/math
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2013-03-14 05:30:28 +0000
committerMartin Wilke <miwi@FreeBSD.org>2013-03-14 05:30:28 +0000
commit073078520edc34677efbdcf88e71fc6c1b148093 (patch)
tree1418310ea949b65a5a090c36026cef214012b26f /math
parent1b607e2b11933cc01f27e0f9f4d95ecd0bb872b0 (diff)
downloadports-073078520edc34677efbdcf88e71fc6c1b148093.tar.gz
ports-073078520edc34677efbdcf88e71fc6c1b148093.zip
- Fix build with FORTRAN on
PR: 176535 Submitted by: Ports Fury
Notes
Notes: svn path=/head/; revision=314130
Diffstat (limited to 'math')
-rw-r--r--math/plplot/files/patch-util__plrender.c20
-rw-r--r--math/plplot/pkg-plist6
2 files changed, 26 insertions, 0 deletions
diff --git a/math/plplot/files/patch-util__plrender.c b/math/plplot/files/patch-util__plrender.c
new file mode 100644
index 000000000000..0d47db22bf27
--- /dev/null
+++ b/math/plplot/files/patch-util__plrender.c
@@ -0,0 +1,20 @@
+--- utils/plrender.c.orig
++++ utils/plrender.c
+@@ -834,7 +834,7 @@
+ if ( code ) { fprintf( stderr, \
+ "Unable to read in %s at line %d, bytecount %d\n\
+ Bytes requested: %d\n", __FILE__, __LINE__, \
+- (int) pdfs->bp, (int) 2 * n ); return -1; }
++ (int) pdfs->bp, (int) 2 * n ); return; }
+
+ static void
+ get_ncoords( PLFLT *x, PLFLT *y, PLINT n )
+@@ -869,7 +869,7 @@
+ free( ys );
+ }
+
+- return 0;
++ return;
+ }
+
+ //--------------------------------------------------------------------------
diff --git a/math/plplot/pkg-plist b/math/plplot/pkg-plist
index 28a7c137d51e..9c26d927677e 100644
--- a/math/plplot/pkg-plist
+++ b/math/plplot/pkg-plist
@@ -27,6 +27,7 @@ include/plplot/qsastimedll.h
%%WXGTK%%include/plplot/wxPLplotstream.h
%%WXGTK%%include/plplot/wxPLplotwindow.h
%%TCLTK%%include/plplot/tclMatrix.h
+%%FORTRAN%%lib/fortran/include/plplot/plplot_parameters.h
%%FORTRAN%%lib/fortran/modules/plplot/plplot.mod
%%FORTRAN%%lib/fortran/modules/plplot/plplot_flt.mod
%%FORTRAN%%lib/fortran/modules/plplot/plplotp.mod
@@ -628,4 +629,9 @@ libdata/pkgconfig/plplotd.pc
@dirrm lib/plplot/driversd
@dirrm lib/plplot
%%LUA%%@dirrm %%LUA_MODLIBDIR%%/plplot
+%%FORTRAN%%@dirrm lib/fortran/modules/plplot
+%%FORTRAN%%@dirrmtry lib/fortran/modules
+%%FORTRAN%%@dirrm lib/fortran/include/plplot
+%%FORTRAN%%@dirrmtry lib/fortran/include
+%%FORTRAN%%@dirrmtry lib/fortran
@dirrm include/plplot