aboutsummaryrefslogtreecommitdiff
path: root/math
diff options
context:
space:
mode:
authorMaho Nakata <maho@FreeBSD.org>2013-01-03 07:51:24 +0000
committerMaho Nakata <maho@FreeBSD.org>2013-01-03 07:51:24 +0000
commit5ccfbe91aa880409d9ad69e33c1390f0a7ecc67f (patch)
treedd159c33f5c41e5fa21499f36cdbd1a6aae9fa32 /math
parentc2a6b59d51b1f5df1dca0485ba6c8a0b77dee701 (diff)
downloadports-5ccfbe91aa880409d9ad69e33c1390f0a7ecc67f.tar.gz
ports-5ccfbe91aa880409d9ad69e33c1390f0a7ecc67f.zip
* update to 4.0.2
* correct openblas dependency [1] Submitted by: Eijiro Shibusawa <phd_kimberlite@yahoo.co.jp> [1]
Notes
Notes: svn path=/head/; revision=309855
Diffstat (limited to 'math')
-rw-r--r--math/suitesparse/Makefile15
-rw-r--r--math/suitesparse/distinfo4
-rw-r--r--math/suitesparse/files/patch-SPQR+Source+spqr_factorize.cpp10
-rw-r--r--math/suitesparse/files/patch-UFconfig+UFconfig.mk28
-rw-r--r--math/suitesparse/pkg-plist7
5 files changed, 16 insertions, 48 deletions
diff --git a/math/suitesparse/Makefile b/math/suitesparse/Makefile
index eb34bf450b19..5b1a389efc75 100644
--- a/math/suitesparse/Makefile
+++ b/math/suitesparse/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= suitesparse
-PORTVERSION= 3.6.1
-PORTREVISION= 2
+PORTVERSION= 4.0.2
CATEGORIES= math
MASTER_SITES= http://www.cise.ufl.edu/research/sparse/SuiteSparse/
DISTNAME= SuiteSparse-${PORTVERSION}
@@ -28,7 +27,9 @@ CONFLICTS= umfpack-*
.include <bsd.port.pre.mk>
-.if exists(${LOCALBASE}/lib/libgoto2.so)
+.if exists(${LOCALBASE}/lib/libopenblas.so)
+WITH_BLAS?= openblas
+.elif exists(${LOCALBASE}/lib/libgoto2.so)
WITH_BLAS?= gotoblas
.elif exists(${LOCALBASE}/lib/libatlas.so)
WITH_BLAS?= atlas
@@ -44,6 +45,10 @@ LIB_DEPENDS+= blas.2:${PORTSDIR}/math/blas
LIB_DEPENDS+= lapack.4:${PORTSDIR}/math/lapack
BLAS= -lblas
LAPACK= -llapack
+.elif ${WITH_BLAS} == openblas
+LIB_DEPENDS+= openblas:${PORTSDIR}/math/openblas
+BLAS= -lopenblasp
+LAPACK= -lopenblasp
.elif ${WITH_BLAS} == gotoblas
LIB_DEPENDS+= goto2:${PORTSDIR}/math/gotoblas
LIB_DEPENDS+= lapack.4:${PORTSDIR}/math/lapack
@@ -92,8 +97,11 @@ post-patch:
-e 's|-I\$$(METIS_PATH)/Lib|-I${METIS_PATH}|' \
-e '\|^RANLIB =|s|ranlib|${RANLIB}|' \
-e '\|^SPQR_CONFIG =|s|=.*|= ${CHOLMOD_CONFIG}|' \
+ -e 's|# MAKE = gmake|MAKE = gmake|g' \
-e 's|/usr/local|${LOCALBASE}|g'
@${CP} -r ${WRKSRC} ${WRKSRC_SHARED}
+ @${FIND} -X ${WRKSRC_SHARED} -type f -name 'Makefile' -or -name '*.mk' | ${XARGS} \
+ ${REINPLACE_CMD} -e 's|$$(CFLAGS)|$$(CFLAGS) $$(PICFLAG)|g'
do-build:
@cd ${WRKSRC} ; ${SETENV} ${MAKE_ENV} PICFLAG= \
@@ -113,7 +121,6 @@ do-install:
.for d in AMD BTF CAMD CCOLAMD CHOLMOD COLAMD CXSparse KLU SPQR UMFPACK
@${INSTALL_DATA} ${WRKSRC}/${d}/Include/*.h ${PREFIX}/include/suitesparse
.endfor
- @${INSTALL_DATA} ${WRKSRC}/UFconfig/*.h ${PREFIX}/include/suitesparse
@${INSTALL_DATA} ${WRKSRC}/SPQR/Include/*.hpp ${PREFIX}/include/suitesparse
@for i in `find ${WRKSRC_SHARED} -type f -name '*.a'` ; do \
${INSTALL_DATA} ${WRKSRC}/$${i##${WRKSRC_SHARED}/} \
diff --git a/math/suitesparse/distinfo b/math/suitesparse/distinfo
index 7a13b8267774..45d01b22cb39 100644
--- a/math/suitesparse/distinfo
+++ b/math/suitesparse/distinfo
@@ -1,2 +1,2 @@
-SHA256 (SuiteSparse-3.6.1.tar.gz) = 9876a27ad365ce02610b074167081eb22aa61a18141268dbd84218b7ae37c540
-SIZE (SuiteSparse-3.6.1.tar.gz) = 13043105
+SHA256 (SuiteSparse-4.0.2.tar.gz) = 93b5928987fe010808b3fdff3e7edef42fb2d8cfd65b09dd6d4c41756acb0050
+SIZE (SuiteSparse-4.0.2.tar.gz) = 22421100
diff --git a/math/suitesparse/files/patch-SPQR+Source+spqr_factorize.cpp b/math/suitesparse/files/patch-SPQR+Source+spqr_factorize.cpp
deleted file mode 100644
index 6a16bdf4d3d4..000000000000
--- a/math/suitesparse/files/patch-SPQR+Source+spqr_factorize.cpp
+++ /dev/null
@@ -1,10 +0,0 @@
---- SPQR/Source/spqr_factorize.cpp~ 2008-09-22 06:10:37.000000000 +0900
-+++ SPQR/Source/spqr_factorize.cpp 2009-02-16 15:47:49.000000000 +0900
-@@ -31,6 +31,7 @@
- // =============================================================================
-
- #include "spqr.hpp"
-+#include <string>
-
- #define FCHUNK 32 // FUTURE: make a parameter; Householder block size
-
diff --git a/math/suitesparse/files/patch-UFconfig+UFconfig.mk b/math/suitesparse/files/patch-UFconfig+UFconfig.mk
deleted file mode 100644
index c44a170507f9..000000000000
--- a/math/suitesparse/files/patch-UFconfig+UFconfig.mk
+++ /dev/null
@@ -1,28 +0,0 @@
---- UFconfig/UFconfig.mk.orig 2011-07-19 19:43:11.000000000 -0400
-+++ UFconfig/UFconfig.mk 2011-07-19 19:44:13.000000000 -0400
-@@ -237,18 +237,18 @@
-
- # alternatives:
- # CFLAGS = -g -fexceptions \
-- -Wall -W -Wshadow -Wmissing-prototypes -Wstrict-prototypes \
-- -Wredundant-decls -Wnested-externs -Wdisabled-optimization -ansi \
-- -funit-at-a-time
-+# -Wall -W -Wshadow -Wmissing-prototypes -Wstrict-prototypes \
-+# -Wredundant-decls -Wnested-externs -Wdisabled-optimization -ansi \
-+# -funit-at-a-time
- # CFLAGS = -O3 -fexceptions \
-- -Wall -W -Werror -Wshadow -Wmissing-prototypes -Wstrict-prototypes \
-- -Wredundant-decls -Wnested-externs -Wdisabled-optimization -ansi
-+# -Wall -W -Werror -Wshadow -Wmissing-prototypes -Wstrict-prototypes \
-+# -Wredundant-decls -Wnested-externs -Wdisabled-optimization -ansi
- # CFLAGS = -O3 -fexceptions -D_FILE_OFFSET_BITS=64 -D_LARGEFILE64_SOURCE
- # CFLAGS = -O3
- # CFLAGS = -O3 -g -fexceptions
- # CFLAGS = -g -fexceptions \
-- -Wall -W -Wshadow \
-- -Wredundant-decls -Wdisabled-optimization -ansi
-+# -Wall -W -Wshadow \
-+# -Wredundant-decls -Wdisabled-optimization -ansi
-
- # consider:
- # -fforce-addr -fmove-all-movables -freduce-all-givs -ftsp-ordering
diff --git a/math/suitesparse/pkg-plist b/math/suitesparse/pkg-plist
index e5121c38c2d8..77e9bc57ff54 100644
--- a/math/suitesparse/pkg-plist
+++ b/math/suitesparse/pkg-plist
@@ -1,7 +1,6 @@
include/suitesparse/SuiteSparseQR.hpp
include/suitesparse/SuiteSparseQR_C.h
include/suitesparse/SuiteSparseQR_definitions.h
-include/suitesparse/UFconfig.h
include/suitesparse/amd.h
include/suitesparse/amd_internal.h
include/suitesparse/btf.h
@@ -103,9 +102,9 @@ lib/librbio.so.1
lib/libspqr.a
lib/libspqr.so
lib/libspqr.so.1
-lib/libufconfig.a
-lib/libufconfig.so
-lib/libufconfig.so.1
+lib/libsuitesparseconfig.a
+lib/libsuitesparseconfig.so
+lib/libsuitesparseconfig.so.1
lib/libumfpack.a
lib/libumfpack.so
lib/libumfpack.so.1