aboutsummaryrefslogtreecommitdiff
path: root/math
diff options
context:
space:
mode:
authorMark Linimon <linimon@FreeBSD.org>2007-09-08 01:12:10 +0000
committerMark Linimon <linimon@FreeBSD.org>2007-09-08 01:12:10 +0000
commit9839011ec3910790376ce9ace5e2a1c5bcb2781f (patch)
tree41c61966bf1404bd3cfce06493a35d6a1a4acfc6 /math
parent41a56135d1e8a68844e4c575702cdbad451d7322 (diff)
downloadports-9839011ec3910790376ce9ace5e2a1c5bcb2781f.tar.gz
ports-9839011ec3910790376ce9ace5e2a1c5bcb2781f.zip
Welcome bsd.perl.mk. Add support for constructs such as USE_PERL5=5.8.0+.
Drop support for antique perl. Work done by: gabor Sponsored by: Google Summer of Code 2007 Hat: portmgr
Notes
Notes: svn path=/head/; revision=199069
Diffstat (limited to 'math')
-rw-r--r--math/PDL/Makefile4
-rw-r--r--math/p5-AI-DecisionTree/Makefile8
-rw-r--r--math/p5-Algorithm-Combinatorics/Makefile8
-rw-r--r--math/p5-Algorithm-CurveFit/Makefile8
-rw-r--r--math/p5-Bit-Vector-Minimal/Makefile8
-rw-r--r--math/p5-CAD-Calc/Makefile8
-rw-r--r--math/p5-Data-Float/Makefile8
-rw-r--r--math/p5-GIS-Distance/Makefile8
-rw-r--r--math/p5-Geo-Distance/Makefile9
-rw-r--r--math/p5-Graph/Makefile8
-rw-r--r--math/p5-Math-Algebra-Symbols/Makefile10
-rw-r--r--math/p5-Math-Base85/Makefile10
-rw-r--r--math/p5-Math-Bezier-Convert/Makefile8
-rw-r--r--math/p5-Math-Calc-Units/Makefile10
-rw-r--r--math/p5-Math-Cephes/Makefile8
-rw-r--r--math/p5-Math-Combinatorics/Makefile8
-rw-r--r--math/p5-Math-ConvexHull/Makefile8
-rw-r--r--math/p5-Math-Geometry-Planar-GPC/Makefile8
-rw-r--r--math/p5-Math-Geometry-Planar-Offset/Makefile8
-rw-r--r--math/p5-Math-Geometry-Planar/Makefile8
-rw-r--r--math/p5-Math-Intersection-StraightLine/Makefile8
-rw-r--r--math/p5-Math-Random-MT-Auto/Makefile6
-rw-r--r--math/p5-Math-Random-OO/Makefile8
-rw-r--r--math/p5-Math-RandomOrg/Makefile8
-rw-r--r--math/p5-Math-Round-Var/Makefile8
-rw-r--r--math/p5-Math-Sequence/Makefile8
-rw-r--r--math/p5-Math-Symbolic-Custom-CCompiler/Makefile8
-rw-r--r--math/p5-Math-Symbolic-Custom-Contains/Makefile8
-rw-r--r--math/p5-Math-Symbolic-Custom-ErrorPropagation/Makefile8
-rw-r--r--math/p5-Math-Symbolic-Custom-LaTeXDumper/Makefile8
-rw-r--r--math/p5-Math-Symbolic-Custom-Pattern/Makefile8
-rw-r--r--math/p5-Math-Symbolic-Custom-Simplification/Makefile8
-rw-r--r--math/p5-Math-Symbolic-Custom-Transformation/Makefile8
-rw-r--r--math/p5-Math-Symbolic/Makefile8
-rw-r--r--math/p5-Math-SymbolicX-BigNum/Makefile8
-rw-r--r--math/p5-Math-SymbolicX-Complex/Makefile8
-rw-r--r--math/p5-Math-SymbolicX-Error/Makefile8
-rw-r--r--math/p5-Math-SymbolicX-Inline/Makefile8
-rw-r--r--math/p5-Math-SymbolicX-NoSimplification/Makefile8
-rw-r--r--math/p5-Math-SymbolicX-ParserExtensionFactory/Makefile8
-rw-r--r--math/p5-Math-SymbolicX-Statistics-Distributions/Makefile8
-rw-r--r--math/p5-Math-Vec/Makefile8
-rw-r--r--math/p5-Number-WithError-LaTeX/Makefile10
-rw-r--r--math/p5-Number-WithError/Makefile8
-rw-r--r--math/p5-Set-Partition/Makefile8
-rw-r--r--math/p5-Statistics-Contingency/Makefile8
-rw-r--r--math/p5-Statistics-Descriptive-Discrete/Makefile14
-rw-r--r--math/p5-Task-Math-Symbolic/Makefile8
48 files changed, 49 insertions, 344 deletions
diff --git a/math/PDL/Makefile b/math/PDL/Makefile
index b400740f679f..10e38bb31d66 100644
--- a/math/PDL/Makefile
+++ b/math/PDL/Makefile
@@ -59,10 +59,6 @@ pre-extract:
BROKEN= test script t/flexraw.t fails all 26 tests
.endif
-.if ${PERL_LEVEL} < 500601
-IGNORE= requires perl 5.6.x or later. Install lang/perl5 then try again
-.endif # ${PERL_LEVEL} < 500601
-
post-patch:
@${GREP} -lR "/usr/local/bin/perl" ${WRKSRC} | ${XARGS} \
${PERL} -pi -e "s!/usr/local/bin/perl!${PERL}!"
diff --git a/math/p5-AI-DecisionTree/Makefile b/math/p5-AI-DecisionTree/Makefile
index 05c1976839d5..83fdaa958e78 100644
--- a/math/p5-AI-DecisionTree/Makefile
+++ b/math/p5-AI-DecisionTree/Makefile
@@ -20,10 +20,4 @@ PERL_CONFIGURE= yes
MAN3= AI::DecisionTree.3 \
AI::DecisionTree::Instance.3
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 500601
-IGNORE= This port requires perl 5.6.x or later. Install lang/perl5 then try again
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/math/p5-Algorithm-Combinatorics/Makefile b/math/p5-Algorithm-Combinatorics/Makefile
index cd939f65053d..a81e8657f038 100644
--- a/math/p5-Algorithm-Combinatorics/Makefile
+++ b/math/p5-Algorithm-Combinatorics/Makefile
@@ -23,10 +23,4 @@ MAN3= Algorithm::Combinatorics.3
PERL_CONFIGURE= yes
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 500600
-IGNORE= requires perl 5.6 or above
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/math/p5-Algorithm-CurveFit/Makefile b/math/p5-Algorithm-CurveFit/Makefile
index f13c99c261d1..f02443df2c46 100644
--- a/math/p5-Algorithm-CurveFit/Makefile
+++ b/math/p5-Algorithm-CurveFit/Makefile
@@ -22,10 +22,4 @@ PERL_CONFIGURE= yes
MAN3= Algorithm::CurveFit.3
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 500600 # inherited from math/p5-Math-Symbolic
-IGNORE= requires 5.6.0 or newer. Please install lang/perl5.8 and try again
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/math/p5-Bit-Vector-Minimal/Makefile b/math/p5-Bit-Vector-Minimal/Makefile
index 4f0ef495ae3c..5ea74a043e27 100644
--- a/math/p5-Bit-Vector-Minimal/Makefile
+++ b/math/p5-Bit-Vector-Minimal/Makefile
@@ -19,10 +19,4 @@ PERL_CONFIGURE= yes
MAN3= Bit::Vector::Minimal.3
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 500600
-IGNORE= This port requires perl 5.6 or above.
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/math/p5-CAD-Calc/Makefile b/math/p5-CAD-Calc/Makefile
index 08244a7c7d6a..7f8ee0baeb76 100644
--- a/math/p5-CAD-Calc/Makefile
+++ b/math/p5-CAD-Calc/Makefile
@@ -25,10 +25,4 @@ MAN3= CAD::Calc.3
PERL_MODBUILD= yes
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 500600 # inherited from math/p5-Math-Vec
-IGNORE= requires at least Perl 5.6. Please install lang/perl5.8 and try again
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/math/p5-Data-Float/Makefile b/math/p5-Data-Float/Makefile
index f62a123f7eb4..6ce5eae72c0b 100644
--- a/math/p5-Data-Float/Makefile
+++ b/math/p5-Data-Float/Makefile
@@ -19,10 +19,4 @@ PERL_CONFIGURE= yes
MAN3= Data::Float.3
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 500600
-IGNORE= requires Perl 5.6.0 or newer. Install lang/perl5.8 and try again
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/math/p5-GIS-Distance/Makefile b/math/p5-GIS-Distance/Makefile
index 1813c1f70ab9..6c7ad13a5a92 100644
--- a/math/p5-GIS-Distance/Makefile
+++ b/math/p5-GIS-Distance/Makefile
@@ -25,10 +25,4 @@ MAN3= GIS::Distance.3 GIS::Distance::Cosine.3 \
GIS::Distance::Haversine.3 GIS::Distance::MathTrig.3 \
GIS::Distance::Polar.3 GIS::Distance::Vincenty.3
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 500601 # Inherited from devel/p5-Class-Measure
-IGNORE= requires Perl 5.6.1 or newer. Install lang/perl5.8 and try again
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/math/p5-Geo-Distance/Makefile b/math/p5-Geo-Distance/Makefile
index 0cc907dcd13a..da087022962e 100644
--- a/math/p5-Geo-Distance/Makefile
+++ b/math/p5-Geo-Distance/Makefile
@@ -17,13 +17,6 @@ COMMENT= Calculate Distances and Closest Locations
PERL_CONFIGURE= yes
-.include <bsd.port.pre.mk>
-
-# Module from CPAN written for 5.6 or later
-.if ${PERL_LEVEL} < 500600
-IGNORE= requires perl 5.6.x or later. Install lang/perl5.8 then try again
-.endif
-
MAN3= Geo::Distance.3
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/math/p5-Graph/Makefile b/math/p5-Graph/Makefile
index 5be6d9b862e0..1609be52d97d 100644
--- a/math/p5-Graph/Makefile
+++ b/math/p5-Graph/Makefile
@@ -37,10 +37,4 @@ MAN3= Graph.3 \
Graph::Undirected.3 \
Graph::UnionFind.3
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 500601
-IGNORE= requires perl 5.6.1 or later. Install lang/perl5.8 and try again
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/math/p5-Math-Algebra-Symbols/Makefile b/math/p5-Math-Algebra-Symbols/Makefile
index 800df81c63bd..1c988b4b2f38 100644
--- a/math/p5-Math-Algebra-Symbols/Makefile
+++ b/math/p5-Math-Algebra-Symbols/Makefile
@@ -23,12 +23,6 @@ MAN3= Math::Algebra::Symbols.3 \
Math::Algebra::Symbols::Symbols.3 \
Math::Algebra::Symbols::Term.3
-PERL_CONFIGURE= yes
+PERL_CONFIGURE= 5.8.0+
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 500800
-IGNORE= currently requires Perl 5.8. Please install lang/perl5.8 and try again
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/math/p5-Math-Base85/Makefile b/math/p5-Math-Base85/Makefile
index 2c098814f8db..3fe84b92698d 100644
--- a/math/p5-Math-Base85/Makefile
+++ b/math/p5-Math-Base85/Makefile
@@ -19,12 +19,4 @@ PERL_CONFIGURE= yes
MAN3= Math::Base85.3
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 500601
-post-patch:
- @${PERL} -pi -e 's/use Math::Big/#$$&/;' \
- -e 's|^use constant\s*(.*?)\s*=>.s*(.*)$$|sub $$1 { $$2 }|' ${WRKSRC}/Base85.pm
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/math/p5-Math-Bezier-Convert/Makefile b/math/p5-Math-Bezier-Convert/Makefile
index 0ed20fc62d63..b05951095742 100644
--- a/math/p5-Math-Bezier-Convert/Makefile
+++ b/math/p5-Math-Bezier-Convert/Makefile
@@ -25,10 +25,4 @@ post-patch:
post-configure:
@${PERL} -pi -e 's/^(POD2MAN_EXE.*)$$/\1 --lax/;' ${WRKSRC}/Makefile
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 500600
-IGNORE= requires perl 5.6.x or later. Install lang/perl5.8 then try again
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/math/p5-Math-Calc-Units/Makefile b/math/p5-Math-Calc-Units/Makefile
index 0e9928bb5203..be4a8fc58eac 100644
--- a/math/p5-Math-Calc-Units/Makefile
+++ b/math/p5-Math-Calc-Units/Makefile
@@ -19,12 +19,4 @@ PERL_CONFIGURE= yes
MAN3= Math::Calc::Units.3
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 500600
-BUILD_DEPENDS+= ${SITE_PERL}/Test/More.pm:${PORTSDIR}/devel/p5-Test-Simple
-post-patch:
- ${PERL} -pi -e 's/ our / my /' ${WRKSRC}/Units/Convert/Base.pm
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/math/p5-Math-Cephes/Makefile b/math/p5-Math-Cephes/Makefile
index ef88d594a5c8..24c3bd5a7cf4 100644
--- a/math/p5-Math-Cephes/Makefile
+++ b/math/p5-Math-Cephes/Makefile
@@ -24,10 +24,4 @@ MAN3= Math::Cephes.3 \
PERL_CONFIGURE= yes
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 500600
-IGNORE= requires at least Perl 5.6.0. Please install lang/perl5.8 and try again
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/math/p5-Math-Combinatorics/Makefile b/math/p5-Math-Combinatorics/Makefile
index 025183fd5106..5567fe019894 100644
--- a/math/p5-Math-Combinatorics/Makefile
+++ b/math/p5-Math-Combinatorics/Makefile
@@ -19,10 +19,4 @@ MAN3= Math::Combinatorics.3
PERL_CONFIGURE= yes
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 500600
-IGNORE= requires Perl 5.6 or greater. Please install lang/perl58 and try again
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/math/p5-Math-ConvexHull/Makefile b/math/p5-Math-ConvexHull/Makefile
index 91d87f1365d6..9cfce69920ed 100644
--- a/math/p5-Math-ConvexHull/Makefile
+++ b/math/p5-Math-ConvexHull/Makefile
@@ -19,10 +19,4 @@ PERL_CONFIGURE= yes
MAN3= Math::ConvexHull.3
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 500600
-IGNORE= requires perl 5.6.0 or later. Install lang/perl5.8 and try again
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/math/p5-Math-Geometry-Planar-GPC/Makefile b/math/p5-Math-Geometry-Planar-GPC/Makefile
index 5f0ad77c0698..6e13b11080c8 100644
--- a/math/p5-Math-Geometry-Planar-GPC/Makefile
+++ b/math/p5-Math-Geometry-Planar-GPC/Makefile
@@ -19,10 +19,4 @@ MAN3= Math::Geometry::Planar::GPC.3
PERL_CONFIGURE= yes
-.include <bsd.port.pre.mk>
-
-#.if ${PERL_LEVEL} < 500600
-#IGNORE= requires at least Perl 5.6. Please install lang/perl5.8 and try again
-#.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/math/p5-Math-Geometry-Planar-Offset/Makefile b/math/p5-Math-Geometry-Planar-Offset/Makefile
index b269e70b3c79..ee8f8cf55134 100644
--- a/math/p5-Math-Geometry-Planar-Offset/Makefile
+++ b/math/p5-Math-Geometry-Planar-Offset/Makefile
@@ -19,10 +19,4 @@ MAN3= Math::Geometry::Planar::Offset.3
PERL_MODBUILD= yes
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 500600
-IGNORE= requires at least Perl 5.6. Please install lang/perl5.8 and try again
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/math/p5-Math-Geometry-Planar/Makefile b/math/p5-Math-Geometry-Planar/Makefile
index db11b38e03ed..ff0fabe556a3 100644
--- a/math/p5-Math-Geometry-Planar/Makefile
+++ b/math/p5-Math-Geometry-Planar/Makefile
@@ -23,10 +23,4 @@ MAN3= Math::Geometry::Planar.3
PERL_CONFIGURE= yes
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 500600
-IGNORE= requires at least Perl 5.6. Please install lang/perl5.8 and try again
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/math/p5-Math-Intersection-StraightLine/Makefile b/math/p5-Math-Intersection-StraightLine/Makefile
index 777872960732..ea9155b2c22b 100644
--- a/math/p5-Math-Intersection-StraightLine/Makefile
+++ b/math/p5-Math-Intersection-StraightLine/Makefile
@@ -19,10 +19,4 @@ MAN3= Math::Intersection::StraightLine.3
PERL_CONFIGURE= yes
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 500600
-IGNORE= requires at least Perl5.6
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/math/p5-Math-Random-MT-Auto/Makefile b/math/p5-Math-Random-MT-Auto/Makefile
index dbaba38ca4f2..6a33f9c2e826 100644
--- a/math/p5-Math-Random-MT-Auto/Makefile
+++ b/math/p5-Math-Random-MT-Auto/Makefile
@@ -18,16 +18,12 @@ COMMENT= Auto-seeded Mersenne Twister PRNGs
RUN_DEPENDS= ${SITE_PERL}/Object/InsideOut.pm:${PORTSDIR}/devel/p5-Object-InsideOut \
p5-Exception-Class>=1.22:${PORTSDIR}/devel/p5-Exception-Class
-PERL_CONFIGURE= yes
+PERL_CONFIGURE= 5.8.0+ # Inherited from p5-Object-InsideOut
MAN3= Math::Random::MT::Auto.3 Math::Random::MT::Auto::Range.3
.include <bsd.port.pre.mk>
-.if ${PERL_LEVEL} < 500800 # Inherited from p5-Object-InsideOut
-IGNORE= requires perl 5.8 or later. Install lang/perl5.8 and try again
-.endif
-
.if ${PERL_LEVEL} < 500808
RUN_DEPENDS+= p5-Scalar-List-Utils>=1.18:${PORTSDIR}/lang/p5-Scalar-List-Utils
.endif
diff --git a/math/p5-Math-Random-OO/Makefile b/math/p5-Math-Random-OO/Makefile
index 0cee135121ba..919330d886d5 100644
--- a/math/p5-Math-Random-OO/Makefile
+++ b/math/p5-Math-Random-OO/Makefile
@@ -28,10 +28,4 @@ MAN3= Math::Random::OO.3 \
Math::Random::OO::Uniform.3 \
Math::Random::OO::UniformInt.3
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 500600
-IGNORE= requires perl 5.6 or later. Please install lang/perl5.8 and try again
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/math/p5-Math-RandomOrg/Makefile b/math/p5-Math-RandomOrg/Makefile
index 9c1330168a01..cf3f8db4aec5 100644
--- a/math/p5-Math-RandomOrg/Makefile
+++ b/math/p5-Math-RandomOrg/Makefile
@@ -23,10 +23,4 @@ MAN3= Math::RandomOrg.3
PERL_CONFIGURE= yes
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 500600
-IGNORE= requires at least Perl 5.6 due to dependencies. Please install lang/perl5.8 and try again
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/math/p5-Math-Round-Var/Makefile b/math/p5-Math-Round-Var/Makefile
index 01d67703f7cf..e7daca3b874f 100644
--- a/math/p5-Math-Round-Var/Makefile
+++ b/math/p5-Math-Round-Var/Makefile
@@ -19,10 +19,4 @@ MAN3= Math::Round::Var.3
PERL_MODBUILD= yes
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 500600
-IGNORE= requires at least Perl 5.6. Please install lang/perl5.8 and try again
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/math/p5-Math-Sequence/Makefile b/math/p5-Math-Sequence/Makefile
index ea71f5028d67..c1becbf1ab57 100644
--- a/math/p5-Math-Sequence/Makefile
+++ b/math/p5-Math-Sequence/Makefile
@@ -22,10 +22,4 @@ MAN3= Math::Sequence.3
PERL_CONFIGURE= yes
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 500600
-IGNORE= requires at least Perl 5.6 due to dependencies. Please install lang/perl5.8 and try again
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/math/p5-Math-Symbolic-Custom-CCompiler/Makefile b/math/p5-Math-Symbolic-Custom-CCompiler/Makefile
index d85671fcb804..cc0e85ada142 100644
--- a/math/p5-Math-Symbolic-Custom-CCompiler/Makefile
+++ b/math/p5-Math-Symbolic-Custom-CCompiler/Makefile
@@ -23,10 +23,4 @@ MAN3= Math::Symbolic::Custom::CCompiler.3
PERL_CONFIGURE= yes
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 500600
-IGNORE= requires at least Perl 5.6 due to dependencies. Please install lang/perl5.8 and try again
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/math/p5-Math-Symbolic-Custom-Contains/Makefile b/math/p5-Math-Symbolic-Custom-Contains/Makefile
index 842d281f130b..9dada5db6d9c 100644
--- a/math/p5-Math-Symbolic-Custom-Contains/Makefile
+++ b/math/p5-Math-Symbolic-Custom-Contains/Makefile
@@ -23,10 +23,4 @@ MAN3= Math::Symbolic::Custom::Contains.3
PERL_MODBUILD= yes
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 500600
-IGNORE= requires at least Perl 5.6 due to dependencies. Please install lang/perl5.8 and try again
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/math/p5-Math-Symbolic-Custom-ErrorPropagation/Makefile b/math/p5-Math-Symbolic-Custom-ErrorPropagation/Makefile
index 28f8a0bf206f..7161c1f7df9e 100644
--- a/math/p5-Math-Symbolic-Custom-ErrorPropagation/Makefile
+++ b/math/p5-Math-Symbolic-Custom-ErrorPropagation/Makefile
@@ -22,10 +22,4 @@ MAN3= Math::Symbolic::Custom::ErrorPropagation.3
PERL_CONFIGURE= yes
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 500600
-IGNORE= requires at least Perl 5.6 due to dependencies. Please install lang/perl5.8 and try again
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/math/p5-Math-Symbolic-Custom-LaTeXDumper/Makefile b/math/p5-Math-Symbolic-Custom-LaTeXDumper/Makefile
index 7a4677519b61..575bd1db82a0 100644
--- a/math/p5-Math-Symbolic-Custom-LaTeXDumper/Makefile
+++ b/math/p5-Math-Symbolic-Custom-LaTeXDumper/Makefile
@@ -22,10 +22,4 @@ MAN3= Math::Symbolic::Custom::LaTeXDumper.3
PERL_CONFIGURE= yes
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 500600
-IGNORE= requires at least Perl 5.6 due to dependencies. Please install lang/perl5.8 and try again
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/math/p5-Math-Symbolic-Custom-Pattern/Makefile b/math/p5-Math-Symbolic-Custom-Pattern/Makefile
index e67ac236172d..d4eba0bd0100 100644
--- a/math/p5-Math-Symbolic-Custom-Pattern/Makefile
+++ b/math/p5-Math-Symbolic-Custom-Pattern/Makefile
@@ -24,10 +24,4 @@ MAN3= Math::Symbolic::Custom::Pattern.3 \
PERL_CONFIGURE= yes
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 500600
-IGNORE= requires at least Perl 5.6 due to dependencies. Please install lang/perl5.8 and try again
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/math/p5-Math-Symbolic-Custom-Simplification/Makefile b/math/p5-Math-Symbolic-Custom-Simplification/Makefile
index 5b7bfdeb5b01..a0764f03161c 100644
--- a/math/p5-Math-Symbolic-Custom-Simplification/Makefile
+++ b/math/p5-Math-Symbolic-Custom-Simplification/Makefile
@@ -22,10 +22,4 @@ MAN3= Math::Symbolic::Custom::Simplification.3
PERL_CONFIGURE= yes
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 500600
-IGNORE= requires at least Perl 5.6 due to dependencies. Please install lang/perl5.8 and try again
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/math/p5-Math-Symbolic-Custom-Transformation/Makefile b/math/p5-Math-Symbolic-Custom-Transformation/Makefile
index e00daba33a20..962e42489a5b 100644
--- a/math/p5-Math-Symbolic-Custom-Transformation/Makefile
+++ b/math/p5-Math-Symbolic-Custom-Transformation/Makefile
@@ -24,10 +24,4 @@ MAN3= Math::Symbolic::Custom::Transformation.3 \
PERL_CONFIGURE= yes
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 500600
-IGNORE= requires at least Perl 5.6 due to dependencies. Please install lang/perl5.8 and try again
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/math/p5-Math-Symbolic/Makefile b/math/p5-Math-Symbolic/Makefile
index ba28e4e6cdf9..2d723fe18c8e 100644
--- a/math/p5-Math-Symbolic/Makefile
+++ b/math/p5-Math-Symbolic/Makefile
@@ -43,10 +43,4 @@ MAN3= Math::Symbolic.3 \
PERL_CONFIGURE= yes
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 500600
-IGNORE= requires at least Perl 5.6 due to dependencies. Please install lang/perl5.8 and try again
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/math/p5-Math-SymbolicX-BigNum/Makefile b/math/p5-Math-SymbolicX-BigNum/Makefile
index 35e6c746427a..fc6707dcf32c 100644
--- a/math/p5-Math-SymbolicX-BigNum/Makefile
+++ b/math/p5-Math-SymbolicX-BigNum/Makefile
@@ -23,10 +23,4 @@ MAN3= Math::SymbolicX::BigNum.3
PERL_CONFIGURE= yes
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 500600
-IGNORE= requires at least Perl 5.6 due to dependencies. Please install lang/perl5.8 and try again
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/math/p5-Math-SymbolicX-Complex/Makefile b/math/p5-Math-SymbolicX-Complex/Makefile
index a700087981a1..ae37f2a27aa4 100644
--- a/math/p5-Math-SymbolicX-Complex/Makefile
+++ b/math/p5-Math-SymbolicX-Complex/Makefile
@@ -23,10 +23,4 @@ MAN3= Math::SymbolicX::Complex.3
PERL_CONFIGURE= yes
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 500600
-IGNORE= requires at least Perl 5.6 due to dependencies. Please install lang/perl5.8 and try again
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/math/p5-Math-SymbolicX-Error/Makefile b/math/p5-Math-SymbolicX-Error/Makefile
index c33a82b26545..c593d146ba40 100644
--- a/math/p5-Math-SymbolicX-Error/Makefile
+++ b/math/p5-Math-SymbolicX-Error/Makefile
@@ -24,10 +24,4 @@ MAN3= Math::SymbolicX::Error.3
PERL_CONFIGURE= yes
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 500600
-IGNORE= requires at least Perl 5.6 due to dependencies. Please install lang/perl5.8 and try again
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/math/p5-Math-SymbolicX-Inline/Makefile b/math/p5-Math-SymbolicX-Inline/Makefile
index 9b6086ca33f6..4e3b86533500 100644
--- a/math/p5-Math-SymbolicX-Inline/Makefile
+++ b/math/p5-Math-SymbolicX-Inline/Makefile
@@ -23,10 +23,4 @@ MAN3= Math::SymbolicX::Inline.3
PERL_CONFIGURE= yes
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 500600
-IGNORE= requires at least Perl 5.6 due to dependencies. Please install lang/perl5.8 and try again
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/math/p5-Math-SymbolicX-NoSimplification/Makefile b/math/p5-Math-SymbolicX-NoSimplification/Makefile
index b48902e8ad45..b1dae024a5c1 100644
--- a/math/p5-Math-SymbolicX-NoSimplification/Makefile
+++ b/math/p5-Math-SymbolicX-NoSimplification/Makefile
@@ -22,10 +22,4 @@ MAN3= Math::SymbolicX::NoSimplification.3
PERL_CONFIGURE= yes
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 500600
-IGNORE= requires at least Perl 5.6 due to dependencies. Please install lang/perl5.8 and try again
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/math/p5-Math-SymbolicX-ParserExtensionFactory/Makefile b/math/p5-Math-SymbolicX-ParserExtensionFactory/Makefile
index 19257a79ea14..56a1e14f1447 100644
--- a/math/p5-Math-SymbolicX-ParserExtensionFactory/Makefile
+++ b/math/p5-Math-SymbolicX-ParserExtensionFactory/Makefile
@@ -22,10 +22,4 @@ MAN3= Math::SymbolicX::ParserExtensionFactory.3
PERL_CONFIGURE= yes
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 500600
-IGNORE= requires at least Perl 5.6 due to dependencies. Please install lang/perl5.8 and try again
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/math/p5-Math-SymbolicX-Statistics-Distributions/Makefile b/math/p5-Math-SymbolicX-Statistics-Distributions/Makefile
index a369e22f1599..266dfc313029 100644
--- a/math/p5-Math-SymbolicX-Statistics-Distributions/Makefile
+++ b/math/p5-Math-SymbolicX-Statistics-Distributions/Makefile
@@ -23,10 +23,4 @@ MAN3= Math::SymbolicX::Statistics::Distributions.3
PERL_CONFIGURE= yes
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 500600
-IGNORE= requires at least Perl 5.6 due to dependencies. Please install lang/perl5.8 and try again
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/math/p5-Math-Vec/Makefile b/math/p5-Math-Vec/Makefile
index cff09ef45129..864a8c0bd2e6 100644
--- a/math/p5-Math-Vec/Makefile
+++ b/math/p5-Math-Vec/Makefile
@@ -21,10 +21,4 @@ BUILD_DEPENDS= ${SITE_PERL}/Test/More.pm:${PORTSDIR}/devel/p5-Test-Simple
PERL_MODBUILD= yes
MAN3= Math::Vec.3
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 500600
-IGNORE= requires perl 5.6.0 or later. Install lang/perl5.8 and try again
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/math/p5-Number-WithError-LaTeX/Makefile b/math/p5-Number-WithError-LaTeX/Makefile
index ed37863c5915..85fd4e418d81 100644
--- a/math/p5-Number-WithError-LaTeX/Makefile
+++ b/math/p5-Number-WithError-LaTeX/Makefile
@@ -24,12 +24,6 @@ RUN_DEPENDS= ${BUILD_DEPENDS}
MAN3= Number::WithError::LaTeX.3
-PERL_CONFIGURE= yes
+PERL_CONFIGURE= 5.8.0+
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 500800
-IGNORE= requires at least Perl 5.8 due to dependencies. Please install lang/perl5.8 and try again
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/math/p5-Number-WithError/Makefile b/math/p5-Number-WithError/Makefile
index bc3c19b29d13..e0ba9b9fe33b 100644
--- a/math/p5-Number-WithError/Makefile
+++ b/math/p5-Number-WithError/Makefile
@@ -24,10 +24,4 @@ MAN3= Number::WithError.3
PERL_CONFIGURE= yes
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 500600
-IGNORE= requires at least Perl 5.6 due to dependencies. Please install lang/perl5.8 and try again
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/math/p5-Set-Partition/Makefile b/math/p5-Set-Partition/Makefile
index e5bcbb662fc0..20103cdb3db5 100644
--- a/math/p5-Set-Partition/Makefile
+++ b/math/p5-Set-Partition/Makefile
@@ -19,10 +19,4 @@ MAN3= Set::Partition.3
PERL_CONFIGURE= yes
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 500600
-IGNORE= requires at least Perl 5.6. Please install lang/perl5.8 and try again
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/math/p5-Statistics-Contingency/Makefile b/math/p5-Statistics-Contingency/Makefile
index ed2f74cbe0f2..826b3c901e73 100644
--- a/math/p5-Statistics-Contingency/Makefile
+++ b/math/p5-Statistics-Contingency/Makefile
@@ -22,10 +22,4 @@ PERL_CONFIGURE= yes
MAN3= Statistics::Contingency.3
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 500601
-IGNORE= This port will require perl 5.6.x or later in the future. Install lang/perl5 then try again
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/math/p5-Statistics-Descriptive-Discrete/Makefile b/math/p5-Statistics-Descriptive-Discrete/Makefile
index 6456d9e0d313..8ef2d0101e39 100644
--- a/math/p5-Statistics-Descriptive-Discrete/Makefile
+++ b/math/p5-Statistics-Descriptive-Discrete/Makefile
@@ -19,16 +19,4 @@ MAN3= Statistics::Descriptive::Discrete.3
PERL_CONFIGURE= yes
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 500600
-#IGNORE= requires at least Perl 5.6. Please install lang/perl5.8 and try again
-#post-patch:
-# @${PERL} -pi -e 's/our ([^ ]+)/use vars qw($$1); $$1/g;' \
-# -e '$$_ = "" if /use warnings/;' \
-# ${WRKSRC}/lib/GraphViz/Traverse.pm \
-# ${WRKSRC}/t/*.t \
-# ${WRKSRC}/Makefile.PL
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/math/p5-Task-Math-Symbolic/Makefile b/math/p5-Task-Math-Symbolic/Makefile
index 425baa0652c9..856dea4dc334 100644
--- a/math/p5-Task-Math-Symbolic/Makefile
+++ b/math/p5-Task-Math-Symbolic/Makefile
@@ -37,10 +37,4 @@ PERL_CONFIGURE= yes
MAN3= Task::Math::Symbolic.3
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 500600
-IGNORE= requires Perl 5.6. Install lang/perl5, and try again
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>