aboutsummaryrefslogtreecommitdiff
path: root/math
diff options
context:
space:
mode:
authorMax Brazhnikov <makc@FreeBSD.org>2013-03-22 20:06:14 +0000
committerMax Brazhnikov <makc@FreeBSD.org>2013-03-22 20:06:14 +0000
commitffd97a0193e0238aa21bc32b570fd052292e0fe5 (patch)
treeb368198f913179c06dafd19ac72527fcf9836f6d /math
parentccbdf54cacb9796580726f8d5278fe3fa53d5e53 (diff)
downloadports-ffd97a0193e0238aa21bc32b570fd052292e0fe5.tar.gz
ports-ffd97a0193e0238aa21bc32b570fd052292e0fe5.zip
- convert USE_CMAKE to USES
- while here clean up some ports from CMAKE_VERBOSE, which is intended for users Approved by: portmgr (miwi)
Notes
Notes: svn path=/head/; revision=314960
Diffstat (limited to 'math')
-rw-r--r--math/abakus/Makefile3
-rw-r--r--math/carve/Makefile3
-rw-r--r--math/cgal/Makefile2
-rw-r--r--math/clipper/Makefile2
-rw-r--r--math/eigen2/Makefile2
-rw-r--r--math/eigen3/Makefile3
-rw-r--r--math/fann/Makefile2
-rw-r--r--math/freemat/Makefile2
-rw-r--r--math/labplot/Makefile2
-rw-r--r--math/metis/Makefile2
-rw-r--r--math/parmetis/Makefile2
-rw-r--r--math/plplot/Makefile2
-rw-r--r--math/qhull/Makefile2
-rw-r--r--math/qtoctave/Makefile2
-rw-r--r--math/rkward-kde4/Makefile2
-rw-r--r--math/speedcrunch/Makefile2
-rw-r--r--math/ufc/Makefile2
-rw-r--r--math/vtk5/Makefile3
18 files changed, 18 insertions, 22 deletions
diff --git a/math/abakus/Makefile b/math/abakus/Makefile
index 8435e65996db..9a7cae1a8dc6 100644
--- a/math/abakus/Makefile
+++ b/math/abakus/Makefile
@@ -17,8 +17,7 @@ LIB_DEPENDS= mpfr:${PORTSDIR}/math/mpfr
USE_BZIP2= yes
USE_KDE4= automoc4 kdehier kdelibs kdeprefix
USE_QT4= moc_build qmake_build rcc_build uic_build
-USES= bison
-USE_CMAKE= yes
+USES= bison cmake
CMAKE_ARGS= -DCMAKE_REQUIRED_INCLUDES:STRING="${LOCALBASE}/include" \
-DCMAKE_REQUIRED_FLAGS:STRING="${LDFLAGS}" \
-DFLEX_EXECUTABLE:FILEPATH=${LOCALBASE}/bin/flex
diff --git a/math/carve/Makefile b/math/carve/Makefile
index 54730398a202..4354da09c74d 100644
--- a/math/carve/Makefile
+++ b/math/carve/Makefile
@@ -15,8 +15,7 @@ LIB_DEPENDS= boost_filesystem:${PORTSDIR}/devel/boost-libs
OPTIONS_DEFINE= GUI
-USE_CMAKE= yes
-CMAKE_OUTSOURCE=yes
+USES= cmake:outsource
USE_GL= glut
USE_LDCONFIG= yes
diff --git a/math/cgal/Makefile b/math/cgal/Makefile
index 34f385250c9c..8857838525d3 100644
--- a/math/cgal/Makefile
+++ b/math/cgal/Makefile
@@ -29,7 +29,7 @@ LIB_DEPENDS= GLU.1:${PORTSDIR}/graphics/libGLU \
FETCH_ARGS= -pRr
USE_LDCONFIG= yes
-USE_CMAKE= yes
+USES= cmake
USE_QT4= corelib opengl qmake_build gui moc_build rcc_build
HAS_CONFIGURE= yes
DOCSDIR= ${PREFIX}/share/doc/CGAL-3.4
diff --git a/math/clipper/Makefile b/math/clipper/Makefile
index 8083898fdda9..eb7a7f1b2b4b 100644
--- a/math/clipper/Makefile
+++ b/math/clipper/Makefile
@@ -15,6 +15,6 @@ WRKSRC= ${WRKDIR}/cpp
USE_LDCONFIG= yes
USE_ZIP= yes
-USE_CMAKE= yes
+USES= cmake
.include <bsd.port.mk>
diff --git a/math/eigen2/Makefile b/math/eigen2/Makefile
index 835fd5336673..559351ffb43d 100644
--- a/math/eigen2/Makefile
+++ b/math/eigen2/Makefile
@@ -16,7 +16,7 @@ MAINTAINER= kde@FreeBSD.org
COMMENT= Lightweight library for vector and matrix math
USE_BZIP2= yes
-USE_CMAKE= yes
+USES= cmake
LATEST_LINK= ${PORTNAME}2
diff --git a/math/eigen3/Makefile b/math/eigen3/Makefile
index 2b2816c97215..99287581cf46 100644
--- a/math/eigen3/Makefile
+++ b/math/eigen3/Makefile
@@ -14,8 +14,7 @@ LICENSE= LGPL21 MPL
LICENSE_COMB= multi
USE_BZIP2= yes
-USE_CMAKE= yes
-CMAKE_OUTSOURCE=yes
+USES= cmake:outsource
CMAKE_ENV+= PKG_CONFIG_LIBDIR="${PREFIX}/libdata"
NO_BUILD= yes
diff --git a/math/fann/Makefile b/math/fann/Makefile
index 46b9efb0c272..a7911c43f9af 100644
--- a/math/fann/Makefile
+++ b/math/fann/Makefile
@@ -12,7 +12,7 @@ COMMENT= Free open source neural network library
WRKSRC= ${WRKDIR}/FANN-2.2.0-Source
-USE_CMAKE= yes
+USES= cmake
USE_ZIP= yes
USE_LDCONFIG= yes
diff --git a/math/freemat/Makefile b/math/freemat/Makefile
index e7ba6f0c6677..134c01580079 100644
--- a/math/freemat/Makefile
+++ b/math/freemat/Makefile
@@ -35,7 +35,7 @@ FFLAGS+= -O2
USE_GL= yes
USE_PKGCONFIG= yes
-USE_CMAKE= yes
+USES= cmake
USE_QT4= gui network opengl moc_build rcc_build uic_build \
qmake_build xml svg
CPPFLAGS+= ${CXXFLAGS} -I${LOCALBASE}/include ${AMDINC}
diff --git a/math/labplot/Makefile b/math/labplot/Makefile
index 9337233fb434..a2f52bff7a25 100644
--- a/math/labplot/Makefile
+++ b/math/labplot/Makefile
@@ -22,7 +22,7 @@ USE_BZIP2= yes
USE_XORG= xft xpm
USE_KDE4= automoc4 kdelibs kdeprefix
USE_QT4= moc_build qmake_build rcc_build uic_build
-USE_CMAKE= yes
+USES= cmake
CMAKE_ARGS= -DOPJ_LIBRARY:STRING=""
MAKE_JOBS_SAFE= yes
diff --git a/math/metis/Makefile b/math/metis/Makefile
index 034006aca188..4bb9732d31ca 100644
--- a/math/metis/Makefile
+++ b/math/metis/Makefile
@@ -13,7 +13,7 @@ LICENSE= AL2
CONFLICTS= metis-4* metis-edf-[0-9]*
-USE_CMAKE= yes
+USES= cmake
OPTIONS_DEFINE = OPENMP SHARED STATIC
diff --git a/math/parmetis/Makefile b/math/parmetis/Makefile
index b342345827ea..b959e00c8e90 100644
--- a/math/parmetis/Makefile
+++ b/math/parmetis/Makefile
@@ -20,7 +20,7 @@ LICENSE_PERMS= auto-accept
OPTIONS_DEFINE= OPENMPI DOCS
OPENMPI_DESC= Use openmpi instead of mpich2
-USE_CMAKE= yes
+USES= cmake
USE_GMAKE= yes
PORTDOCS= manual.pdf
diff --git a/math/plplot/Makefile b/math/plplot/Makefile
index 8f6fd85f0c29..bf756e00cff0 100644
--- a/math/plplot/Makefile
+++ b/math/plplot/Makefile
@@ -26,7 +26,7 @@ OPTIONS_DEFAULT= THREADS X11
USE_GNOME= pango
USE_PERL5_BUILD=yes
USE_GHOSTSCRIPT=yes
-USE_CMAKE= yes
+USES= cmake
CMAKE_ARGS= -DENABLE_java:BOOL=OFF -DENABLE_octave:BOOL=OFF \
-DENABLE_pdl:BOOL=OFF -DENABLE_ada:BOOL=OFF \
-DENABLE_d:BOOL=OFF -DENABLE_ocaml:BOOL=OFF \
diff --git a/math/qhull/Makefile b/math/qhull/Makefile
index 2b20c728bc44..5471a92c15aa 100644
--- a/math/qhull/Makefile
+++ b/math/qhull/Makefile
@@ -11,7 +11,7 @@ EXTRACT_SUFX= .tgz
MAINTAINER= stephen@FreeBSD.org
COMMENT= Qhull computes convex hulls, Delaunay triangulations, and halfspaces
-USE_CMAKE= yes
+USES= cmake
USE_LDCONFIG= yes
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
diff --git a/math/qtoctave/Makefile b/math/qtoctave/Makefile
index e93bd7437311..f6b1090ef292 100644
--- a/math/qtoctave/Makefile
+++ b/math/qtoctave/Makefile
@@ -13,7 +13,7 @@ RUN_DEPENDS= octave:${PORTSDIR}/math/octave
USE_QT4= designer gui network script svg xml \
qmake_build moc_build rcc_build uic_build \
linguist_build
-USE_CMAKE= yes
+USES= cmake
CMAKE_ARGS+= -DWITH_UseRPMTools:Bool=Off
MAKE_JOBS_SAFE= yes
diff --git a/math/rkward-kde4/Makefile b/math/rkward-kde4/Makefile
index d1fdac2a2efa..77b10a650249 100644
--- a/math/rkward-kde4/Makefile
+++ b/math/rkward-kde4/Makefile
@@ -25,7 +25,7 @@ USE_KDE4= kdehier kdeprefix automoc4 kdelibs
USE_PHP= yes
WANT_PHP_CLI= yes
USE_GETTEXT= yes
-USE_CMAKE= yes
+USES= cmake
INSTALLS_ICONS= yes
CFLAGS+= -I${LOCALBASE}/include
diff --git a/math/speedcrunch/Makefile b/math/speedcrunch/Makefile
index b6eee279f036..3604d00a2674 100644
--- a/math/speedcrunch/Makefile
+++ b/math/speedcrunch/Makefile
@@ -15,7 +15,7 @@ MAINTAINER= makc@FreeBSD.org
COMMENT= A desktop calculator for power users
USE_QT4= qmake_build moc_build rcc_build uic_build gui xml
-USE_CMAKE= yes
+USES= cmake
CMAKE_SOURCE_PATH= src
MAKE_JOBS_SAFE= yes
diff --git a/math/ufc/Makefile b/math/ufc/Makefile
index 615eed3a950c..6550cd64242f 100644
--- a/math/ufc/Makefile
+++ b/math/ufc/Makefile
@@ -15,7 +15,7 @@ LIB_DEPENDS= boost_math_c99:${PORTSDIR}/devel/boost-libs
# LICENSE= public domain
-USE_CMAKE= yes
+USES= cmake
USE_PYTHON= -2.7
PYDISTUTILS_PKGNAME= ufc
diff --git a/math/vtk5/Makefile b/math/vtk5/Makefile
index 934916c79493..3a38308648b7 100644
--- a/math/vtk5/Makefile
+++ b/math/vtk5/Makefile
@@ -23,7 +23,7 @@ CONFLICTS= vtk-4*
SUB_FILES= vtk.3
-USE_CMAKE= yes
+USES= cmake:outsource
USE_XORG= xt
USE_LDCONFIG= ${PREFIX}/lib/vtk-${PORTVERSION:R}
CXXFLAGS+= -DUSE_INTERP_ERRORLINE
@@ -47,7 +47,6 @@ PLIST_SUB+= VER1="${PORTVERSION}" \
MAN3= vtk.3
PORTDOCS= README.html
-CMAKE_OUTSOURCE= yes
CMAKE_ARGS+= -DBUILD_DOCUMENTATION:BOOL=ON \
-DBUILD_TESTING:BOOL=OFF \