aboutsummaryrefslogtreecommitdiff
path: root/math
diff options
context:
space:
mode:
authorTijl Coosemans <tijl@FreeBSD.org>2016-03-24 15:47:50 +0000
committerTijl Coosemans <tijl@FreeBSD.org>2016-03-24 15:47:50 +0000
commit77760fcb6307bb10ac6bbf1653f33308bc4ffeb2 (patch)
tree9a9bfdddc0d5bd83f4f805c6db760afc834ef9b7 /math
parentc5d0b8fd869a1e1db110b14b701c70a27d9773bc (diff)
downloadports-77760fcb6307bb10ac6bbf1653f33308bc4ffeb2.tar.gz
ports-77760fcb6307bb10ac6bbf1653f33308bc4ffeb2.zip
Make print/ghostscript9-agpl-base the default Ghostscript port. Upstream
changed the license to the AGPL 3 in version 9.07 so print/ghostscript9-base is stuck at 9.06 which is almost 4 years old now. Fix the logic in Uses/ghostscript.mk so "agpl" is treated as a real version on its own instead of as a variant of other versions. Fix print/ghostscript9-agpl-base to install eps2write. Update math/asymptote to 2.37 to support newer Ghostscript. PR: 208159 Exp-run by: antoine Approved by: portmgr (antoine)
Notes
Notes: svn path=/head/; revision=411798
Diffstat (limited to 'math')
-rw-r--r--math/R/Makefile1
-rw-r--r--math/asymptote/Makefile24
-rw-r--r--math/asymptote/distinfo4
-rw-r--r--math/asymptote/files/patch-Makefile.in23
-rw-r--r--math/asymptote/files/patch-configure.ac16
-rw-r--r--math/asymptote/files/patch-settings.cc12
-rw-r--r--math/asymptote/pkg-plist10
-rw-r--r--math/plplot/Makefile2
8 files changed, 32 insertions, 60 deletions
diff --git a/math/R/Makefile b/math/R/Makefile
index c4ec8faf04f8..b3fb12046aac 100644
--- a/math/R/Makefile
+++ b/math/R/Makefile
@@ -3,6 +3,7 @@
PORTNAME?= R
PORTVERSION= 3.2.2
+PORTREVISION= 1
CATEGORIES= math lang
MASTER_SITES= http://cran.r-project.org/%SUBDIR%/ \
ftp://cran.r-project.org/pub/R/%SUBDIR%/ \
diff --git a/math/asymptote/Makefile b/math/asymptote/Makefile
index 4c38f9ddae69..b81b3a5b67ac 100644
--- a/math/asymptote/Makefile
+++ b/math/asymptote/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= asymptote
-PORTVERSION= 2.32
-PORTREVISION= 5
+PORTVERSION= 2.37
CATEGORIES= math
MASTER_SITES= SF/${PORTNAME}/${PORTVERSION}
DISTNAME= ${PORTNAME}-${PORTVERSION}.src
@@ -14,7 +13,8 @@ COMMENT= Powerful script-based vector graphics language
LICENSE= GPLv3 LGPL3
LICENSE_COMB= dual
-LIB_DEPENDS= libgc-threaded.so:${PORTSDIR}/devel/boehm-gc-threaded
+LIB_DEPENDS= libgc-threaded.so:${PORTSDIR}/devel/boehm-gc-threaded \
+ libsigsegv.so:${PORTSDIR}/devel/libsigsegv
RUN_DEPENDS= animate:${PORTSDIR}/graphics/ImageMagick \
gv:${PORTSDIR}/print/gv \
${PYTHON_PKGNAMEPREFIX}pillow>0:${PORTSDIR}/graphics/py-pillow \
@@ -22,20 +22,19 @@ RUN_DEPENDS= animate:${PORTSDIR}/graphics/ImageMagick \
ALL_TARGET= asy asy-keywords.el
-CONFIGURE_ARGS= --enable-gc
+CONFIGURE_ARGS= --enable-gc=system
CPPFLAGS+= -I${LOCALBASE}/include
GNU_CONFIGURE= yes
INSTALL_TARGET= install-asy
-MAKE_ENV= ${CONFIGURE_ENV} ASYMPTOTE_HOME=${WRKDIR} HOME=${WRKDIR}
+MAKE_ENV= ASYMPTOTE_HOME=${WRKDIR} HOME=${WRKDIR}
MAKE_JOBS_UNSAFE= yes
ONLY_FOR_ARCHS= i386 amd64
-USES= ghostscript gmake perl5 python tar:tgz
-USE_AUTOTOOLS= autoconf aclocal
+USES= gettext-runtime ghostscript gmake ncurses perl5 python tar:tgz
USE_GL= glut
USE_PERL5= build
USE_TEX= dvipsk formats
@@ -64,6 +63,7 @@ OPTIONS_DEFINE= DOCS EXAMPLES FFTW GSL MANPAGES OFFSCREEN READLINE
READLINE_CONFIGURE_ENABLE= readline
READLINE_DESC= ${LIBEDIT_DESC}
+READLINE_USES= readline
.include <bsd.port.options.mk>
@@ -80,15 +80,11 @@ INSTALL_TARGET+= install-man
.endif
post-patch:
- @${REINPLACE_CMD} -e 's,%%LOCALBASE%%,${LOCALBASE},1' -i.bak ${WRKSRC}/settings.cc
-
-run-autotools:
- @(cd ${CONFIGURE_WRKSRC} && \
- ${SETENV} ${AUTOTOOLS_ENV} ${AUTORECONF} --force --install)
+ @${REINPLACE_CMD} 's/-lgc/-lgc-threaded/' ${WRKSRC}/configure
+ @${REINPLACE_CMD} 's,/usr/lib/libgs.so,${LOCALBASE}/lib/libgs.so,' \
+ ${WRKSRC}/settings.cc
post-install:
- @(cd ${STAGEDIR}${PREFIX}/bin && \
- ${LN} -sf ../share/asymptote/GUI/xasy.py xasy)
${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/asy
.include <bsd.port.mk>
diff --git a/math/asymptote/distinfo b/math/asymptote/distinfo
index 593649998a5c..0c28cded5225 100644
--- a/math/asymptote/distinfo
+++ b/math/asymptote/distinfo
@@ -1,2 +1,2 @@
-SHA256 (asymptote-2.32.src.tgz) = 2035035e02774598312d5588da2685d20fb85a378ea2bbe48b825c5442b18fa5
-SIZE (asymptote-2.32.src.tgz) = 1794495
+SHA256 (asymptote-2.37.src.tgz) = 111502a4daf055b517bb7e393af2b70f84f376a28671144751695651aa00d09a
+SIZE (asymptote-2.37.src.tgz) = 3459415
diff --git a/math/asymptote/files/patch-Makefile.in b/math/asymptote/files/patch-Makefile.in
index 938782762d38..1da5ecf5299d 100644
--- a/math/asymptote/files/patch-Makefile.in
+++ b/math/asymptote/files/patch-Makefile.in
@@ -1,14 +1,6 @@
---- ./Makefile.in.orig 2014-05-22 18:11:41.000000000 +0200
-+++ ./Makefile.in 2014-05-27 05:26:25.000000000 +0200
-@@ -53,7 +53,6 @@
- EXEXTRA = piicon.eps *.views *.dat *.bib
- DOCEXTRA = *.asy *.csv *.dat latexusage.tex externalprc.tex pixel.pdf
- KEYWORDS = base $(ASYMPTOTE_SITEDIR)
--LATEXFILES = asymptote.sty asycolors.sty ocg.sty latexmkrc
- CONTEXTFILES = colo-asy.tex
- ASY = ./asy -dir base -config "" -render=0
-
-@@ -84,7 +83,7 @@
+--- Makefile.in.orig 2016-03-14 05:33:18 UTC
++++ Makefile.in
+@@ -88,7 +88,7 @@ datadir = $(DESTDIR)@datadir@
asydir = $(datadir)/asymptote
GUIdir = $(asydir)/GUI
docdir = $(DESTDIR)@docdir@
@@ -17,17 +9,12 @@
animationsdir = $(exampledir)/animations
latexdir = $(DESTDIR)@latexdir@
contextdir = $(DESTDIR)@contextdir@
-@@ -234,13 +233,11 @@
+@@ -238,7 +238,7 @@ install-asy: asy sty
${INSTALL} -p -m 644 base/*.asy $(addprefix base/,$(EXTRA)) \
asy-keywords.el $(asydir)
${INSTALL} -p -m 755 GUI/*.py $(GUIdir)
- ln -sf @datadir@/asymptote/GUI/xasy.py $(bindir)/$(XNAME)
++ ln -sf ../share/asymptote/GUI/xasy.py $(bindir)/$(XNAME)
${INSTALL} -p -m 644 examples/*.asy $(addprefix examples/,$(EXEXTRA)) \
doc/extra/*.asy $(addprefix doc/,$(DOCEXTRA)) $(exampledir)
${INSTALL} -p -m 644 examples/animations/*.asy \
- examples/animations/inlinemovie.tex \
- examples/animations/inlinemovie3.tex $(animationsdir)
-- -${INSTALL} -p -m 644 $(addprefix doc/,$(LATEXFILES)) $(latexdir)
- -${INSTALL} -p -m 644 $(addprefix doc/,$(CONTEXTFILES)) $(contextdir)
-
- install-html: html
diff --git a/math/asymptote/files/patch-configure.ac b/math/asymptote/files/patch-configure.ac
deleted file mode 100644
index 2e2f220721d1..000000000000
--- a/math/asymptote/files/patch-configure.ac
+++ /dev/null
@@ -1,16 +0,0 @@
---- ./configure.ac.orig 2014-05-22 18:12:40.000000000 +0200
-+++ ./configure.ac 2014-05-27 05:26:25.000000000 +0200
-@@ -1,4 +1,3 @@
--# -*- Autoconf -*-
- # Run autoheader and autoconf to produce a header and configure script from
- # this file.
-
-@@ -160,7 +159,7 @@
- CPPFLAGS=$CPPFLAGS" $INCL"
- AC_CHECK_HEADER(gc.h,
- AC_CHECK_LIB([gc],[GC_malloc],[
-- LIBS=$LIBS"-lgc "
-+ LIBS=$LIBS"-lgc-threaded "
- AC_MSG_NOTICE([enabling system $GCNAME])],[
- GCDIR=$GCFILE
- INCL="-I\$(GC)/include"
diff --git a/math/asymptote/files/patch-settings.cc b/math/asymptote/files/patch-settings.cc
index dcb5e22de367..0746f38efa69 100644
--- a/math/asymptote/files/patch-settings.cc
+++ b/math/asymptote/files/patch-settings.cc
@@ -1,6 +1,6 @@
---- ./settings.cc.orig 2014-05-22 18:11:31.000000000 +0200
-+++ ./settings.cc 2014-05-27 05:26:36.000000000 +0200
-@@ -94,10 +94,10 @@
+--- settings.cc.orig 2016-03-14 05:33:18 UTC
++++ settings.cc
+@@ -95,7 +95,7 @@ string defaultPSViewer="gv";
#ifdef __APPLE__
string defaultPDFViewer="open";
#else
@@ -8,8 +8,4 @@
+string defaultPDFViewer="gv";
#endif
string defaultGhostscript="gs";
--string defaultGhostscriptLibrary="/usr/lib/libgs.so";
-+string defaultGhostscriptLibrary="/usr/local/lib/libgs.so";
- string defaultDisplay="display";
- string defaultAnimate="animate";
- void queryRegistry() {}
+ string defaultGhostscriptLibrary="/usr/lib/libgs.so";
diff --git a/math/asymptote/pkg-plist b/math/asymptote/pkg-plist
index 842630f83deb..ec45ed0c1b0b 100644
--- a/math/asymptote/pkg-plist
+++ b/math/asymptote/pkg-plist
@@ -167,6 +167,7 @@ man/man1/xasy.1x.gz
%%DATADIR%%/size11.asy
%%DATADIR%%/slide.asy
%%DATADIR%%/slopefield.asy
+%%DATADIR%%/smoothcontour3.asy
%%DATADIR%%/solids.asy
%%DATADIR%%/stats.asy
%%DATADIR%%/syzygy.asy
@@ -203,6 +204,7 @@ man/man1/xasy.1x.gz
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/1overx.asy
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/BezierPatch.asy
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/BezierSurface.asy
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/BezierTriangle.asy
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/Bode.asy
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/CAD1.asy
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/CDlabel.asy
@@ -323,6 +325,8 @@ man/man1/xasy.1x.gz
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/gamma3.asy
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/generalaxis.asy
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/generalaxis3.asy
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/genusthree.asy
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/genustwo.asy
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/graphmarkers.asy
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/grid.asy
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/grid3xyz.asy
@@ -474,6 +478,7 @@ man/man1/xasy.1x.gz
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/tanh.asy
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/teapot.asy
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/tensor.asy
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/tetra.asy
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/textpath.asy
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/thermodynamics.asy
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/threeviews.asy
@@ -516,4 +521,7 @@ man/man1/xasy.1x.gz
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/xxsq01y.asy
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/yingyang.asy
%%TEXMFLOCALDIR%%/tex/context/third/asymptote/colo-asy.tex
-@dir %%TEXMFLOCALDIR%%/tex/latex/asymptote
+%%TEXMFLOCALDIR%%/tex/latex/asymptote/asycolors.sty
+%%TEXMFLOCALDIR%%/tex/latex/asymptote/asymptote.sty
+%%TEXMFLOCALDIR%%/tex/latex/asymptote/latexmkrc
+%%TEXMFLOCALDIR%%/tex/latex/asymptote/ocg.sty
diff --git a/math/plplot/Makefile b/math/plplot/Makefile
index 2788b4af2a72..4f910f497d48 100644
--- a/math/plplot/Makefile
+++ b/math/plplot/Makefile
@@ -3,7 +3,7 @@
PORTNAME= plplot
PORTVERSION= 5.11.1
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= math science
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTVERSION}%20Source