aboutsummaryrefslogtreecommitdiff
path: root/math
diff options
context:
space:
mode:
authorKevin Lo <kevlo@FreeBSD.org>2007-04-10 11:04:52 +0000
committerKevin Lo <kevlo@FreeBSD.org>2007-04-10 11:04:52 +0000
commitadfb5d153f8e7b175efa7f89513bd69cea90f16f (patch)
tree991bd3ed10ce207a7751b00f70d2b6efb5fad7a3 /math
parent02a5b0bf8a9d2dafe80f2ee71ea58829f9f410e7 (diff)
downloadports-adfb5d153f8e7b175efa7f89513bd69cea90f16f.tar.gz
ports-adfb5d153f8e7b175efa7f89513bd69cea90f16f.zip
Update to 0.8.6
Notes
Notes: svn path=/head/; revision=189664
Diffstat (limited to 'math')
-rw-r--r--math/algotutor/Makefile9
-rw-r--r--math/algotutor/distinfo6
-rw-r--r--math/algotutor/files/patch-algotutor22
-rw-r--r--math/algotutor/pkg-plist3
4 files changed, 21 insertions, 19 deletions
diff --git a/math/algotutor/Makefile b/math/algotutor/Makefile
index 3d0898bdd9ea..f8713d311837 100644
--- a/math/algotutor/Makefile
+++ b/math/algotutor/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= algotutor
-PORTVERSION= 0.8.5
-PORTREVISION= 1
+PORTVERSION= 0.8.6
CATEGORIES= math
MASTER_SITES= http://saturn.stu.edu.tw/~ckhung/dl/
EXTRACT_SUFX= .tgz
@@ -24,9 +23,9 @@ NO_BUILD= yes
MAN1= algotutor.1 gen_at_graph.1
BINFILES= algotutor gen_at_graph
LIBFILES= BST.pm Board.pm Collection.pm Configurable.pm DCEdge.pm \
- Edge.pm Graph.pm Heap.pm PQueue.pm RBTree.pm RecCanvas.pm \
- RecDialog.pm TreeNode.pm Vector.pm Vertex.pm basic.pl \
- utilalgo
+ Edge.pm Graph.pm Heap.pm Line.pm PQueue.pm RBTree.pm \
+ RecCanvas.pm RecDialog.pm TreeNode.pm Vector.pm Vector2.pm \
+ Vector3.pm Vertex.pm basic.pl utilalgo
post-patch:
${REINPLACE_CMD} -e 's,#!/usr/bin/perl,#!${PERL},' ${WRKSRC}/algotutor
diff --git a/math/algotutor/distinfo b/math/algotutor/distinfo
index fd00b3fe5b25..079b2e470f5d 100644
--- a/math/algotutor/distinfo
+++ b/math/algotutor/distinfo
@@ -1,3 +1,3 @@
-MD5 (algotutor-0.8.5.tgz) = bf69debf762432c535579dac94db0efc
-SHA256 (algotutor-0.8.5.tgz) = 15202ca2439bfd95e8f095abbe3cd8a1ec4fde003116ca19723eb868a133927c
-SIZE (algotutor-0.8.5.tgz) = 106432
+MD5 (algotutor-0.8.6.tgz) = 58b867cb319ed3e6f8b0bd434b4d9145
+SHA256 (algotutor-0.8.6.tgz) = 78e4779779e5a75ef8419c660cccbe9fcd4aac679bbd478e80133ff915414886
+SIZE (algotutor-0.8.6.tgz) = 176802
diff --git a/math/algotutor/files/patch-algotutor b/math/algotutor/files/patch-algotutor
index dcc1ba0fe824..5b5fa38e9628 100644
--- a/math/algotutor/files/patch-algotutor
+++ b/math/algotutor/files/patch-algotutor
@@ -1,5 +1,5 @@
---- algotutor.orig Tue Apr 12 21:35:39 2005
-+++ algotutor Wed Apr 13 11:50:11 2005
+--- algotutor.orig Tue Apr 10 18:55:36 2007
++++ algotutor Tue Apr 10 18:56:10 2007
@@ -4,7 +4,7 @@
use strict;
@@ -9,12 +9,12 @@
BEGIN {
my ($path) = $0 =~ m#(.*/)#;
-@@ -33,7 +33,7 @@
- dynprog($opts{a});
- }
-
--die "need exactly one data file. Example:\n\talgotutor -a bst /usr/share/algotutor/data/countries.gr\n"
-+die "need exactly one data file. Example:\n\talgotutor -a bst !!PREFIX!!/share/algotutor/data/countries.gr\n"
- unless $#ARGV == 0;
- $dfn = $ARGV[0];
- die "cannot read data file '$dfn'.\nDoes it exist and do you have read permissions?\n" unless -r $dfn;
+@@ -58,7 +58,7 @@
+ $tab->{$algo}{run}();
+ } else {
+ # algorithms other than dynamic programming
+- die "need exactly one data file. Example:\n\talgotutor -a bst /usr/share/algotutor/data/countries.gr\n"
++ die "need exactly one data file. Example:\n\talgotutor -a bst !!PREFIX!!/share/algotutor/data/countries.gr\n"
+ unless $#ARGV == 0;
+ $dfn = $ARGV[0];
+ die "cannot read data file '$dfn'.\nDoes it exist and do you have read permissions?\n" unless -r $dfn;
diff --git a/math/algotutor/pkg-plist b/math/algotutor/pkg-plist
index a44810ead063..cc33677e245e 100644
--- a/math/algotutor/pkg-plist
+++ b/math/algotutor/pkg-plist
@@ -8,12 +8,15 @@ bin/gen_at_graph
%%SITE_PERL%%/algotutor/Edge.pm
%%SITE_PERL%%/algotutor/Graph.pm
%%SITE_PERL%%/algotutor/Heap.pm
+%%SITE_PERL%%/algotutor/Line.pm
%%SITE_PERL%%/algotutor/PQueue.pm
%%SITE_PERL%%/algotutor/RBTree.pm
%%SITE_PERL%%/algotutor/RecCanvas.pm
%%SITE_PERL%%/algotutor/RecDialog.pm
%%SITE_PERL%%/algotutor/TreeNode.pm
%%SITE_PERL%%/algotutor/Vector.pm
+%%SITE_PERL%%/algotutor/Vector2.pm
+%%SITE_PERL%%/algotutor/Vector3.pm
%%SITE_PERL%%/algotutor/Vertex.pm
%%SITE_PERL%%/algotutor/basic.pl
%%SITE_PERL%%/algotutor/cgeom/dom