aboutsummaryrefslogtreecommitdiff
path: root/math
diff options
context:
space:
mode:
authorEitan Adler <eadler@FreeBSD.org>2012-01-21 17:40:15 +0000
committerEitan Adler <eadler@FreeBSD.org>2012-01-21 17:40:15 +0000
commitc59a3834c4bd220def36c5006080d4e0f57b83e0 (patch)
treed65d5bf921ef2499700b90c4dc6855a0137ddaf2 /math
parent556296fe6692c3141d20c3bf87b479397ff4f4b0 (diff)
downloadports-c59a3834c4bd220def36c5006080d4e0f57b83e0.tar.gz
ports-c59a3834c4bd220def36c5006080d4e0f57b83e0.zip
At the moment 1385 ports use BUILD_DEPENDS= ${RUN_DEPENDS} and 450
ports use BUILD_DEPENDS:= ${RUN_DEPENDS}. This patch fixes ports that are currently broken. This is a temporary measure until we organically stop using := or someone(s) spend a lot of time changing all the ports over. Explicit duplication > := > = and this just moves ports one step to the left Approved by: portmgr
Notes
Notes: svn path=/head/; revision=289563
Diffstat (limited to 'math')
-rw-r--r--math/algotutor/Makefile2
-rw-r--r--math/p5-AI-Perceptron/Makefile2
-rw-r--r--math/p5-CAD-Calc/Makefile2
-rw-r--r--math/p5-GIS-Distance-Fast/Makefile2
-rw-r--r--math/p5-Geo-Distance-XS/Makefile2
-rw-r--r--math/p5-Graph/Makefile2
-rw-r--r--math/p5-Math-Algebra-Symbols/Makefile2
-rw-r--r--math/p5-Math-Currency/Makefile2
-rw-r--r--math/p5-Math-Geometry-Planar-Offset/Makefile2
-rw-r--r--math/p5-Math-Geometry-Planar/Makefile2
-rw-r--r--math/p5-Math-LinearCombination/Makefile2
-rw-r--r--math/p5-Math-Random-ISAAC-XS/Makefile2
-rw-r--r--math/p5-Math-Random-ISAAC/Makefile2
-rw-r--r--math/p5-Math-RandomOrg/Makefile2
-rw-r--r--math/p5-Math-Sequence/Makefile2
-rw-r--r--math/p5-Math-Series/Makefile2
-rw-r--r--math/p5-Math-SimpleVariable/Makefile2
-rw-r--r--math/p5-Math-Symbolic-Custom-CCompiler/Makefile2
-rw-r--r--math/p5-Math-Symbolic-Custom-Contains/Makefile2
-rw-r--r--math/p5-Math-Symbolic-Custom-ErrorPropagation/Makefile2
-rw-r--r--math/p5-Math-Symbolic-Custom-Pattern/Makefile2
-rw-r--r--math/p5-Math-Symbolic-Custom-Simplification/Makefile2
-rw-r--r--math/p5-Math-Symbolic/Makefile2
-rw-r--r--math/p5-Math-SymbolicX-BigNum/Makefile2
-rw-r--r--math/p5-Math-SymbolicX-Complex/Makefile2
-rw-r--r--math/p5-Math-SymbolicX-Error/Makefile2
-rw-r--r--math/p5-Math-SymbolicX-Inline/Makefile2
-rw-r--r--math/p5-Math-SymbolicX-NoSimplification/Makefile2
-rw-r--r--math/p5-Set-IntSpan-Fast-XS/Makefile2
-rw-r--r--math/p5-Set-IntSpan-Fast/Makefile2
-rw-r--r--math/p5-Statistics-Basic/Makefile2
-rw-r--r--math/p5-Statistics-Contingency/Makefile2
-rw-r--r--math/pear-Math_BigInteger/Makefile2
-rw-r--r--math/pear-Math_Combinatorics/Makefile2
-rw-r--r--math/py-pymc/Makefile2
35 files changed, 35 insertions, 35 deletions
diff --git a/math/algotutor/Makefile b/math/algotutor/Makefile
index b92310e1d7b4..a4bd9098bcd0 100644
--- a/math/algotutor/Makefile
+++ b/math/algotutor/Makefile
@@ -16,7 +16,7 @@ MAINTAINER= kevlo@FreeBSD.org
COMMENT= An interactive tutorial for algorithms and data structures
BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Tk.pm:${PORTSDIR}/x11-toolkits/p5-Tk
-RUN_DEPENDS= ${BUILD_DEPENDS}
+RUN_DEPENDS:= ${BUILD_DEPENDS}
USE_PERL5_BUILD=yes
NO_BUILD= yes
diff --git a/math/p5-AI-Perceptron/Makefile b/math/p5-AI-Perceptron/Makefile
index 0f180b54a78c..26c17a5a7ed8 100644
--- a/math/p5-AI-Perceptron/Makefile
+++ b/math/p5-AI-Perceptron/Makefile
@@ -15,7 +15,7 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= Perl module for introducing to internal operations of neural networks
BUILD_DEPENDS= ${SITE_PERL}/accessors.pm:${PORTSDIR}/devel/p5-accessors
-RUN_DEPENDS= ${BUILD_DEPENDS}
+RUN_DEPENDS:= ${BUILD_DEPENDS}
PERL_MODBUILD= yes
diff --git a/math/p5-CAD-Calc/Makefile b/math/p5-CAD-Calc/Makefile
index dc1cbd1d49c2..f63e1189c67b 100644
--- a/math/p5-CAD-Calc/Makefile
+++ b/math/p5-CAD-Calc/Makefile
@@ -18,7 +18,7 @@ COMMENT= Generic cad-related geometry calculations
BUILD_DEPENDS= ${SITE_PERL}/Math/Vec.pm:${PORTSDIR}/math/p5-Math-Vec \
${SITE_PERL}/Math/Round/Var.pm:${PORTSDIR}/math/p5-Math-Round-Var \
${SITE_PERL}/Math/Geometry/Planar/Offset.pm:${PORTSDIR}/math/p5-Math-Geometry-Planar-Offset
-RUN_DEPENDS= ${BUILD_DEPENDS}
+RUN_DEPENDS:= ${BUILD_DEPENDS}
MAN3= CAD::Calc.3
diff --git a/math/p5-GIS-Distance-Fast/Makefile b/math/p5-GIS-Distance-Fast/Makefile
index 8f922f30d98d..5dca35665890 100644
--- a/math/p5-GIS-Distance-Fast/Makefile
+++ b/math/p5-GIS-Distance-Fast/Makefile
@@ -16,7 +16,7 @@ MAINTAINER= tobez@FreeBSD.org
COMMENT= C implementation of GIS::Distance formulas
BUILD_DEPENDS= p5-GIS-Distance>=0.07:${PORTSDIR}/math/p5-GIS-Distance
-RUN_DEPENDS= ${BUILD_DEPENDS}
+RUN_DEPENDS:= ${BUILD_DEPENDS}
PERL_CONFIGURE= yes
diff --git a/math/p5-Geo-Distance-XS/Makefile b/math/p5-Geo-Distance-XS/Makefile
index 5fded223e965..2830712284a0 100644
--- a/math/p5-Geo-Distance-XS/Makefile
+++ b/math/p5-Geo-Distance-XS/Makefile
@@ -16,7 +16,7 @@ MAINTAINER= tobez@FreeBSD.org
COMMENT= Calculate Distances and Closest Locations faster
BUILD_DEPENDS= p5-Geo-Distance>=0.16:${PORTSDIR}/math/p5-Geo-Distance
-RUN_DEPENDS= ${BUILD_DEPENDS}
+RUN_DEPENDS:= ${BUILD_DEPENDS}
PERL_CONFIGURE= yes
diff --git a/math/p5-Graph/Makefile b/math/p5-Graph/Makefile
index 3a6ce93cec67..fc1293a68e22 100644
--- a/math/p5-Graph/Makefile
+++ b/math/p5-Graph/Makefile
@@ -17,7 +17,7 @@ COMMENT= Graph, the Perl module for graph operations
BUILD_DEPENDS= ${SITE_PERL}/Heap.pm:${PORTSDIR}/devel/p5-Heap \
${SITE_PERL}/${PERL_ARCH}/List/Util.pm:${PORTSDIR}/lang/p5-Scalar-List-Utils
-RUN_DEPENDS= ${BUILD_DEPENDS}
+RUN_DEPENDS:= ${BUILD_DEPENDS}
PERL_CONFIGURE= yes
diff --git a/math/p5-Math-Algebra-Symbols/Makefile b/math/p5-Math-Algebra-Symbols/Makefile
index 59f63b5e5d1a..bb9ae28861ab 100644
--- a/math/p5-Math-Algebra-Symbols/Makefile
+++ b/math/p5-Math-Algebra-Symbols/Makefile
@@ -15,7 +15,7 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= Symbolic Algebra in Pure Perl
BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Scalar/Util.pm:${PORTSDIR}/lang/p5-Scalar-List-Utils
-RUN_DEPENDS= ${BUILD_DEPENDS}
+RUN_DEPENDS:= ${BUILD_DEPENDS}
MAN3= Math::Algebra::Symbols.3 \
Math::Algebra::Symbols::Sum.3 \
diff --git a/math/p5-Math-Currency/Makefile b/math/p5-Math-Currency/Makefile
index a68c62bebf28..36ec881f626d 100644
--- a/math/p5-Math-Currency/Makefile
+++ b/math/p5-Math-Currency/Makefile
@@ -15,7 +15,7 @@ MAINTAINER= perl@FreeBSD.org
COMMENT= Perl module for exact currency math with formatting and rounding
BUILD_DEPENDS= ${SITE_PERL}/Math/FixedPrecision.pm:${PORTSDIR}/math/p5-Math-FixedPrecision
-RUN_DEPENDS= ${BUILD_DEPENDS}
+RUN_DEPENDS:= ${BUILD_DEPENDS}
PERL_MODBUILD= yes
diff --git a/math/p5-Math-Geometry-Planar-Offset/Makefile b/math/p5-Math-Geometry-Planar-Offset/Makefile
index c353f21dfb32..ffa33f5941bf 100644
--- a/math/p5-Math-Geometry-Planar-Offset/Makefile
+++ b/math/p5-Math-Geometry-Planar-Offset/Makefile
@@ -15,7 +15,7 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= Calculate offset polygons
BUILD_DEPENDS= ${SITE_PERL}/Test/YAML.pm:${PORTSDIR}/textproc/p5-YAML
-RUN_DEPENDS= ${BUILD_DEPENDS}
+RUN_DEPENDS:= ${BUILD_DEPENDS}
MAN3= Math::Geometry::Planar::Offset.3
diff --git a/math/p5-Math-Geometry-Planar/Makefile b/math/p5-Math-Geometry-Planar/Makefile
index 70e21bf477b7..ec153810278f 100644
--- a/math/p5-Math-Geometry-Planar/Makefile
+++ b/math/p5-Math-Geometry-Planar/Makefile
@@ -17,7 +17,7 @@ COMMENT= A collection of planar geometry functions
BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Math/Geometry/Planar/GPC.pm:${PORTSDIR}/math/p5-Math-Geometry-Planar-GPC \
${SITE_PERL}/Math/Geometry/Planar/Offset.pm:${PORTSDIR}/math/p5-Math-Geometry-Planar-Offset
-RUN_DEPENDS= ${BUILD_DEPENDS}
+RUN_DEPENDS:= ${BUILD_DEPENDS}
MAN3= Math::Geometry::Planar.3
diff --git a/math/p5-Math-LinearCombination/Makefile b/math/p5-Math-LinearCombination/Makefile
index 380ee02d1ac6..356dfdf75236 100644
--- a/math/p5-Math-LinearCombination/Makefile
+++ b/math/p5-Math-LinearCombination/Makefile
@@ -16,7 +16,7 @@ COMMENT= Sum of variables with a numerical coefficient
BUILD_DEPENDS= ${SITE_PERL}/fields.pm:${PORTSDIR}/devel/p5-Class-Fields \
${SITE_PERL}/Math/SimpleVariable.pm:${PORTSDIR}/math/p5-Math-SimpleVariable
-RUN_DEPENDS= ${BUILD_DEPENDS}
+RUN_DEPENDS:= ${BUILD_DEPENDS}
PERL_CONFIGURE= yes
diff --git a/math/p5-Math-Random-ISAAC-XS/Makefile b/math/p5-Math-Random-ISAAC-XS/Makefile
index 5144e70639d6..b9422f8360a0 100644
--- a/math/p5-Math-Random-ISAAC-XS/Makefile
+++ b/math/p5-Math-Random-ISAAC-XS/Makefile
@@ -16,7 +16,7 @@ MAINTAINER= wen@FreeBSD.org
COMMENT= C implementation of the ISAAC PRNG Algorithm
BUILD_DEPENDS= p5-Test-NoWarnings>0:${PORTSDIR}/devel/p5-Test-NoWarnings
-RUN_DEPENDS= ${BUILD_DEPENDS}
+RUN_DEPENDS:= ${BUILD_DEPENDS}
PERL_MODBUILD= yes
diff --git a/math/p5-Math-Random-ISAAC/Makefile b/math/p5-Math-Random-ISAAC/Makefile
index 60984bf5b838..51d962a1725a 100644
--- a/math/p5-Math-Random-ISAAC/Makefile
+++ b/math/p5-Math-Random-ISAAC/Makefile
@@ -16,7 +16,7 @@ MAINTAINER= wen@FreeBSD.org
COMMENT= Perl interface to the ISAAC PRNG Algorithm
BUILD_DEPENDS= p5-Test-NoWarnings>0:${PORTSDIR}/devel/p5-Test-NoWarnings
-RUN_DEPENDS= ${BUILD_DEPENDS} \
+RUN_DEPENDS:= ${BUILD_DEPENDS} \
p5-Math-Random-ISAAC-XS>0:${PORTSDIR}/math/p5-Math-Random-ISAAC-XS
PERL_CONFIGURE= yes
diff --git a/math/p5-Math-RandomOrg/Makefile b/math/p5-Math-RandomOrg/Makefile
index a51e87aa5d69..75014f8047af 100644
--- a/math/p5-Math-RandomOrg/Makefile
+++ b/math/p5-Math-RandomOrg/Makefile
@@ -16,7 +16,7 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= Retrieve random numbers and data from random.org
BUILD_DEPENDS= ${SITE_PERL}/LWP/Simple.pm:${PORTSDIR}/www/p5-libwww
-RUN_DEPENDS= ${BUILD_DEPENDS}
+RUN_DEPENDS:= ${BUILD_DEPENDS}
MAN3= Math::RandomOrg.3
diff --git a/math/p5-Math-Sequence/Makefile b/math/p5-Math-Sequence/Makefile
index 46434535484f..0d9703e20271 100644
--- a/math/p5-Math-Sequence/Makefile
+++ b/math/p5-Math-Sequence/Makefile
@@ -15,7 +15,7 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= Perl extension dealing with mathematic sequences
BUILD_DEPENDS= ${SITE_PERL}/Math/Symbolic.pm:${PORTSDIR}/math/p5-Math-Symbolic
-RUN_DEPENDS= ${BUILD_DEPENDS}
+RUN_DEPENDS:= ${BUILD_DEPENDS}
MAN3= Math::Sequence.3
diff --git a/math/p5-Math-Series/Makefile b/math/p5-Math-Series/Makefile
index 7fc2635a1649..35ccaf2b900b 100644
--- a/math/p5-Math-Series/Makefile
+++ b/math/p5-Math-Series/Makefile
@@ -16,7 +16,7 @@ COMMENT= Perl extension dealing with mathematic series
BUILD_DEPENDS= ${SITE_PERL}/Math/Symbolic.pm:${PORTSDIR}/math/p5-Math-Symbolic \
${SITE_PERL}/Math/Sequence.pm:${PORTSDIR}/math/p5-Math-Sequence
-RUN_DEPENDS= ${BUILD_DEPENDS}
+RUN_DEPENDS:= ${BUILD_DEPENDS}
MAN3= Math::Series.3
diff --git a/math/p5-Math-SimpleVariable/Makefile b/math/p5-Math-SimpleVariable/Makefile
index 4d6115d1fb61..6c17d38f90d7 100644
--- a/math/p5-Math-SimpleVariable/Makefile
+++ b/math/p5-Math-SimpleVariable/Makefile
@@ -15,7 +15,7 @@ MAINTAINER= skv@FreeBSD.org
COMMENT= Simple representation of mathematical variables
BUILD_DEPENDS= ${SITE_PERL}/fields.pm:${PORTSDIR}/devel/p5-Class-Fields
-RUN_DEPENDS= ${BUILD_DEPENDS}
+RUN_DEPENDS:= ${BUILD_DEPENDS}
PERL_CONFIGURE= yes
diff --git a/math/p5-Math-Symbolic-Custom-CCompiler/Makefile b/math/p5-Math-Symbolic-Custom-CCompiler/Makefile
index 38d5dc2ed890..a1b3375c2312 100644
--- a/math/p5-Math-Symbolic-Custom-CCompiler/Makefile
+++ b/math/p5-Math-Symbolic-Custom-CCompiler/Makefile
@@ -16,7 +16,7 @@ COMMENT= Compile Math::Symbolic trees to C
BUILD_DEPENDS= p5-Math-Symbolic>=0.509:${PORTSDIR}/math/p5-Math-Symbolic \
p5-Inline>=0.44:${PORTSDIR}/devel/p5-Inline
-RUN_DEPENDS= ${BUILD_DEPENDS}
+RUN_DEPENDS:= ${BUILD_DEPENDS}
MAN3= Math::Symbolic::Custom::CCompiler.3
diff --git a/math/p5-Math-Symbolic-Custom-Contains/Makefile b/math/p5-Math-Symbolic-Custom-Contains/Makefile
index a535161116bc..3f2c55db93b2 100644
--- a/math/p5-Math-Symbolic-Custom-Contains/Makefile
+++ b/math/p5-Math-Symbolic-Custom-Contains/Makefile
@@ -16,7 +16,7 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= Find subtrees in Math::Symbolic expressions
BUILD_DEPENDS= ${SITE_PERL}/Math/Symbolic.pm:${PORTSDIR}/math/p5-Math-Symbolic
-RUN_DEPENDS= ${BUILD_DEPENDS}
+RUN_DEPENDS:= ${BUILD_DEPENDS}
MAN3= Math::Symbolic::Custom::Contains.3
diff --git a/math/p5-Math-Symbolic-Custom-ErrorPropagation/Makefile b/math/p5-Math-Symbolic-Custom-ErrorPropagation/Makefile
index 449bd17c67a9..0659e8f21192 100644
--- a/math/p5-Math-Symbolic-Custom-ErrorPropagation/Makefile
+++ b/math/p5-Math-Symbolic-Custom-ErrorPropagation/Makefile
@@ -15,7 +15,7 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= Calculate Gaussian Error Propagation
BUILD_DEPENDS= ${SITE_PERL}/Math/Symbolic.pm:${PORTSDIR}/math/p5-Math-Symbolic
-RUN_DEPENDS= ${BUILD_DEPENDS}
+RUN_DEPENDS:= ${BUILD_DEPENDS}
MAN3= Math::Symbolic::Custom::ErrorPropagation.3
diff --git a/math/p5-Math-Symbolic-Custom-Pattern/Makefile b/math/p5-Math-Symbolic-Custom-Pattern/Makefile
index 2ae197858b95..e35e13749064 100644
--- a/math/p5-Math-Symbolic-Custom-Pattern/Makefile
+++ b/math/p5-Math-Symbolic-Custom-Pattern/Makefile
@@ -18,7 +18,7 @@ BUILD_DEPENDS= p5-Math-Symbolic>=0.510:${PORTSDIR}/math/p5-Math-Symbolic \
p5-Test-Pod>=1.0:${PORTSDIR}/devel/p5-Test-Pod \
p5-Test-Pod-Coverage>=1.0:${PORTSDIR}/devel/p5-Test-Pod-Coverage \
${SITE_PERL}/${PERL_ARCH}/Clone.pm:${PORTSDIR}/devel/p5-Clone
-RUN_DEPENDS= ${BUILD_DEPENDS}
+RUN_DEPENDS:= ${BUILD_DEPENDS}
MAN3= Math::Symbolic::Custom::Pattern.3 \
Math::Symbolic::Custom::Pattern::Export.3
diff --git a/math/p5-Math-Symbolic-Custom-Simplification/Makefile b/math/p5-Math-Symbolic-Custom-Simplification/Makefile
index b09b31dae501..d3e66827ede5 100644
--- a/math/p5-Math-Symbolic-Custom-Simplification/Makefile
+++ b/math/p5-Math-Symbolic-Custom-Simplification/Makefile
@@ -15,7 +15,7 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= User defined simplification routines
BUILD_DEPENDS= ${SITE_PERL}/Math/Symbolic.pm:${PORTSDIR}/math/p5-Math-Symbolic
-RUN_DEPENDS= ${BUILD_DEPENDS}
+RUN_DEPENDS:= ${BUILD_DEPENDS}
MAN3= Math::Symbolic::Custom::Simplification.3
diff --git a/math/p5-Math-Symbolic/Makefile b/math/p5-Math-Symbolic/Makefile
index 64acc09bee07..d0ee65370f09 100644
--- a/math/p5-Math-Symbolic/Makefile
+++ b/math/p5-Math-Symbolic/Makefile
@@ -18,7 +18,7 @@ COMMENT= Symbolic calculations
BUILD_DEPENDS= ${SITE_PERL}/Parse/RecDescent.pm:${PORTSDIR}/devel/p5-Parse-RecDescent \
${SITE_PERL}/Test/Pod.pm:${PORTSDIR}/devel/p5-Test-Pod \
${SITE_PERL}/Test/Pod/Coverage.pm:${PORTSDIR}/devel/p5-Test-Pod-Coverage
-RUN_DEPENDS= ${BUILD_DEPENDS}
+RUN_DEPENDS:= ${BUILD_DEPENDS}
MAN3= Math::Symbolic.3 \
Math::Symbolic::AuxFunctions.3 \
diff --git a/math/p5-Math-SymbolicX-BigNum/Makefile b/math/p5-Math-SymbolicX-BigNum/Makefile
index 1f0168dc5848..d22431acdc7f 100644
--- a/math/p5-Math-SymbolicX-BigNum/Makefile
+++ b/math/p5-Math-SymbolicX-BigNum/Makefile
@@ -16,7 +16,7 @@ COMMENT= Big number support for the Math::Symbolic parser
BUILD_DEPENDS= ${SITE_PERL}/Math/Symbolic.pm:${PORTSDIR}/math/p5-Math-Symbolic \
${SITE_PERL}/Math/SymbolicX/ParserExtensionFactory.pm:${PORTSDIR}/math/p5-Math-SymbolicX-ParserExtensionFactory
-RUN_DEPENDS= ${BUILD_DEPENDS}
+RUN_DEPENDS:= ${BUILD_DEPENDS}
MAN3= Math::SymbolicX::BigNum.3
diff --git a/math/p5-Math-SymbolicX-Complex/Makefile b/math/p5-Math-SymbolicX-Complex/Makefile
index b646f1f2fa08..b099ee97e7ef 100644
--- a/math/p5-Math-SymbolicX-Complex/Makefile
+++ b/math/p5-Math-SymbolicX-Complex/Makefile
@@ -16,7 +16,7 @@ COMMENT= Complex number support for the Math::Symbolic parser
BUILD_DEPENDS= ${SITE_PERL}/Math/Symbolic.pm:${PORTSDIR}/math/p5-Math-Symbolic \
${SITE_PERL}/Math/SymbolicX/ParserExtensionFactory.pm:${PORTSDIR}/math/p5-Math-SymbolicX-ParserExtensionFactory
-RUN_DEPENDS= ${BUILD_DEPENDS}
+RUN_DEPENDS:= ${BUILD_DEPENDS}
MAN3= Math::SymbolicX::Complex.3
diff --git a/math/p5-Math-SymbolicX-Error/Makefile b/math/p5-Math-SymbolicX-Error/Makefile
index 8f3e31449d4a..5ffb94302149 100644
--- a/math/p5-Math-SymbolicX-Error/Makefile
+++ b/math/p5-Math-SymbolicX-Error/Makefile
@@ -17,7 +17,7 @@ COMMENT= Parser extension for dealing with numeric errors
BUILD_DEPENDS= ${SITE_PERL}/Math/Symbolic.pm:${PORTSDIR}/math/p5-Math-Symbolic \
${SITE_PERL}/Math/SymbolicX/ParserExtensionFactory.pm:${PORTSDIR}/math/p5-Math-SymbolicX-ParserExtensionFactory \
${SITE_PERL}/Number/WithError.pm:${PORTSDIR}/math/p5-Number-WithError
-RUN_DEPENDS= ${BUILD_DEPENDS}
+RUN_DEPENDS:= ${BUILD_DEPENDS}
MAN3= Math::SymbolicX::Error.3
diff --git a/math/p5-Math-SymbolicX-Inline/Makefile b/math/p5-Math-SymbolicX-Inline/Makefile
index 9d7659684168..34576132c656 100644
--- a/math/p5-Math-SymbolicX-Inline/Makefile
+++ b/math/p5-Math-SymbolicX-Inline/Makefile
@@ -16,7 +16,7 @@ COMMENT= Inlined Math::Symbolic functions
BUILD_DEPENDS= ${SITE_PERL}/Math/Symbolic.pm:${PORTSDIR}/math/p5-Math-Symbolic \
${SITE_PERL}/Math/Symbolic/Custom/Contains.pm:${PORTSDIR}/math/p5-Math-Symbolic-Custom-Contains
-RUN_DEPENDS= ${BUILD_DEPENDS}
+RUN_DEPENDS:= ${BUILD_DEPENDS}
MAN3= Math::SymbolicX::Inline.3
diff --git a/math/p5-Math-SymbolicX-NoSimplification/Makefile b/math/p5-Math-SymbolicX-NoSimplification/Makefile
index 63d96376a675..b99845e4b768 100644
--- a/math/p5-Math-SymbolicX-NoSimplification/Makefile
+++ b/math/p5-Math-SymbolicX-NoSimplification/Makefile
@@ -15,7 +15,7 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= Turn off Math::Symbolic simplification
BUILD_DEPENDS= ${SITE_PERL}/Math/Symbolic.pm:${PORTSDIR}/math/p5-Math-Symbolic
-RUN_DEPENDS= ${BUILD_DEPENDS}
+RUN_DEPENDS:= ${BUILD_DEPENDS}
MAN3= Math::SymbolicX::NoSimplification.3
diff --git a/math/p5-Set-IntSpan-Fast-XS/Makefile b/math/p5-Set-IntSpan-Fast-XS/Makefile
index ee876afc3ca3..9ecef8fd681a 100644
--- a/math/p5-Set-IntSpan-Fast-XS/Makefile
+++ b/math/p5-Set-IntSpan-Fast-XS/Makefile
@@ -17,7 +17,7 @@ COMMENT= Faster Set::IntSpan::Fast
BUILD_DEPENDS= p5-Data-Swap>=0.07:${PORTSDIR}/devel/p5-Data-Swap \
p5-Set-IntSpan-Fast>=1.13:${PORTSDIR}/math/p5-Set-IntSpan-Fast
-RUN_DEPENDS= ${BUILD_DEPENDS}
+RUN_DEPENDS:= ${BUILD_DEPENDS}
PERL_CONFIGURE= yes
diff --git a/math/p5-Set-IntSpan-Fast/Makefile b/math/p5-Set-IntSpan-Fast/Makefile
index 48e470eddcec..9de97ebea14e 100644
--- a/math/p5-Set-IntSpan-Fast/Makefile
+++ b/math/p5-Set-IntSpan-Fast/Makefile
@@ -15,7 +15,7 @@ MAINTAINER= tobez@FreeBSD.org
COMMENT= Fast handling of sets containing integer spans
BUILD_DEPENDS= ${SITE_PERL}/Data/Types.pm:${PORTSDIR}/devel/p5-Data-Types
-RUN_DEPENDS= ${BUILD_DEPENDS}
+RUN_DEPENDS:= ${BUILD_DEPENDS}
PERL_CONFIGURE= yes
diff --git a/math/p5-Statistics-Basic/Makefile b/math/p5-Statistics-Basic/Makefile
index 7e1fa2966482..4545a6b6fd2a 100644
--- a/math/p5-Statistics-Basic/Makefile
+++ b/math/p5-Statistics-Basic/Makefile
@@ -16,7 +16,7 @@ MAINTAINER= tobez@FreeBSD.org
COMMENT= A collection of very basic statistics modules
BUILD_DEPENDS= p5-Number-Format>=1.61:${PORTSDIR}/textproc/p5-Number-Format
-RUN_DEPENDS= ${BUILD_DEPENDS}
+RUN_DEPENDS:= ${BUILD_DEPENDS}
PERL_CONFIGURE= yes
diff --git a/math/p5-Statistics-Contingency/Makefile b/math/p5-Statistics-Contingency/Makefile
index 086aee9917a0..77e22eceb706 100644
--- a/math/p5-Statistics-Contingency/Makefile
+++ b/math/p5-Statistics-Contingency/Makefile
@@ -15,7 +15,7 @@ MAINTAINER= clsung@FreeBSD.org
COMMENT= Calculate precision, recall, F1, accuracy, etc
BUILD_DEPENDS= p5-Params-Validate>=0:${PORTSDIR}/devel/p5-Params-Validate
-RUN_DEPENDS= ${BUILD_DEPENDS}
+RUN_DEPENDS:= ${BUILD_DEPENDS}
PERL_CONFIGURE= yes
diff --git a/math/pear-Math_BigInteger/Makefile b/math/pear-Math_BigInteger/Makefile
index 002441a2a8a9..0e9dd861e2f1 100644
--- a/math/pear-Math_BigInteger/Makefile
+++ b/math/pear-Math_BigInteger/Makefile
@@ -13,7 +13,7 @@ MAINTAINER= meritus@innervision.pl
COMMENT= Pure-PHP arbitrary precission integer arithmetic library
BUILD_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear
-RUN_DEPENDS= ${BUILD_DEPENDS}
+RUN_DEPENDS:= ${BUILD_DEPENDS}
CATEGORY= Math
FILES= BigInteger.php
diff --git a/math/pear-Math_Combinatorics/Makefile b/math/pear-Math_Combinatorics/Makefile
index 4aab90b9133b..6c18301b4904 100644
--- a/math/pear-Math_Combinatorics/Makefile
+++ b/math/pear-Math_Combinatorics/Makefile
@@ -14,7 +14,7 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= A package that produces combinations and permutations
BUILD_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear
-RUN_DEPENDS= ${BUILD_DEPENDS}
+RUN_DEPENDS:= ${BUILD_DEPENDS}
CATEGORY= Math
FILES= Combinatorics.php
diff --git a/math/py-pymc/Makefile b/math/py-pymc/Makefile
index 8af5b7f935e6..de0a40a5ef51 100644
--- a/math/py-pymc/Makefile
+++ b/math/py-pymc/Makefile
@@ -16,7 +16,7 @@ MAINTAINER= wenheping@gmail.com
COMMENT= Markov Chain Monte Carlo Sampling Toolkit
BUILD_DEPENDS= ${PYNUMPY}
-RUN_DEPENDS= ${BUILD_DEPENDS}
+RUN_DEPENDS:= ${BUILD_DEPENDS}
USE_PYTHON= yes
USE_PYDISTUTILS= yes