aboutsummaryrefslogtreecommitdiff
path: root/math
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2020-03-11 08:27:30 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2020-03-11 08:27:30 +0000
commit2d9b7ff23d246ffb86d6703c5f0c519813cebdef (patch)
tree17f5ec1119b6b55b21ce7c5ede386ffe3284e356 /math
parent6bc7a46bf8d2cc7e2f336823c855cc84bd13d3a1 (diff)
downloadports-2d9b7ff23d246ffb86d6703c5f0c519813cebdef.tar.gz
ports-2d9b7ff23d246ffb86d6703c5f0c519813cebdef.zip
Cleanup
- Use base byacc instead of GNU bison - Prevent the detection of makeinfo which would otherwise trigger a rebuild of the texinfo documentation which is not compatible with recent texinfo - Remove a useless sed command, passing DESTDIR in argument of make(1) is enough to override the makefile definition
Notes
Notes: svn path=/head/; revision=528220
Diffstat (limited to 'math')
-rw-r--r--math/oleo/Makefile8
1 files changed, 4 insertions, 4 deletions
diff --git a/math/oleo/Makefile b/math/oleo/Makefile
index de0d3ebfd83b..5febc8f9f030 100644
--- a/math/oleo/Makefile
+++ b/math/oleo/Makefile
@@ -13,11 +13,13 @@ COMMENT= GNU spreadsheet for X11 and terminals
LICENSE= GPLv2+
LICENSE_FILE= ${WRKSRC}/COPYING
-USES= bison localbase ncurses perl5
+USES= bison:alias localbase ncurses perl5
USE_PERL5= build
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-x --without-xlt --without-SciPlot
-MAKE_ENV+= DESTDIR=${STAGEDIR}
+MAKE_ARGS+= DESTDIR="${STAGEDIR}"
+
+BINARY_ALIAS= makeinfo=false # disable detecting local makeinfo
INFO= oleo
@@ -40,8 +42,6 @@ NLS_USES_OFF= gettext-tools
post-patch:
@${GREP} -lR "malloc\.h" ${WRKSRC} | ${XARGS} ${REINPLACE_CMD} -e \
's|malloc\.h|stdlib.h|g'
- @${REINPLACE_CMD} -e '/^DESTDIR/s|=|?=|' \
- ${WRKSRC}/Makefile.in
.for pof in en fr nl
@${REINPLACE_CMD} -e "s|CHARSET|ISO-8859-1|;s|ENCODING|8bit|" \
${WRKSRC}/po/${pof}.po