aboutsummaryrefslogtreecommitdiff
path: root/math
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2020-03-13 19:58:39 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2020-03-13 19:58:39 +0000
commitfc90917cf0760fa810f912efd7d069fd83f6c9c5 (patch)
treeeba9cd21ab472c29d832c481cb0896b6c6b23fee /math
parent056c5054ac667c2e1e7415eb7ccb196778d646c6 (diff)
downloadports-fc90917cf0760fa810f912efd7d069fd83f6c9c5.tar.gz
ports-fc90917cf0760fa810f912efd7d069fd83f6c9c5.zip
math/mlpack: Correction
Notes
Notes: svn path=/head/; revision=528375
Diffstat (limited to 'math')
-rw-r--r--math/mlpack/Makefile4
-rw-r--r--math/mlpack/pkg-plist46
2 files changed, 2 insertions, 48 deletions
diff --git a/math/mlpack/Makefile b/math/mlpack/Makefile
index f2de430c066f..77d735928c5a 100644
--- a/math/mlpack/Makefile
+++ b/math/mlpack/Makefile
@@ -2,6 +2,7 @@
PORTNAME= mlpack
DISTVERSION= 3.2.2
+PORTREVISION= 1
CATEGORIES= math
MASTER_SITES= https://mlpack.org/files/
@@ -18,10 +19,9 @@ LIB_DEPENDS= libboost_program_options.so:devel/boost-libs \
libarmadillo.so:math/armadillo
USES= cmake compiler:c++14-lang pkgconfig
-CMAKE_ARGS+= -DBUILD_TESTS:BOOL=false -DBUILD_CLI_EXECUTABLES=false -DBUILD_PYTHON_BINDINGS=false
USE_LDCONFIG= yes
CMAKE_ARGS= -DSTB_IMAGE_INCLUDE_DIR=${LOCALBASE}/include/stb
-CMAKE_OFF= BUILD_PYTHON_BINDINGS BUILD_TESTS
+CMAKE_OFF= BUILD_PYTHON_BINDINGS BUILD_TESTS BUILD_CLI_EXECUTABLES
.include <bsd.port.mk>
diff --git a/math/mlpack/pkg-plist b/math/mlpack/pkg-plist
index 8566e7246a86..883daf81c49a 100644
--- a/math/mlpack/pkg-plist
+++ b/math/mlpack/pkg-plist
@@ -1,49 +1,3 @@
-bin/mlpack_adaboost
-bin/mlpack_approx_kfn
-bin/mlpack_cf
-bin/mlpack_dbscan
-bin/mlpack_decision_stump
-bin/mlpack_decision_tree
-bin/mlpack_det
-bin/mlpack_emst
-bin/mlpack_fastmks
-bin/mlpack_gmm_generate
-bin/mlpack_gmm_probability
-bin/mlpack_gmm_train
-bin/mlpack_hmm_generate
-bin/mlpack_hmm_loglik
-bin/mlpack_hmm_train
-bin/mlpack_hmm_viterbi
-bin/mlpack_hoeffding_tree
-bin/mlpack_kde
-bin/mlpack_kernel_pca
-bin/mlpack_kfn
-bin/mlpack_kmeans
-bin/mlpack_knn
-bin/mlpack_krann
-bin/mlpack_lars
-bin/mlpack_linear_regression
-bin/mlpack_linear_svm
-bin/mlpack_lmnn
-bin/mlpack_local_coordinate_coding
-bin/mlpack_logistic_regression
-bin/mlpack_lsh
-bin/mlpack_mean_shift
-bin/mlpack_nbc
-bin/mlpack_nca
-bin/mlpack_nmf
-bin/mlpack_pca
-bin/mlpack_perceptron
-bin/mlpack_preprocess_binarize
-bin/mlpack_preprocess_describe
-bin/mlpack_preprocess_imputer
-bin/mlpack_preprocess_scale
-bin/mlpack_preprocess_split
-bin/mlpack_radical
-bin/mlpack_random_forest
-bin/mlpack_range_search
-bin/mlpack_softmax_regression
-bin/mlpack_sparse_coding
include/mlpack/bindings/cli/add_to_po.hpp
include/mlpack/bindings/cli/cli_option.hpp
include/mlpack/bindings/cli/default_param.hpp