aboutsummaryrefslogtreecommitdiff
path: root/math
diff options
context:
space:
mode:
authorWill Andrews <will@FreeBSD.org>2001-01-03 23:39:15 +0000
committerWill Andrews <will@FreeBSD.org>2001-01-03 23:39:15 +0000
commita6467afbb2e7e69c1c322a1888c35ba8d9f709ad (patch)
treecce5cac8572e49ae880459a801a6b361a3d95131 /math
parentb9fc73bebfce8b085f7262fd72dccf34b987808a (diff)
downloadports-a6467afbb2e7e69c1c322a1888c35ba8d9f709ad.tar.gz
ports-a6467afbb2e7e69c1c322a1888c35ba8d9f709ad.zip
Add p5-Math-Currency 0.10, perl module for exact currency math with
formatting and rounding.
Notes
Notes: svn path=/head/; revision=36721
Diffstat (limited to 'math')
-rw-r--r--math/Makefile1
-rw-r--r--math/p5-Math-Currency/Makefile34
-rw-r--r--math/p5-Math-Currency/distinfo1
-rw-r--r--math/p5-Math-Currency/pkg-comment1
-rw-r--r--math/p5-Math-Currency/pkg-descr6
-rw-r--r--math/p5-Math-Currency/pkg-plist3
6 files changed, 46 insertions, 0 deletions
diff --git a/math/Makefile b/math/Makefile
index e2efbba4d48c..3f69ed095ee6 100644
--- a/math/Makefile
+++ b/math/Makefile
@@ -50,6 +50,7 @@
SUBDIR += p5-Bit-Vector
SUBDIR += p5-Math-Bezier
SUBDIR += p5-Math-BigIntFast
+ SUBDIR += p5-Math-Currency
SUBDIR += p5-Math-Expr
SUBDIR += p5-Math-Logic
SUBDIR += p5-MatrixReal
diff --git a/math/p5-Math-Currency/Makefile b/math/p5-Math-Currency/Makefile
new file mode 100644
index 000000000000..2a8247d28b85
--- /dev/null
+++ b/math/p5-Math-Currency/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for: Math-Currency
+# Date created: Wed Jan 3 10:58:59 2001
+# Whom: will
+#
+# $FreeBSD$
+#
+
+PORTNAME= Math-Currency
+PORTVERSION= 0.10
+CATEGORIES= math perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Math
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= ports@FreeBSD.org
+
+BUILD_DEPENDS= ${SITE_PERL}/Math/FixedPrecision.pm:${PORTSDIR}/math/p5-Math-FixedPrecision
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 500007
+BROKEN= "Needs Perl 5.6.0 for Math::BigFloat"
+.endif
+
+SITE_PERL= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}
+USE_PERL5= yes
+USE_ZIP= yes
+PERL_CONFIGURE= yes
+
+MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+MAN3= Math::Currency.3
+
+.include <bsd.port.post.mk>
diff --git a/math/p5-Math-Currency/distinfo b/math/p5-Math-Currency/distinfo
new file mode 100644
index 000000000000..b07276538c72
--- /dev/null
+++ b/math/p5-Math-Currency/distinfo
@@ -0,0 +1 @@
+MD5 (Math-Currency-0.10.zip) = 9aeedd9812a2bb2e481102644d5bb379
diff --git a/math/p5-Math-Currency/pkg-comment b/math/p5-Math-Currency/pkg-comment
new file mode 100644
index 000000000000..d962e7054dff
--- /dev/null
+++ b/math/p5-Math-Currency/pkg-comment
@@ -0,0 +1 @@
+Perl module for exact currency math with formatting and rounding
diff --git a/math/p5-Math-Currency/pkg-descr b/math/p5-Math-Currency/pkg-descr
new file mode 100644
index 000000000000..c7393578b048
--- /dev/null
+++ b/math/p5-Math-Currency/pkg-descr
@@ -0,0 +1,6 @@
+Math::Currency is a perl module that implements exact currency math
+with formatting and rounding.
+
+Author: John Peacock <jpeacock@univpress.com>
+
+--will
diff --git a/math/p5-Math-Currency/pkg-plist b/math/p5-Math-Currency/pkg-plist
new file mode 100644
index 000000000000..94fcfc4f241e
--- /dev/null
+++ b/math/p5-Math-Currency/pkg-plist
@@ -0,0 +1,3 @@
+lib/perl5/site_perl/%%PERL_VER%%/Math/Currency.pm
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Math/Currency/.packlist
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Math/Currency