aboutsummaryrefslogtreecommitdiff
path: root/math
diff options
context:
space:
mode:
authorPete Fritchman <petef@FreeBSD.org>2002-08-10 20:44:15 +0000
committerPete Fritchman <petef@FreeBSD.org>2002-08-10 20:44:15 +0000
commit2d418ba45193ff3cee2afe0051faa3a3435cb785 (patch)
tree70beb0445faf650bf462c68a2ab7759ac0553d46 /math
parentb12ad1fdaeb18fd214eb2d0f3ffad651febd671a (diff)
downloadports-2d418ba45193ff3cee2afe0051faa3a3435cb785.tar.gz
ports-2d418ba45193ff3cee2afe0051faa3a3435cb785.zip
Add entropy 1.0, calculate data entropy to benchmark compression
algorithms. Submitted by: Chris S.J. Peron <maneo@bsdpro.com>
Notes
Notes: svn path=/head/; revision=64354
Diffstat (limited to 'math')
-rw-r--r--math/Makefile1
-rw-r--r--math/entropy/Makefile18
-rw-r--r--math/entropy/distinfo1
-rw-r--r--math/entropy/pkg-comment1
-rw-r--r--math/entropy/pkg-descr3
-rw-r--r--math/entropy/pkg-plist1
6 files changed, 25 insertions, 0 deletions
diff --git a/math/Makefile b/math/Makefile
index 927a247275fe..d1b6fc5a508b 100644
--- a/math/Makefile
+++ b/math/Makefile
@@ -24,6 +24,7 @@
SUBDIR += diehard
SUBDIR += djbfft
SUBDIR += eispack
+ SUBDIR += entropy
SUBDIR += eukleides
SUBDIR += eval
SUBDIR += femlab
diff --git a/math/entropy/Makefile b/math/entropy/Makefile
new file mode 100644
index 000000000000..2e3a549a430c
--- /dev/null
+++ b/math/entropy/Makefile
@@ -0,0 +1,18 @@
+# New ports collection makefile for: entropy
+# Date created: 9 August 2002
+# Whom: Chris S.J. Peron <maneo@bsdpro.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= entropy
+PORTVERSION= 1.0
+CATEGORIES= math archivers
+MASTER_SITES= http://staff.seccuris.com/~cperon/
+
+MAINTAINER= maneo@bsdpro.com
+
+MAN1= entropy.1
+MANCOMPRESSED= yes
+
+.include <bsd.port.mk>
diff --git a/math/entropy/distinfo b/math/entropy/distinfo
new file mode 100644
index 000000000000..c714b75b6fb1
--- /dev/null
+++ b/math/entropy/distinfo
@@ -0,0 +1 @@
+MD5 (entropy-1.0.tar.gz) = 1369f409983abd88e50221ea36049edb
diff --git a/math/entropy/pkg-comment b/math/entropy/pkg-comment
new file mode 100644
index 000000000000..4e9c2146cbfc
--- /dev/null
+++ b/math/entropy/pkg-comment
@@ -0,0 +1 @@
+Calculate data entropy to benchmark compression algorithms
diff --git a/math/entropy/pkg-descr b/math/entropy/pkg-descr
new file mode 100644
index 000000000000..29017039d54e
--- /dev/null
+++ b/math/entropy/pkg-descr
@@ -0,0 +1,3 @@
+Entropy is a program that will calculate the entropy of a given set
+of data. This program is mainly used to benchmark the efficiency
+of existing or developing compression algorithms.
diff --git a/math/entropy/pkg-plist b/math/entropy/pkg-plist
new file mode 100644
index 000000000000..61b29c665db8
--- /dev/null
+++ b/math/entropy/pkg-plist
@@ -0,0 +1 @@
+bin/entropy