aboutsummaryrefslogtreecommitdiff
path: root/math
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2003-01-06 20:48:31 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2003-01-06 20:48:31 +0000
commit92181003750adcc2dbb3a018671cdc6da3893cb4 (patch)
treed2e0f46ec4a603aeeefab3f23d45cbe32947e82c /math
parenta7fb7328a9d9f71af79cb3e6d82f1e2945207bb0 (diff)
downloadports-92181003750adcc2dbb3a018671cdc6da3893cb4.tar.gz
ports-92181003750adcc2dbb3a018671cdc6da3893cb4.zip
add p5-Math-Trig 0.02
Inverse and hyperbolic trigonemetric Functions
Notes
Notes: svn path=/head/; revision=72646
Diffstat (limited to 'math')
-rw-r--r--math/Makefile1
-rw-r--r--math/p5-Math-Trig/Makefile23
-rw-r--r--math/p5-Math-Trig/distinfo1
-rw-r--r--math/p5-Math-Trig/pkg-comment1
-rw-r--r--math/p5-Math-Trig/pkg-descr4
-rw-r--r--math/p5-Math-Trig/pkg-plist5
6 files changed, 35 insertions, 0 deletions
diff --git a/math/Makefile b/math/Makefile
index e3c8c979d782..fbf5dd6704e7 100644
--- a/math/Makefile
+++ b/math/Makefile
@@ -102,6 +102,7 @@
SUBDIR += p5-Math-Random
SUBDIR += p5-Math-Random-MT
SUBDIR += p5-Math-SimpleVariable
+ SUBDIR += p5-Math-Trig
SUBDIR += p5-Math-TrulyRandom
SUBDIR += p5-MatrixReal
SUBDIR += p5-Set-IntSpan
diff --git a/math/p5-Math-Trig/Makefile b/math/p5-Math-Trig/Makefile
new file mode 100644
index 000000000000..08fd6bbb8f56
--- /dev/null
+++ b/math/p5-Math-Trig/Makefile
@@ -0,0 +1,23 @@
+# ex:ts=8
+# Ports collection makefile for: Math::Trig
+# Date created: Jan 7, 2003
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= Math-Trig
+PORTVERSION= 0.02
+CATEGORIES= math perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Math
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= ports@FreeBSD.org
+
+PERL_CONFIGURE= yes
+
+MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+MAN3= Math::Trig.3
+
+.include <bsd.port.mk>
diff --git a/math/p5-Math-Trig/distinfo b/math/p5-Math-Trig/distinfo
new file mode 100644
index 000000000000..32c3a0308315
--- /dev/null
+++ b/math/p5-Math-Trig/distinfo
@@ -0,0 +1 @@
+MD5 (Math-Trig-0.02.tar.gz) = 4f2ba5229067817e3e4834fb188be724
diff --git a/math/p5-Math-Trig/pkg-comment b/math/p5-Math-Trig/pkg-comment
new file mode 100644
index 000000000000..195035f597a0
--- /dev/null
+++ b/math/p5-Math-Trig/pkg-comment
@@ -0,0 +1 @@
+Inverse and hyperbolic trigonemetric Functions
diff --git a/math/p5-Math-Trig/pkg-descr b/math/p5-Math-Trig/pkg-descr
new file mode 100644
index 000000000000..cd5aa368a9d4
--- /dev/null
+++ b/math/p5-Math-Trig/pkg-descr
@@ -0,0 +1,4 @@
+This module exports the missing inverse and hyperbolic trigonometric functions
+of real numbers. The inverse functions return values cooresponding to the
+principal values. Specifying an argument outside of the domain of the function
+will cause undef to be returned.
diff --git a/math/p5-Math-Trig/pkg-plist b/math/p5-Math-Trig/pkg-plist
new file mode 100644
index 000000000000..5c5a19949c0d
--- /dev/null
+++ b/math/p5-Math-Trig/pkg-plist
@@ -0,0 +1,5 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Math/Trig/.packlist
+%%SITE_PERL%%/Math/Trig.pm
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Math/Trig
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/Math 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/Math 2>/dev/null || true