aboutsummaryrefslogtreecommitdiff
path: root/math
diff options
context:
space:
mode:
authorGreg Lewis <glewis@FreeBSD.org>2002-11-08 03:47:27 +0000
committerGreg Lewis <glewis@FreeBSD.org>2002-11-08 03:47:27 +0000
commitb66271640fd28c053da61f5f6dfc25ce30e6b85b (patch)
treee84ed71748b664339796a1ecf06acafc39ba2c83 /math
parent56fd26fcea36bc9afc1bce13f721fcbee11bb75c (diff)
downloadports-b66271640fd28c053da61f5f6dfc25ce30e6b85b.tar.gz
ports-b66271640fd28c053da61f5f6dfc25ce30e6b85b.zip
(1) Remove dependency on and support for linking with gd. Gnuplot is only
interested in gd for making gifs. gd hasn't done this since around version 1.4 IIRC (we're now at 1.8.4). (2) Detect libpng correctly (this is fixed slightly differently than the PR). PR: 45035 Submitted by: Oliver Eikemeier <eikemeier@fillmore-labs.com> (2)
Notes
Notes: svn path=/head/; revision=69708
Diffstat (limited to 'math')
-rw-r--r--math/gnuplot/Makefile10
1 files changed, 4 insertions, 6 deletions
diff --git a/math/gnuplot/Makefile b/math/gnuplot/Makefile
index c76ced06e935..cf46c707ac74 100644
--- a/math/gnuplot/Makefile
+++ b/math/gnuplot/Makefile
@@ -13,21 +13,19 @@ MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= chuckr@FreeBSD.org
-LIB_DEPENDS= png.5:${PORTSDIR}/graphics/png \
- gd.2:${PORTSDIR}/graphics/gd
+LIB_DEPENDS= png.5:${PORTSDIR}/graphics/png
.if !defined(WITHOUT_X11)
USE_XLIB= yes
.endif
GNU_CONFIGURE= yes
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${LOCALBASE}/include/gd"
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include"
CONFIGURE_ARGS= --exec-prefix=${PREFIX} \
--includedir=${LOCALBASE}/include/ \
--libdir=${LOCALBASE}/lib \
- --without-linux-vga \
- --with-gd=${LOCALBASE}/lib \
- --with-readline=gnu --with-lasergnu --with-png
+ --without-linux-vga --without-gd \
+ --with-readline=gnu --with-lasergnu --with-png=${LOCALBASE}
.if defined(WITHOUT_X11)
CONFIGURE_ARGS+= --without-x