aboutsummaryrefslogtreecommitdiff
path: root/math
diff options
context:
space:
mode:
authorSergey Matveychuk <sem@FreeBSD.org>2005-06-23 11:53:28 +0000
committerSergey Matveychuk <sem@FreeBSD.org>2005-06-23 11:53:28 +0000
commit05c86adb6a705497d09493b85ef3a1661e8ca781 (patch)
tree83dd4850248d3139160a5417462b6171966bd66b /math
parent3da6f159dc2b521cb10d182ab25d20cf167b537a (diff)
downloadports-05c86adb6a705497d09493b85ef3a1661e8ca781.tar.gz
ports-05c86adb6a705497d09493b85ef3a1661e8ca781.zip
Aamath is a program that reads mathematical expressions in infix notation and
renders them as ASCII art. It may be useful to send mathematics through text-only media, such as e-mail or newsgroups. PR: ports/82552 Submitted by: Vsevolod Stakhov <vsevolod@highsecure.ru>
Notes
Notes: svn path=/head/; revision=137923
Diffstat (limited to 'math')
-rw-r--r--math/Makefile1
-rw-r--r--math/aamath/Makefile25
-rw-r--r--math/aamath/distinfo2
-rw-r--r--math/aamath/files/patch-Makefile17
-rw-r--r--math/aamath/pkg-descr5
5 files changed, 50 insertions, 0 deletions
diff --git a/math/Makefile b/math/Makefile
index c0add791b1ff..1e94089c7bc0 100644
--- a/math/Makefile
+++ b/math/Makefile
@@ -6,6 +6,7 @@
SUBDIR += GiNaC
SUBDIR += PDL
SUBDIR += R
+ SUBDIR += aamath
SUBDIR += abs
SUBDIR += add
SUBDIR += algae
diff --git a/math/aamath/Makefile b/math/aamath/Makefile
new file mode 100644
index 000000000000..e4e0bb635261
--- /dev/null
+++ b/math/aamath/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: aamath
+# Date created: 2005-06-23
+# Whom: Vsevolod Stakhov <vsevolod@highsecure.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= aamath
+PORTVERSION= 0.3
+CATEGORIES= math textproc
+MASTER_SITES= http://fuse.superglue.se/aamath/
+
+MAINTAINER= vsevolod@highsecure.ru
+COMMENT= Aamath is a tool for rendering mathematical expressions to ascii art
+
+WRKSRC= ${WRKDIR}/${PORTNAME}
+
+PLIST_FILES+= bin/${PORTNAME}
+MAN1= aamath.1
+
+do-install:
+ @${INSTALL_SCRIPT} ${WRKSRC}/aamath ${PREFIX}/bin
+ @${INSTALL_DATA} ${WRKSRC}/${MAN1} ${MAN1PREFIX}/man/man1
+
+.include <bsd.port.mk>
diff --git a/math/aamath/distinfo b/math/aamath/distinfo
new file mode 100644
index 000000000000..2b5d9820613f
--- /dev/null
+++ b/math/aamath/distinfo
@@ -0,0 +1,2 @@
+MD5 (aamath-0.3.tar.gz) = f0e835bd06069b1bdaddd9e9c3447c12
+SIZE (aamath-0.3.tar.gz) = 21894
diff --git a/math/aamath/files/patch-Makefile b/math/aamath/files/patch-Makefile
new file mode 100644
index 000000000000..8c178c8fdd50
--- /dev/null
+++ b/math/aamath/files/patch-Makefile
@@ -0,0 +1,17 @@
+--- Makefile.orig Thu Jun 23 00:12:18 2005
++++ Makefile Thu Jun 23 15:08:04 2005
+@@ -3,7 +3,7 @@
+ CXXFILES = parser.cc lexer.cc expr.cc canvas.cc aamath.cc
+ OBJS = $(CXXFILES:.cc=.o)
+ TARGET = aamath
+-CFLAGS = -Wall -O2 -g -DUSE_READLINE
++CFLAGS ?= -Wall -O2 -g -DUSE_READLINE
+ LFLAGS = -g
+ LIBS = -lreadline -ltermcap
+
+@@ -21,3 +21,5 @@
+
+ clean:
+ rm -f *.o lexer.cc parser.h parser.cc $(TARGET)
++
++all: $(TARGET)
diff --git a/math/aamath/pkg-descr b/math/aamath/pkg-descr
new file mode 100644
index 000000000000..2a87b169dcf6
--- /dev/null
+++ b/math/aamath/pkg-descr
@@ -0,0 +1,5 @@
+Aamath is a program that reads mathematical expressions in infix notation and
+renders them as ASCII art. It may be useful to send mathematics through
+text-only media, such as e-mail or newsgroups.
+
+WWW: http://fuse.superglue.se/aamath/