aboutsummaryrefslogtreecommitdiff
path: root/math
diff options
context:
space:
mode:
authorBrendan Fabeny <bf@FreeBSD.org>2010-12-30 23:38:48 +0000
committerBrendan Fabeny <bf@FreeBSD.org>2010-12-30 23:38:48 +0000
commit3a72b4d3d7a0d3b6b61e2af51589777e30135440 (patch)
tree39bb14b0741b354d2f1de3dafb556225372e807e /math
parentacfa26a12d97a33d1b0a813e30a14cef2044cd19 (diff)
downloadports-3a72b4d3d7a0d3b6b61e2af51589777e30135440.tar.gz
ports-3a72b4d3d7a0d3b6b61e2af51589777e30135440.zip
update to 1.8.0
Approved by: makc, miwi (mentors, implicit)
Notes
Notes: svn path=/head/; revision=267181
Diffstat (limited to 'math')
-rw-r--r--math/unuran/Makefile10
-rw-r--r--math/unuran/distinfo5
-rw-r--r--math/unuran/files/patch-src__utils__stream.c10
-rw-r--r--math/unuran/pkg-plist2
4 files changed, 9 insertions, 18 deletions
diff --git a/math/unuran/Makefile b/math/unuran/Makefile
index d3bb9f02d779..026b9d3b4f1d 100644
--- a/math/unuran/Makefile
+++ b/math/unuran/Makefile
@@ -6,16 +6,17 @@
#
PORTNAME= unuran
-PORTVERSION= 1.7.1
+PORTVERSION= 1.8.0
CATEGORIES= math
MASTER_SITES= http://statmath.wu-wien.ac.at/unuran/ \
- LOCAL/wen
+ LOCAL/bf
MAINTAINER= bf@FreeBSD.org
COMMENT= Universal Non-Uniform RANdom number generators
LIB_DEPENDS= rngstreams:${PORTSDIR}/math/rngstreams
+LICENSE= GPLv2
USE_GMAKE= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --enable-shared --with-urng-rngstream --with-urng-default=rngstream \
@@ -23,14 +24,15 @@ CONFIGURE_ARGS= --enable-shared --with-urng-rngstream --with-urng-default=rngstr
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
+MAKE_ENV= MAKE="${GMAKE}"
USE_LDCONFIG= yes
INFO= unuran
PORTDOCS= unuran.pdf unuran.txt
post-patch:
- ${FIND} -X ${WRKSRC} -name 'Makefile.in' | ${XARGS} ${REINPLACE_CMD} -e \
- 's/sinclude/#sinclude/g'
+ ${REINPLACE_CMD} -e '/UNURANFULLCHECK=true make check/s/make/${GMAKE}/' \
+ ${WRKSRC}/Makefile.in
.ifndef(NOPORTDOCS)
post-install:
diff --git a/math/unuran/distinfo b/math/unuran/distinfo
index 07aa840db9ae..92c7f23994ee 100644
--- a/math/unuran/distinfo
+++ b/math/unuran/distinfo
@@ -1,3 +1,2 @@
-MD5 (unuran-1.7.1.tar.gz) = 5b477d5d2d566738733bc7b999f1fd32
-SHA256 (unuran-1.7.1.tar.gz) = 0d04bdef1f9b958738484672a42f58d5fbf7885267c608f7bb64d5ef84b481c3
-SIZE (unuran-1.7.1.tar.gz) = 4248672
+SHA256 (unuran-1.8.0.tar.gz) = da5c8255d4743e90a46e792dcba9d149c645423cf52e1548a554cd6f66c40c53
+SIZE (unuran-1.8.0.tar.gz) = 4274481
diff --git a/math/unuran/files/patch-src__utils__stream.c b/math/unuran/files/patch-src__utils__stream.c
deleted file mode 100644
index 16b02f7f54d9..000000000000
--- a/math/unuran/files/patch-src__utils__stream.c
+++ /dev/null
@@ -1,10 +0,0 @@
---- src/utils/stream.c.orig 2009-06-23 04:04:56.000000000 -0400
-+++ src/utils/stream.c 2009-06-23 04:21:12.000000000 -0400
-@@ -329,6 +329,7 @@
-
- /* o.k. */
- *ar = data;
-+ fclose(fp);
- return n_data;
-
- /* ------------------------------------------------------- */
diff --git a/math/unuran/pkg-plist b/math/unuran/pkg-plist
index 2be67124336a..3eaf1ef8a9df 100644
--- a/math/unuran/pkg-plist
+++ b/math/unuran/pkg-plist
@@ -6,4 +6,4 @@ include/unuran_urng_rngstreams.h
lib/libunuran.a
lib/libunuran.la
lib/libunuran.so
-lib/libunuran.so.14
+lib/libunuran.so.15