aboutsummaryrefslogtreecommitdiff
path: root/math
diff options
context:
space:
mode:
authorWen Heping <wen@FreeBSD.org>2010-04-19 09:19:19 +0000
committerWen Heping <wen@FreeBSD.org>2010-04-19 09:19:19 +0000
commit9531afff4332f60b89f43922a32be622fe0cd12f (patch)
treecffe727b78104327680d43a9a898afb55f8b4270 /math
parent181dc314240874352560879628543c32264fd220 (diff)
downloadports-9531afff4332f60b89f43922a32be622fe0cd12f.tar.gz
ports-9531afff4332f60b89f43922a32be622fe0cd12f.zip
- Update to 1.5.3
- Pass maintainership to submitter PR: ports/145771 Submitted by: Ashish SHUKLA <wahjava@gmail.com>
Notes
Notes: svn path=/head/; revision=252900
Diffstat (limited to 'math')
-rw-r--r--math/eukleides/Makefile52
-rw-r--r--math/eukleides/distinfo6
-rw-r--r--math/eukleides/files/patch-Config35
-rw-r--r--math/eukleides/files/patch-build_Makefile20
-rw-r--r--math/eukleides/files/patch-build_Makefile~20
-rw-r--r--math/eukleides/files/patch-man_Makefile20
-rw-r--r--math/eukleides/files/patch-parser.y21
-rw-r--r--math/eukleides/pkg-plist35
8 files changed, 142 insertions, 67 deletions
diff --git a/math/eukleides/Makefile b/math/eukleides/Makefile
index 2e70a71271ec..5e7948052720 100644
--- a/math/eukleides/Makefile
+++ b/math/eukleides/Makefile
@@ -7,41 +7,53 @@
#
PORTNAME= eukleides
-PORTVERSION= 1.0.3
-PORTREVISION= 5
+PORTVERSION= 1.5.3
CATEGORIES= math
-MASTER_SITES= http://www.eukleides.org/download/
-DISTNAME= ${PORTNAME}.${PORTVERSION}
+MASTER_SITES= http://www.eukleides.org/files/
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= wahjava@gmail.com
COMMENT= A Euclidean geometry drawing language
+LIB_DEPENDS= readline.6:${PORTSDIR}/devel/readline
RUN_DEPENDS= pstoedit:${PORTSDIR}/graphics/pstoedit \
epstopdf:${PORTSDIR}/print/teTeX-base
+USE_BZIP2= yes
USE_BISON= build
USE_GMAKE= yes
-MAKE_ARGS= CC="${CC}" CFLAGS="${CFLAGS} -c"
-ALL_TARGET= eukleides info
+USE_GETTEXT= yes
+USE_ICONV= yes
-MAN1= eukleides.1
-MLINKS= eukleides.1 euk2eps.1 \
- eukleides.1 euk2edit.1
+MAN1= eukleides.1 euktoeps.1 euktopdf.1 euktopst.1 euktotex.1
+PORTEXAMPLES= greenwich.euk sundial.euk vonkoch.euk
+
+.ifndef NOPORTDOCS
+BUILD_DEPENDS= pdflatex:${PORTSDIR}/print/teTeX-base
+PORTDOCS= de.pdf fr.pdf
INFO= eukleides
+.endif
post-patch:
${GREP} -lR "#!/bin/bash" ${WRKSRC} | ${XARGS} ${REINPLACE_CMD} -e \
's|#!/bin/bash|#!/bin/sh|g'
-
-do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/eukleides ${PREFIX}/bin
- ${INSTALL_SCRIPT} ${WRKSRC}/euk2edit ${PREFIX}/bin
- ${INSTALL_SCRIPT} ${WRKSRC}/euk2eps ${PREFIX}/bin
- ${INSTALL_MAN} ${WRKSRC}/eukleides.1 ${MANPREFIX}/man/man1
- ${INSTALL_DATA} ${WRKSRC}/eukleides.info ${PREFIX}/${INFO_PATH}
-.if !defined(NOPORTDOCS)
- @${MKDIR} ${EXAMPLESDIR}
- ${INSTALL_DATA} ${WRKSRC}/samples/*.euk ${EXAMPLESDIR}
+ ${GREP} -lR "ginstall-info" ${WRKSRC} | ${XARGS} ${REINPLACE_CMD} -e \
+ 's|ginstall-info|install-info|g'
+ ${GREP} -lR "%%[[:alpha:]]\+%%" ${WRKSRC} |${XARGS} ${REINPLACE_CMD} \
+ -e "s|%%PREFIX%%|${PREFIX}|g" \
+ -e "s|%%LOCALBASE%%|${LOCALBASE}|g" \
+ -e "s|%%EXAMPLESDIR%%|${EXAMPLESDIR}|g" \
+ -e "s|%%DOCSDIR%%|${DOCSDIR}|g"
+.ifdef NOPORTDOCS
+ ${REINPLACE_CMD} -e '/^install:/ s/install_doc//g' \
+ -e '/^all:/ s/doc//g' ${WRKSRC}/Makefile
.endif
+pre-install:
+ ${MKDIR} ${EXAMPLESDIR}
+
+post-install:
+ for i in euktoeps euktopdf euktotex; do \
+ ${RM} ${PREFIX}/bin/$${i}.bak; \
+ done
+
.include <bsd.port.mk>
diff --git a/math/eukleides/distinfo b/math/eukleides/distinfo
index 2cfa86fbcd1a..519465c50345 100644
--- a/math/eukleides/distinfo
+++ b/math/eukleides/distinfo
@@ -1,3 +1,3 @@
-MD5 (eukleides.1.0.3.tar.gz) = a0ab145109bd3804d9550b3bf3306c05
-SHA256 (eukleides.1.0.3.tar.gz) = 13d1f959c3c352939d763db96f0aac6be286825919cc156c3c702624a0e53fb0
-SIZE (eukleides.1.0.3.tar.gz) = 50915
+MD5 (eukleides-1.5.3.tar.bz2) = 5bcc9c18b3565100010456079937f01a
+SHA256 (eukleides-1.5.3.tar.bz2) = a9c2f08497d3cb48832fb332784fb4f53a0b1e38f98ce44031773873d97ac32c
+SIZE (eukleides-1.5.3.tar.bz2) = 77439
diff --git a/math/eukleides/files/patch-Config b/math/eukleides/files/patch-Config
new file mode 100644
index 000000000000..760e10d83e24
--- /dev/null
+++ b/math/eukleides/files/patch-Config
@@ -0,0 +1,35 @@
+
+$FreeBSD$
+
+--- Config.orig
++++ Config
+@@ -2,13 +2,13 @@
+ # Copyright (c) Christian Obrecht 2004-2010
+
+ # Installation prefix
+-PREFIX=/usr/local
++PREFIX=%%PREFIX%%
+
+ BINARIES = eukleides euktopst
+
+ # Localized keywords
+ # Uncomment to enable this feature.
+-# LOCALES = de fr
++LOCALES = de fr
+
+ # Documentation
+ # Alternative targets are 'pdf' and 'html'.
+@@ -27,9 +27,9 @@
+ BIN_DIR = $(PREFIX)/bin
+ SHARE_DIR = $(PREFIX)/share
+ MO_DIR = $(SHARE_DIR)/locale
+-DOC_DIR = $(SHARE_DIR)/doc/eukleides
+-EXM_DIR = $(DOC_DIR)/examples
+-MAN_DIR = $(SHARE_DIR)/man/man1
+-INFO_DIR = $(SHARE_DIR)/info
++DOC_DIR = %%DOCSDIR%%
++EXM_DIR = %%EXAMPLESDIR%%
++MAN_DIR = $(PREFIX)/man/man1
++INFO_DIR = $(PREFIX)/info
+ TEX_DIR = $(SHARE_DIR)/texmf/tex/latex/eukleides
+
diff --git a/math/eukleides/files/patch-build_Makefile b/math/eukleides/files/patch-build_Makefile
new file mode 100644
index 000000000000..29ea5058f98a
--- /dev/null
+++ b/math/eukleides/files/patch-build_Makefile
@@ -0,0 +1,20 @@
+
+$FreeBSD$
+
+--- build/Makefile.orig
++++ build/Makefile
+@@ -12,12 +12,12 @@
+ YACC = bison
+ YFLAGS = -d
+ CC = gcc
+-IFLAGS = -I$(COMMON_DIR) -I$(MAIN_DIR) -I$(BUILD_DIR)
++IFLAGS = -I$(COMMON_DIR) -I$(MAIN_DIR) -I$(BUILD_DIR) "-I%%LOCALBASE%%/include"
+ ifneq ($(strip $(LOCALES)),)
+ MOFLAGS = -DMO_DIR=\"$(MO_DIR)\"
+ endif
+ CFLAGS = -Wall -D__$(BINARY)__ $(IFLAGS) $(MOFLAGS)
+-LDFLAGS = -lncurses -lreadline -lm
++LDFLAGS = -lncurses -lreadline -lm "-L%%LOCALBASE%%/lib" -lintl
+ VPATH = $(COMMON_DIR):$(MAIN_DIR):$(BUILD_DIR)
+
+ $(BINARY):
diff --git a/math/eukleides/files/patch-build_Makefile~ b/math/eukleides/files/patch-build_Makefile~
new file mode 100644
index 000000000000..12e3ccf9534f
--- /dev/null
+++ b/math/eukleides/files/patch-build_Makefile~
@@ -0,0 +1,20 @@
+
+$FreeBSD$
+
+--- build/Makefile.orig
++++ build/Makefile
+@@ -12,12 +12,12 @@
+ YACC = bison
+ YFLAGS = -d
+ CC = gcc
+-IFLAGS = -I$(COMMON_DIR) -I$(MAIN_DIR) -I$(BUILD_DIR)
++IFLAGS = -I$(COMMON_DIR) -I$(MAIN_DIR) -I$(BUILD_DIR) "-I%%LOCALBASE%%/../include" "-I%%LOCALBASE%%/include"
+ ifneq ($(strip $(LOCALES)),)
+ MOFLAGS = -DMO_DIR=\"$(MO_DIR)\"
+ endif
+ CFLAGS = -Wall -D__$(BINARY)__ $(IFLAGS) $(MOFLAGS)
+-LDFLAGS = -lncurses -lreadline -lm
++LDFLAGS = -lncurses -lreadline -lm "-L%%LOCALBASE%%/lib" -lintl
+ VPATH = $(COMMON_DIR):$(MAIN_DIR):$(BUILD_DIR)
+
+ $(BINARY):
diff --git a/math/eukleides/files/patch-man_Makefile b/math/eukleides/files/patch-man_Makefile
new file mode 100644
index 000000000000..29b9fe8ab052
--- /dev/null
+++ b/math/eukleides/files/patch-man_Makefile
@@ -0,0 +1,20 @@
+
+$FreeBSD$
+
+--- man/Makefile.orig
++++ man/Makefile
+@@ -3,13 +3,10 @@
+
+ include ../Config
+
+-MAN_PAGES := $(addsuffix .gz, $(wildcard *.1))
++MAN_PAGES := $(wildcard *.1)
+
+ man: $(MAN_PAGES)
+
+-%.1.gz: %.1
+- @gzip -c $< > $@
+-
+ install: $(MAN_PAGES)
+ @install -d $(MAN_DIR)
+ @install -m 0644 $^ $(MAN_DIR)
diff --git a/math/eukleides/files/patch-parser.y b/math/eukleides/files/patch-parser.y
deleted file mode 100644
index 04a847df16de..000000000000
--- a/math/eukleides/files/patch-parser.y
+++ /dev/null
@@ -1,21 +0,0 @@
---- parser.y.orig 2009-03-13 18:38:32.000000000 +0100
-+++ parser.y 2009-03-13 18:38:19.000000000 +0100
-@@ -29,7 +29,6 @@
- int warning(char *);
- int yyerror(char *);
-
--int drawing_style = FULL;
- symrec* tracevar;
- double tracestep, tracebegin;
- int tracestyle, traceind = -1;
-@@ -93,6 +92,10 @@
- %type <flag> drawing_flag segment_marking_flag angle_marking_flag color_flag
- %type <string> ident
-
-+%{
-+int drawing_style = FULL;
-+%}
-+
- %%
-
- input:
diff --git a/math/eukleides/pkg-plist b/math/eukleides/pkg-plist
index a30e1ecee681..48da7c32e81e 100644
--- a/math/eukleides/pkg-plist
+++ b/math/eukleides/pkg-plist
@@ -1,24 +1,13 @@
-bin/euk2edit
-bin/euk2eps
bin/eukleides
-%%PORTDOCS%%%%EXAMPLESDIR%%/abdul_al_wafa.euk
-%%PORTDOCS%%%%EXAMPLESDIR%%/agnesi.euk
-%%PORTDOCS%%%%EXAMPLESDIR%%/angles.euk
-%%PORTDOCS%%%%EXAMPLESDIR%%/archimedes.euk
-%%PORTDOCS%%%%EXAMPLESDIR%%/bisectors.euk
-%%PORTDOCS%%%%EXAMPLESDIR%%/gravity_center.euk
-%%PORTDOCS%%%%EXAMPLESDIR%%/inequality.euk
-%%PORTDOCS%%%%EXAMPLESDIR%%/intercept.euk
-%%PORTDOCS%%%%EXAMPLESDIR%%/intersection.euk
-%%PORTDOCS%%%%EXAMPLESDIR%%/lines_and_circles.euk
-%%PORTDOCS%%%%EXAMPLESDIR%%/locus.euk
-%%PORTDOCS%%%%EXAMPLESDIR%%/morley.euk
-%%PORTDOCS%%%%EXAMPLESDIR%%/orthocenter.euk
-%%PORTDOCS%%%%EXAMPLESDIR%%/parallelogram.euk
-%%PORTDOCS%%%%EXAMPLESDIR%%/pascal.euk
-%%PORTDOCS%%%%EXAMPLESDIR%%/perdigal.euk
-%%PORTDOCS%%%%EXAMPLESDIR%%/pstexample.euk
-%%PORTDOCS%%%%EXAMPLESDIR%%/quadrilateral.euk
-%%PORTDOCS%%%%EXAMPLESDIR%%/similar.euk
-%%PORTDOCS%%%%EXAMPLESDIR%%/vecten.euk
-%%PORTDOCS%%@dirrm %%EXAMPLESDIR%%
+bin/euktoeps
+bin/euktopdf
+bin/euktopst
+bin/euktotex
+share/locale/de/LC_MESSAGES/eukleides.mo
+share/locale/fr/LC_MESSAGES/eukleides.mo
+share/texmf/tex/latex/eukleides/eukleides.sty
+share/texmf/tex/latex/eukleides/eukleides.tex
+@dirrm share/texmf/tex/latex/eukleides
+@dirrmtry share/texmf/tex/latex
+@dirrmtry share/texmf/tex
+@dirrmtry share/texmf