aboutsummaryrefslogtreecommitdiff
path: root/math
diff options
context:
space:
mode:
authorMartin Matuska <mm@FreeBSD.org>2010-04-25 19:27:08 +0000
committerMartin Matuska <mm@FreeBSD.org>2010-04-25 19:27:08 +0000
commitbde42a038531224b74d0d14bc007bfc6b9adc839 (patch)
tree17a976c794ad595cb77f62b6c5bb2b9c61ae95ef /math
parent9edb10042ae6148ed23f18b1f7072eaea3ef93c0 (diff)
downloadports-bde42a038531224b74d0d14bc007bfc6b9adc839.tar.gz
ports-bde42a038531224b74d0d14bc007bfc6b9adc839.zip
- Fix gmp version 5 support for php52
PR: ports/146041 Submitted by: myself Approved by: maintainer
Notes
Notes: svn path=/head/; revision=253240
Diffstat (limited to 'math')
-rw-r--r--math/php52-gmp/Makefile2
-rw-r--r--math/php52-gmp/files/patch-gmp.c11
2 files changed, 13 insertions, 0 deletions
diff --git a/math/php52-gmp/Makefile b/math/php52-gmp/Makefile
index d48e2865920f..750ab322ddbd 100644
--- a/math/php52-gmp/Makefile
+++ b/math/php52-gmp/Makefile
@@ -5,6 +5,8 @@
# $FreeBSD$
#
+PORTREVISION= 1
+
CATEGORIES= math
MASTERDIR= ${.CURDIR}/../../lang/php52
diff --git a/math/php52-gmp/files/patch-gmp.c b/math/php52-gmp/files/patch-gmp.c
new file mode 100644
index 000000000000..7d137f0e827e
--- /dev/null
+++ b/math/php52-gmp/files/patch-gmp.c
@@ -0,0 +1,11 @@
+--- gmp.c.orig 2010-04-21 22:00:31.841602968 +0000
++++ gmp.c 2010-04-21 22:00:46.412804473 +0000
+@@ -1396,7 +1396,7 @@
+
+ GMPG(rand_initialized) = 1;
+ }
+- mpz_urandomb(*gmpnum_result, GMPG(rand_state), GMP_ABS (limiter) * __GMP_BITS_PER_MP_LIMB);
++ mpz_urandomb(*gmpnum_result, GMPG(rand_state), GMP_ABS (limiter) * GMP_LIMB_BITS);
+
+ ZEND_REGISTER_RESOURCE(return_value, gmpnum_result, le_gmp);
+ }