aboutsummaryrefslogtreecommitdiff
path: root/math
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2004-03-07 16:41:00 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2004-03-07 16:41:00 +0000
commit0ebb8e91940e2944443be3b4a54fa6b294af1972 (patch)
tree98d5377cd0fb65c330db6344f84882b50d01d1db /math
parentabbf5f79157616aa03c499fd787910c4e2b87099 (diff)
downloadports-0ebb8e91940e2944443be3b4a54fa6b294af1972.tar.gz
ports-0ebb8e91940e2944443be3b4a54fa6b294af1972.zip
- Update to version 1.0.2
PR: ports/63880 Submitted by: Ports Fury
Notes
Notes: svn path=/head/; revision=103205
Diffstat (limited to 'math')
-rw-r--r--math/mtrxmath/Makefile24
-rw-r--r--math/mtrxmath/distinfo4
-rw-r--r--math/mtrxmath/files/patch-Makefile18
-rw-r--r--math/mtrxmath/files/patch-mtrxmath.c11
-rw-r--r--math/mtrxmath/files/patch-mult.c10
-rw-r--r--math/mtrxmath/pkg-descr2
-rw-r--r--math/mtrxmath/pkg-plist2
7 files changed, 30 insertions, 41 deletions
diff --git a/math/mtrxmath/Makefile b/math/mtrxmath/Makefile
index 8f5914fb2a23..1f5f594cb73e 100644
--- a/math/mtrxmath/Makefile
+++ b/math/mtrxmath/Makefile
@@ -5,21 +5,25 @@
# $FreeBSD$
#
-PORTNAME= mtrxmath
-PORTVERSION= 0.9.3
-PORTREVISION= 1
-CATEGORIES= math
-MASTER_SITES= http://www.angelfire.com/linux/linuxjeff/mtrxmath/files/
+PORTNAME= mtrxmath
+PORTVERSION= 1.0.2
+CATEGORIES= math
+MASTER_SITES= http://www.angelfire.com/linux/linuxjeff/mtrxmath/files/
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= ports@FreeBSD.org
COMMENT= A small tool for matrix mathemetics
-USE_GETOPT_LONG=yes
-MAKE_ENV= CPPFLAGS="${CPPFLAGS}" \
- LDFLAGS="${LDFLAGS}"
+USE_GETOPT_LONG= yes
+MAKE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
+
+PORTDOCS= README
+PLIST_FILES= bin/mtrxmath
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/mtrxmath ${PREFIX}/bin
- ${INSTALL_DATA} ${WRKSRC}/README ${PREFIX}/share/README.mtrxmath
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
+.endif
.include <bsd.port.mk>
diff --git a/math/mtrxmath/distinfo b/math/mtrxmath/distinfo
index 1c6f55229115..230546ca25a4 100644
--- a/math/mtrxmath/distinfo
+++ b/math/mtrxmath/distinfo
@@ -1,2 +1,2 @@
-MD5 (mtrxmath-0.9.3.tar.gz) = 3cece8368ef32e8fe39a6b7774e2bc14
-SIZE (mtrxmath-0.9.3.tar.gz) = 13479
+MD5 (mtrxmath-1.0.2.tar.gz) = 7061de720440c470c83c322e7b6d0307
+SIZE (mtrxmath-1.0.2.tar.gz) = 15889
diff --git a/math/mtrxmath/files/patch-Makefile b/math/mtrxmath/files/patch-Makefile
index f096036dd594..a28360d8b6e3 100644
--- a/math/mtrxmath/files/patch-Makefile
+++ b/math/mtrxmath/files/patch-Makefile
@@ -1,12 +1,18 @@
---- Makefile.orig Mon Jan 8 08:29:11 2001
-+++ Makefile Sun Jul 6 20:09:15 2003
-@@ -1,4 +1,4 @@
--CFLAGS=-Wall -g
-+CFLAGS+=-Wall -g ${CPPFLAGS}
+--- Makefile.orig Mon Apr 9 10:26:51 2001
++++ Makefile Sun Mar 7 12:06:36 2004
+@@ -1,10 +1,9 @@
+ # Edited for Debian GNU/Linux
+ DESTDIR=
+-CFLAGS=-Wall
++CFLAGS+=-Wall ${CPPFLAGS}
+ IFLAGS=--owner=root --group=root
+ BASEPATH=${DESTDIR}/usr
+ BINPATH=${BASEPATH}/bin
+-MANPATH=${BASEPATH}/share/man/man1
SRCS=add.c mtrxmath.c mult.c sub.c inverse.c
-@@ -8,7 +8,7 @@
+@@ -14,7 +13,7 @@
all: ${EXE}
${EXE}: ${OBJS}
diff --git a/math/mtrxmath/files/patch-mtrxmath.c b/math/mtrxmath/files/patch-mtrxmath.c
deleted file mode 100644
index d3533f877408..000000000000
--- a/math/mtrxmath/files/patch-mtrxmath.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- mtrxmath.c.orig Tue Jan 9 20:44:12 2001
-+++ mtrxmath.c Tue Jan 9 20:44:00 2001
-@@ -102,7 +102,7 @@
- exit(0);
- }
- if (cmdopt==INVERT) {
-- final == inverse(foo);
-+ final = inverse(foo);
- show_matrix(final);
- exit(0);
- }
diff --git a/math/mtrxmath/files/patch-mult.c b/math/mtrxmath/files/patch-mult.c
deleted file mode 100644
index da4b9c88257d..000000000000
--- a/math/mtrxmath/files/patch-mult.c
+++ /dev/null
@@ -1,10 +0,0 @@
---- mult.c.orig Tue Jan 9 20:40:21 2001
-+++ mult.c Tue Jan 9 20:40:28 2001
-@@ -11,7 +11,6 @@
- #include <stdio.h>
- #include <stdlib.h>
- #include <string.h>
--#include <malloc.h>
- #include "mtrxmath.h"
-
- MATRIX_PTR matrix_multiply( MATRIX_PTR first, MATRIX_PTR second)
diff --git a/math/mtrxmath/pkg-descr b/math/mtrxmath/pkg-descr
index c035d978bca1..3121b42bafa8 100644
--- a/math/mtrxmath/pkg-descr
+++ b/math/mtrxmath/pkg-descr
@@ -3,5 +3,7 @@ matrices of any size. It supports addition, subtraction,
multiplication, inversion, division, and will support whatever else is
necessary.
+WWW: http://www.angelfire.com/linux/linuxjeff/mtrxmath/
+
- George Reid
greid@ukug.uk.freebsd.org
diff --git a/math/mtrxmath/pkg-plist b/math/mtrxmath/pkg-plist
deleted file mode 100644
index fef81d6874b3..000000000000
--- a/math/mtrxmath/pkg-plist
+++ /dev/null
@@ -1,2 +0,0 @@
-bin/mtrxmath
-share/README.mtrxmath