aboutsummaryrefslogtreecommitdiff
path: root/math
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2001-11-26 13:18:55 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2001-11-26 13:18:55 +0000
commit8408ed8657475f978f43d085fd220f2a4e29e271 (patch)
tree3c49a8277901ced46332cf890229e0fdb2a4a787 /math
parentd4634bbee230a3c17214b517917c3255d28265e7 (diff)
downloadports-8408ed8657475f978f43d085fd220f2a4e29e271.tar.gz
ports-8408ed8657475f978f43d085fd220f2a4e29e271.zip
upgrade to 1.0.1
Notes
Notes: svn path=/head/; revision=50569
Diffstat (limited to 'math')
-rw-r--r--math/GiNaC/Makefile14
-rw-r--r--math/GiNaC/distinfo2
-rw-r--r--math/GiNaC/files/patch-ginac::numeric.cpp11
-rw-r--r--math/GiNaC/pkg-plist7
4 files changed, 27 insertions, 7 deletions
diff --git a/math/GiNaC/Makefile b/math/GiNaC/Makefile
index 9b2179172c73..b207b3657ac9 100644
--- a/math/GiNaC/Makefile
+++ b/math/GiNaC/Makefile
@@ -7,7 +7,7 @@
#
PORTNAME= GiNaC
-PORTVERSION= 0.9.0
+PORTVERSION= 1.0.1
CATEGORIES= math
MASTER_SITES= ftp://ftpthep.physik.uni-mainz.de/pub/GiNaC/ \
http://www.ginac.de/
@@ -18,7 +18,6 @@ USE_BZIP2= yes
LIB_DEPENDS= cln:${PORTSDIR}/math/cln
USE_LIBTOOL= yes
-
USE_GMAKE= yes
USE_NEWGCC= yes
@@ -26,4 +25,15 @@ INSTALLS_SHLIB= yes
MAN1= ginsh.1 viewgar.1 ginac-config.1
+post-patch:
+ @${PERL} -pi -e "s,sstream,strstream,g" ${WRKSRC}/configure
+.for file in numeric.cpp tostring.h
+ @${PERL} -pi -e "s,sstream,strstream,g ; \
+ s,stringstream,strstream,g" ${WRKSRC}/ginac/${file}
+.endfor
+
+pre-build:
+ @(cd ${WRKSRC} ; \
+ ${LN} -sf ${PREFIX}/bin/libtool)
+
.include <bsd.port.mk>
diff --git a/math/GiNaC/distinfo b/math/GiNaC/distinfo
index 06475b67b722..81b3f44eee4b 100644
--- a/math/GiNaC/distinfo
+++ b/math/GiNaC/distinfo
@@ -1 +1 @@
-MD5 (GiNaC-0.9.0.tar.bz2) = 016919dda78be4205cbc1f45aa9331bf
+MD5 (GiNaC-1.0.1.tar.bz2) = abd5b008717c00c25133e66d3190a074
diff --git a/math/GiNaC/files/patch-ginac::numeric.cpp b/math/GiNaC/files/patch-ginac::numeric.cpp
new file mode 100644
index 000000000000..817362cd1477
--- /dev/null
+++ b/math/GiNaC/files/patch-ginac::numeric.cpp
@@ -0,0 +1,11 @@
+--- ginac/numeric.cpp.orig Mon Nov 26 20:59:49 2001
++++ ginac/numeric.cpp Mon Nov 26 21:00:12 2001
+@@ -249,7 +249,7 @@
+ // Read number as string
+ std::string str;
+ if (n.find_string("number", str)) {
+- std::istringstream s(str);
++ std::istringstream s(str.c_str());
+ cln::cl_idecoded_float re, im;
+ char c;
+ s.get(c);
diff --git a/math/GiNaC/pkg-plist b/math/GiNaC/pkg-plist
index 5c9bfdf3f5fe..0f6604efc74c 100644
--- a/math/GiNaC/pkg-plist
+++ b/math/GiNaC/pkg-plist
@@ -13,6 +13,7 @@ include/ginac/expair.h
include/ginac/expairseq.h
include/ginac/exprseq.h
include/ginac/fail.h
+include/ginac/fderivative.h
include/ginac/flags.h
include/ginac/function.h
include/ginac/ginac.h
@@ -33,6 +34,7 @@ include/ginac/registrar.h
include/ginac/relational.h
include/ginac/structure.h
include/ginac/symbol.h
+include/ginac/symmetry.h
include/ginac/tensor.h
include/ginac/tinfos.h
include/ginac/version.h
@@ -48,8 +50,5 @@ info/ginac.info-5
@exec install-info %D/info/ginac.info %D/info/dir
lib/libginac.a
lib/libginac.so
-lib/libginac-0.9.so.0
+lib/libginac-1.0.so.0
share/aclocal/ginac.m4
-@dirrm share/doc/GiNaC/reference
-@dirrm share/doc/GiNaC/tutorial
-@dirrm share/doc/GiNaC