aboutsummaryrefslogtreecommitdiff
path: root/math
diff options
context:
space:
mode:
authorThierry Thomas <thierry@FreeBSD.org>2007-05-28 13:15:29 +0000
committerThierry Thomas <thierry@FreeBSD.org>2007-05-28 13:15:29 +0000
commit87ca193adea74e0d5a2b2e9e6d615e90b800caa3 (patch)
tree83ec8ae065d4ea2eb49835e7b01d12661f4b29ee /math
parentd8e8830722416ad54fe63dacd15ad5948fa8fbee (diff)
downloadports-87ca193adea74e0d5a2b2e9e6d615e90b800caa3.tar.gz
ports-87ca193adea74e0d5a2b2e9e6d615e90b800caa3.zip
The JTS Topology Suite is an API of 2D spatial predicates and functions. It has
the following design goals: * JTS conforms to the Simple Features Specification for SQL published by the Open GIS Consortium * JTS provides a complete, consistent, robust implementation of fundamental 2D spatial algorithms * JTS is fast enough for production use * JTS is written in 100% pure Java(TM) * JTS is open source (under the LGPL license) <http://www.vividsolutions.com/Jts/JTSHome.htm>
Notes
Notes: svn path=/head/; revision=192174
Diffstat (limited to 'math')
-rw-r--r--math/Makefile1
-rw-r--r--math/jts/Makefile65
-rw-r--r--math/jts/distinfo3
-rw-r--r--math/jts/files/testJTS.sh.in17
-rw-r--r--math/jts/pkg-descr12
5 files changed, 98 insertions, 0 deletions
diff --git a/math/Makefile b/math/Makefile
index f11e84215e42..69168d993e6b 100644
--- a/math/Makefile
+++ b/math/Makefile
@@ -110,6 +110,7 @@
SUBDIR += jsmath
SUBDIR += jsmath-fonts
SUBDIR += jsmath-fonts-sprite
+ SUBDIR += jts
SUBDIR += k3dsurf
SUBDIR += kash3
SUBDIR += kaskade
diff --git a/math/jts/Makefile b/math/jts/Makefile
new file mode 100644
index 000000000000..c0545a8a00cd
--- /dev/null
+++ b/math/jts/Makefile
@@ -0,0 +1,65 @@
+# New ports collection makefile for: jts
+# Date created: 22 May 2005
+# Whom: Thierry Thomas <thierry@pompo.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= jts
+PORTVERSION= 1.8.0
+CATEGORIES= math databases
+MASTER_SITES= http://www.vividsolutions.com/Jts/bin/
+
+MAINTAINER= thierry@FreeBSD.org
+COMMENT= JTS Topology Suite
+
+RUN_DEPENDS= ${JAVALIBDIR}/jdom.jar:${PORTSDIR}/java/jdom \
+ ${JAVALIBDIR}/junit.jar:${PORTSDIR}/java/junit \
+ ${JAVALIBDIR}/xml-apis.jar:${PORTSDIR}/textproc/xerces-j
+
+USE_ZIP= yes
+NO_BUILD= yes
+USE_JAVA= yes
+NO_WRKSUBDIR= yes
+
+VER= ${PORTVERSION:R}
+# Note: ATM JTS requires a deprecated jdom - to be checked when upgrading!
+JARFILES= JTS_Test acme jts-${VER} jtsio-${VER} jdom-old
+
+DOCS= "JTS Developer Guide.pdf" "JTS Technical Specs.pdf" \
+ "JTS TestBuilder & TestRunner User Guide.pdf" \
+ "JTS Version History.html"
+PORTDOCS0= ${DOCS:S| |_|g}
+PORTDOCS= ${PORTDOCS0:S|&|and|g}
+
+PLIST_FILES= ${JARFILES:S|^|%%JAVAJARDIR%%/|:S|$|.jar|:S|-${VER}||}
+
+post-extract:
+ ${MV} ${WRKSRC}/lib/jdom.jar ${WRKSRC}/lib/jdom-old.jar
+.for pdf in ${PORTDOCS0}
+ ${MV} ${WRKSRC}/doc/${pdf:S|_| |g} ${WRKSRC}/doc/${pdf}
+.endfor
+
+do-install:
+.for jar in ${JARFILES}
+ ${INSTALL_DATA} ${WRKSRC}/lib/${jar}.jar \
+ ${JAVAJARDIR}/${jar:S|-${VER}||}.jar
+.endfor
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS0:S|^|${WRKSRC}/doc/|} ${DOCSDIR}
+ ${MV} "${DOCSDIR}/JTS_TestBuilder_&_TestRunner_User_Guide.pdf" \
+ "${DOCSDIR}/JTS_TestBuilder_and_TestRunner_User_Guide.pdf"
+ @${ECHO_MSG} "===> Documentation installed in ${DOCSDIR}."
+.endif
+
+.if defined(MAINTAINER_MODE)
+regression-test: install
+ ${SED} -e 's|%%JAVAJARDIR%%|${JAVAJARDIR}|; \
+ s|%%JAVALIBDIR%%|${JAVALIBDIR}|;\
+ s|%%JAVA%%|${JAVA}|' \
+ ${FILESDIR}/testJTS.sh.in > ${WRKSRC}/testJTS.sh
+ (cd ${WRKSRC} && ${SH} ./testJTS.sh )
+.endif
+
+.include <bsd.port.mk>
diff --git a/math/jts/distinfo b/math/jts/distinfo
new file mode 100644
index 000000000000..69b0e930ee7d
--- /dev/null
+++ b/math/jts/distinfo
@@ -0,0 +1,3 @@
+MD5 (jts-1.8.0.zip) = 090b1afd304ce6578519ad0acb7fa10a
+SHA256 (jts-1.8.0.zip) = e464b44382518167a0d257f7e47b71777cd5f630d59f2b1091bc3ca739cde4cd
+SIZE (jts-1.8.0.zip) = 7765677
diff --git a/math/jts/files/testJTS.sh.in b/math/jts/files/testJTS.sh.in
new file mode 100644
index 000000000000..a2050b10863b
--- /dev/null
+++ b/math/jts/files/testJTS.sh.in
@@ -0,0 +1,17 @@
+#! /bin/sh
+# $FreeBSD$
+
+JLD="%%JAVALIBDIR%%"
+JJD="%%JAVAJARDIR%%"
+JAVA="%%JAVA%%"
+
+classpath=""
+for file in junit.jar xml-apis.jar
+do
+classpath="$JLD/$file:$classpath"
+done
+for file in JTS_Test.jar acme.jar jts.jar jtsio.jar jdom-old.jar
+do
+classpath="$JJD/$file:$classpath"
+done
+$JAVA -cp "$classpath" com.vividsolutions.jtstest.testrunner.TopologyTestApp -Files testxml/validate testxml/general
diff --git a/math/jts/pkg-descr b/math/jts/pkg-descr
new file mode 100644
index 000000000000..abe017f179bd
--- /dev/null
+++ b/math/jts/pkg-descr
@@ -0,0 +1,12 @@
+The JTS Topology Suite is an API of 2D spatial predicates and functions. It has
+the following design goals:
+
+ * JTS conforms to the Simple Features Specification for SQL published by the
+ Open GIS Consortium
+ * JTS provides a complete, consistent, robust implementation of fundamental
+ 2D spatial algorithms
+ * JTS is fast enough for production use
+ * JTS is written in 100% pure Java(TM)
+ * JTS is open source (under the LGPL license)
+
+WWW: http://www.vividsolutions.com/Jts/JTSHome.htm