aboutsummaryrefslogtreecommitdiff
path: root/math
diff options
context:
space:
mode:
authorAlan Eldridge <alane@FreeBSD.org>2002-11-27 14:23:12 +0000
committerAlan Eldridge <alane@FreeBSD.org>2002-11-27 14:23:12 +0000
commit8aa22814fd90a7103370528ac732824c4729196c (patch)
tree54e9b9c820021c822e6a31f816ab853da58912b7 /math
parentd5c9c64b2b74b3d6a285426816aba0179e97880e (diff)
downloadports-8aa22814fd90a7103370528ac732824c4729196c.tar.gz
ports-8aa22814fd90a7103370528ac732824c4729196c.zip
Patch to use autoconf the right way. Untested because I really don't want to
suck the whole gnome world onto my machine, particularly in the middle of a complete package rebuild. Approved by: kris
Notes
Notes: svn path=/head/; revision=71153
Diffstat (limited to 'math')
-rw-r--r--math/gretl/Makefile7
1 files changed, 2 insertions, 5 deletions
diff --git a/math/gretl/Makefile b/math/gretl/Makefile
index 8896fb983936..674d15e353e0 100644
--- a/math/gretl/Makefile
+++ b/math/gretl/Makefile
@@ -14,8 +14,7 @@ MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= ports@FreeBSD.org
-BUILD_DEPENDS= autoconf:${PORTSDIR}/devel/autoconf \
- gnuplot:${PORTSDIR}/math/gnuplot
+BUILD_DEPENDS= gnuplot:${PORTSDIR}/math/gnuplot
LIB_DEPENDS= gmp.6:${PORTSDIR}/math/libgmp4 \
xml2.5:${PORTSDIR}/textproc/libxml2 \
gtk-x11-2.0.0:${PORTSDIR}/x11-toolkits/gtk20
@@ -25,6 +24,7 @@ USE_X_PREFIX= yes
USE_GMAKE= yes
USE_GNOMENG= yes
GNU_CONFIGURE= yes
+USE_AUTOCONF_VER= 253
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
@@ -43,7 +43,4 @@ USE_GNOME= gnomeprefix
PLIST_SUB+= GNOME2:="" DATADIR="share/gnome"
.endif
-pre-configure:
- @cd ${CONFIGURE_WRKSRC} && ${LOCALBASE}/bin/autoconf
-
.include <bsd.port.mk>