aboutsummaryrefslogtreecommitdiff
path: root/math
diff options
context:
space:
mode:
authorAlex Dupre <ale@FreeBSD.org>2010-06-11 15:09:45 +0000
committerAlex Dupre <ale@FreeBSD.org>2010-06-11 15:09:45 +0000
commit8cbf48bd4b10e39f4f96a5a77120e40e99de8d26 (patch)
tree50f448e0fb0b8504eebaae343d466dcd9e4dd1be /math
parentf7015e22ab5c4280ed395c1e3d7cffedb479583f (diff)
downloadports-8cbf48bd4b10e39f4f96a5a77120e40e99de8d26.tar.gz
ports-8cbf48bd4b10e39f4f96a5a77120e40e99de8d26.zip
Chase mpfr library and bump PORTREVISION.
Notes
Notes: svn path=/head/; revision=256398
Diffstat (limited to 'math')
-rw-r--r--math/cgal/Makefile4
-rw-r--r--math/gretl/Makefile4
-rw-r--r--math/mpc/Makefile4
-rw-r--r--math/mpc/files/patch-src_acos.c11
-rw-r--r--math/p5-Math-MPFR/Makefile3
-rw-r--r--math/sdpa-gmp/Makefile4
-rw-r--r--math/wcalc/Makefile4
7 files changed, 23 insertions, 11 deletions
diff --git a/math/cgal/Makefile b/math/cgal/Makefile
index 2a323d35111b..0b000f3f7639 100644
--- a/math/cgal/Makefile
+++ b/math/cgal/Makefile
@@ -7,7 +7,7 @@
PORTNAME= cgal
PORTVERSION= 3.4
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= math
MASTER_SITES= http://gforge.inria.fr/frs/download.php/15692/
DISTNAME= CGAL-${PORTVERSION}
@@ -23,7 +23,7 @@ BUILD_DEPENDS= ${LOCALBASE}/include/boost/tuple/tuple.hpp:${PORTSDIR}/devel/boos
RUN_DEPENDS= ${LOCALBASE}/include/boost/tuple/tuple.hpp:${PORTSDIR}/devel/boost-libs
LIB_DEPENDS= GLU.1:${PORTSDIR}/graphics/libGLU \
gmp.10:${PORTSDIR}/math/gmp \
- mpfr.3:${PORTSDIR}/math/mpfr
+ mpfr.4:${PORTSDIR}/math/mpfr
USE_LDCONFIG= yes
USE_CMAKE= yes
diff --git a/math/gretl/Makefile b/math/gretl/Makefile
index 2595464385e4..94a4f9b8fa9b 100644
--- a/math/gretl/Makefile
+++ b/math/gretl/Makefile
@@ -8,7 +8,7 @@
PORTNAME= gretl
PORTVERSION= 1.8.7
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= math finance
MASTER_SITES= SF
@@ -17,7 +17,7 @@ COMMENT= GNU Regression, Econometrics and Time-series Library
BUILD_DEPENDS= gnuplot:${PORTSDIR}/math/gnuplot
LIB_DEPENDS= fftw3.5:${PORTSDIR}/math/fftw3 \
- mpfr.3:${PORTSDIR}/math/mpfr
+ mpfr.4:${PORTSDIR}/math/mpfr
RUN_DEPENDS= gnuplot:${PORTSDIR}/math/gnuplot
USE_BZIP2= yes
diff --git a/math/mpc/Makefile b/math/mpc/Makefile
index e790b41fd924..6f2eb2fa4813 100644
--- a/math/mpc/Makefile
+++ b/math/mpc/Makefile
@@ -7,7 +7,7 @@
PORTNAME= mpc
PORTVERSION= 0.8.1
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= math devel
MASTER_SITES= http://www.multiprecision.org/mpc/download/
@@ -15,7 +15,7 @@ MAINTAINER= gerald@FreeBSD.org
COMMENT= Library of complex numbers with arbitrarily high precision
LIB_DEPENDS= gmp.10:${PORTSDIR}/math/gmp \
- mpfr.3:${PORTSDIR}/math/mpfr
+ mpfr.4:${PORTSDIR}/math/mpfr
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-gmp=${LOCALBASE} \
diff --git a/math/mpc/files/patch-src_acos.c b/math/mpc/files/patch-src_acos.c
new file mode 100644
index 000000000000..15ffa52b44e8
--- /dev/null
+++ b/math/mpc/files/patch-src_acos.c
@@ -0,0 +1,11 @@
+--- src/acos.c.orig 2010-06-11 16:14:09.000000000 +0200
++++ src/acos.c 2010-06-11 16:14:30.000000000 +0200
+@@ -189,7 +189,7 @@
+ rnd_im = rnd_im == GMP_RNDU ? GMP_RNDD
+ : rnd_im == GMP_RNDD ? GMP_RNDU
+ #if MPFR_VERSION_MAJOR >= 3
+- : rnd_im == GMP_RNDA ? GMP_RNDZ
++ : rnd_im == MPFR_RNDA ? MPFR_RNDZ
+ #endif
+ : rnd_im;
+ rnd1 = RNDC(GMP_RNDN, rnd_im);
diff --git a/math/p5-Math-MPFR/Makefile b/math/p5-Math-MPFR/Makefile
index ba728e5f26f7..4488a2793d1d 100644
--- a/math/p5-Math-MPFR/Makefile
+++ b/math/p5-Math-MPFR/Makefile
@@ -7,6 +7,7 @@
PORTNAME= Math-MPFR
PORTVERSION= 3.0
+PORTREVISION= 1
CATEGORIES= math perl5
MASTER_SITES= CPAN
PKGNAMEPREFIX= p5-
@@ -14,7 +15,7 @@ PKGNAMEPREFIX= p5-
MAINTAINER= perl@FreeBSD.org
COMMENT= A perl interface to MPFR Library
-LIB_DEPENDS= mpfr.3:${PORTSDIR}/math/mpfr
+LIB_DEPENDS= mpfr.4:${PORTSDIR}/math/mpfr
PERL_CONFIGURE= yes
MAKE_ENV= INC="-I${LOCALBASE}/include"
diff --git a/math/sdpa-gmp/Makefile b/math/sdpa-gmp/Makefile
index 3dcdde9dda6c..80dd0abd5472 100644
--- a/math/sdpa-gmp/Makefile
+++ b/math/sdpa-gmp/Makefile
@@ -7,7 +7,7 @@
PORTNAME= sdpa-gmp
PORTVERSION= 7.1.2
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= math
MASTER_SITES= http://sdpa.indsys.chuo-u.ac.jp/sdpa/files/
DISTFILES= ${SRCFILE} ${MANUALFILE}
@@ -27,7 +27,7 @@ MANUALFILE= sdpa.${MANUALVER}.manual.${MANDATE}.pdf
GNU_CONFIGURE= yes
LIB_DEPENDS+= spooles:${PORTSDIR}/math/spooles \
gmp.10:${PORTSDIR}/math/gmp \
- mpfr.3:${PORTSDIR}/math/mpfr
+ mpfr.4:${PORTSDIR}/math/mpfr
CONFIGURE_ARGS+= --with-system-spooles
CONFIGURE_ENV+= CXXFLAGS="${CXXFLAGS} -I${LOCALBASE}/include -I${LOCALBASE}/include/spooles" CPPFLAGS="${CPPFLAGS} -I${LOCALBASE}/include -I${LOCALBASE}/include/spooles" CFLAGS="${CFLAGS} -I${LOCALBASE}/include -I${LOCALBASE}/include/spooles" LDFLAGS="-L${LOCALBASE}/lib"
diff --git a/math/wcalc/Makefile b/math/wcalc/Makefile
index f676eb20bae1..784576cc2248 100644
--- a/math/wcalc/Makefile
+++ b/math/wcalc/Makefile
@@ -7,7 +7,7 @@
PORTNAME= wcalc
PORTVERSION= 2.4
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= math
MASTER_SITES= SF/w-calc/Wcalc/${PORTVERSION}
DISTNAME= wcalc-${PORTVERSION}
@@ -16,7 +16,7 @@ MAINTAINER= amarendra.godbole@gmail.com
COMMENT= A natural-expression command-line calculator
LIB_DEPENDS= gmp.10:${PORTSDIR}/math/gmp \
- mpfr.3:${PORTSDIR}/math/mpfr
+ mpfr.4:${PORTSDIR}/math/mpfr
CFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib