aboutsummaryrefslogtreecommitdiff
path: root/mbone/rtpmon
diff options
context:
space:
mode:
authorBill Fenner <fenner@FreeBSD.org>1996-11-10 21:10:47 +0000
committerBill Fenner <fenner@FreeBSD.org>1996-11-10 21:10:47 +0000
commit80825be7fbfc05498a43e23aa676f8268034b0d1 (patch)
tree2241dca90ba377d503ba7e2a9c6e39d9d61d0724 /mbone/rtpmon
parentb59156cd49917cbb8d3932caf65353a6e84f7264 (diff)
downloadports-80825be7fbfc05498a43e23aa676f8268034b0d1.tar.gz
ports-80825be7fbfc05498a43e23aa676f8268034b0d1.zip
New port: rtpmon 1.0a5, a multicast RTP session monitor
Notes
Notes: svn path=/head/; revision=4375
Diffstat (limited to 'mbone/rtpmon')
-rw-r--r--mbone/rtpmon/Makefile24
-rw-r--r--mbone/rtpmon/distinfo1
-rw-r--r--mbone/rtpmon/files/patch-aa23
-rw-r--r--mbone/rtpmon/files/patch-ab15
-rw-r--r--mbone/rtpmon/pkg-comment1
-rw-r--r--mbone/rtpmon/pkg-descr6
-rw-r--r--mbone/rtpmon/pkg-plist2
7 files changed, 72 insertions, 0 deletions
diff --git a/mbone/rtpmon/Makefile b/mbone/rtpmon/Makefile
new file mode 100644
index 000000000000..0aa6e8d4c4e4
--- /dev/null
+++ b/mbone/rtpmon/Makefile
@@ -0,0 +1,24 @@
+# New ports collection makefile for: rtpmon
+# Version required: 1.0a5
+# Date created: 1 November 1996
+# Whom: Bill Fenner <fenner@FreeBSD.ORG>
+#
+# $Id$
+#
+
+DISTNAME= rtpmon-1.0a5
+CATEGORIES+= mbone
+MASTER_SITES= ftp://mm-ftp.cs.berkeley.edu/pub/rtpmon/
+
+MAINTAINER= fenner@FreeBSD.org
+
+LIB_DEPENDS= tk41\\.1:${PORTSDIR}/x11/tk41
+
+GNU_CONFIGURE= yes
+USE_X11= yes
+
+post-install:
+ strip ${PREFIX}/bin/rtpmon
+ ${COMPRESS_MAN} ${PREFIX}/man/man1/rtpmon.1
+
+.include <bsd.port.mk>
diff --git a/mbone/rtpmon/distinfo b/mbone/rtpmon/distinfo
new file mode 100644
index 000000000000..35ed37910aaf
--- /dev/null
+++ b/mbone/rtpmon/distinfo
@@ -0,0 +1 @@
+MD5 (rtpmon-1.0a5.tar.gz) = bfa1daf618d0cfd818e084f3abede7fa
diff --git a/mbone/rtpmon/files/patch-aa b/mbone/rtpmon/files/patch-aa
new file mode 100644
index 000000000000..21c999ab8d8a
--- /dev/null
+++ b/mbone/rtpmon/files/patch-aa
@@ -0,0 +1,23 @@
+--- configure.orig Tue Oct 22 22:32:09 1996
++++ configure Wed Nov 6 22:57:53 1996
+@@ -1609,6 +1609,7 @@
+ $prefix/lib/tcl7.6 \
+ $prefix/share/lib/tcl7.6 \
+ $x_libraries/tcl7.6 \
++ /usr/libdata/tcl \
+ $dir/lib/tcl7.5 \
+ $dir/share/lib/tcl7.5 \
+ ../tcl7.5/library \
+@@ -1951,6 +1952,12 @@
+ LDFLAGS="$LDFLAGS -L$place"
+ libtk="-ltk41"
+ fi
++
++ if test -r $place/libtk41.so.1.0 ; then
++ echo "$ac_t""$place/libtk41.so.1.0" 1>&6
++ LDFLAGS="$LDFLAGS -L$place"
++ libtk="-ltk41"
++ fi
+
+ if test "$libtk" = "no" ; then
+ if test -r $place/libtk4.2.a ; then
diff --git a/mbone/rtpmon/files/patch-ab b/mbone/rtpmon/files/patch-ab
new file mode 100644
index 000000000000..2a653b26e713
--- /dev/null
+++ b/mbone/rtpmon/files/patch-ab
@@ -0,0 +1,15 @@
+--- Makefile.in.orig Wed Nov 6 18:18:43 1996
++++ Makefile.in Wed Nov 6 18:20:40 1996
+@@ -112,5 +112,12 @@
+ rtpmon: $(OBJS)
+ $(C++) -o $@ $(LDFLAGS) $(OBJS) $(LIBS)
+
++install: rtpmon
++ cp rtpmon @prefix@/bin
++ chown bin @prefix@/bin/rtpmon
++ chgrp bin @prefix@/bin/rtpmon
++ chmod 555 @prefix@/bin/rtpmon
++ cp rtpmon.1 @prefix@/man/man1
++
+ clean:
+ rm -f *.o rtpmon config.cache config.log
diff --git a/mbone/rtpmon/pkg-comment b/mbone/rtpmon/pkg-comment
new file mode 100644
index 000000000000..535d0d11114d
--- /dev/null
+++ b/mbone/rtpmon/pkg-comment
@@ -0,0 +1 @@
+A program to montior loss in multicast sessions
diff --git a/mbone/rtpmon/pkg-descr b/mbone/rtpmon/pkg-descr
new file mode 100644
index 000000000000..48020dc00c1a
--- /dev/null
+++ b/mbone/rtpmon/pkg-descr
@@ -0,0 +1,6 @@
+Rtpmon is a third-party RTCP monitor. It can be used to monitor
+the control information exchanged between applications that implement
+RTP, the Real-Time Transport Protocol. Feedback from receivers,
+including the loss rate and jitter, are displayed in a table that
+can be sorted in various ways to help isolate and diagnose multicast
+distribution problems.
diff --git a/mbone/rtpmon/pkg-plist b/mbone/rtpmon/pkg-plist
new file mode 100644
index 000000000000..439906d7c404
--- /dev/null
+++ b/mbone/rtpmon/pkg-plist
@@ -0,0 +1,2 @@
+bin/rtpmon
+man/man1/rtpmon.1.gz