aboutsummaryrefslogtreecommitdiff
path: root/mbone
diff options
context:
space:
mode:
authorBill Fenner <fenner@FreeBSD.org>2002-09-29 18:00:33 +0000
committerBill Fenner <fenner@FreeBSD.org>2002-09-29 18:00:33 +0000
commitcf3ebcc97d37c784d8760e8fe2b891e6744c40c2 (patch)
tree02d24c0e4e905d4288d17f8f10d46e70e5692aaf /mbone
parent246717df8e9fe8e4a6c12e03006491c545e5c3c2 (diff)
downloadports-cf3ebcc97d37c784d8760e8fe2b891e6744c40c2.tar.gz
ports-cf3ebcc97d37c784d8760e8fe2b891e6744c40c2.zip
Fix broken rtpmon build.
Notes
Notes: svn path=/head/; revision=67245
Diffstat (limited to 'mbone')
-rw-r--r--mbone/rtpmon/Makefile4
-rw-r--r--mbone/rtpmon/files/patch-aa20
-rw-r--r--mbone/rtpmon/files/patch-config.h23
3 files changed, 35 insertions, 12 deletions
diff --git a/mbone/rtpmon/Makefile b/mbone/rtpmon/Makefile
index 482d5cf34e79..373068a8c944 100644
--- a/mbone/rtpmon/Makefile
+++ b/mbone/rtpmon/Makefile
@@ -8,12 +8,12 @@
PORTNAME= rtpmon
PORTVERSION= 1.0a7
PORTREVISION= 1
-CATEGORIES= mbone tk82
+CATEGORIES= mbone tk83
MASTER_SITES= ftp://mm-ftp.cs.berkeley.edu/pub/rtpmon/
MAINTAINER= fenner@FreeBSD.org
-LIB_DEPENDS= tk82.1:${PORTSDIR}/x11-toolkits/tk82
+LIB_DEPENDS= tk83.1:${PORTSDIR}/x11-toolkits/tk83
BUILD_DEPENDS= autoconf:${PORTSDIR}/devel/autoconf
GNU_CONFIGURE= yes
diff --git a/mbone/rtpmon/files/patch-aa b/mbone/rtpmon/files/patch-aa
index f794feddf129..086f814a5657 100644
--- a/mbone/rtpmon/files/patch-aa
+++ b/mbone/rtpmon/files/patch-aa
@@ -33,7 +33,7 @@
- /usr/contrib/include \
- $prefix/include \
- $x_includes"
-+ places="/usr/local/include/tcl8.2"
++ places="/usr/local/include/tcl8.3"
for place in $places ; do
if test -r $place/tcl.h ; then
@@ -74,11 +74,11 @@
- libtcl="-ltcl7.5"
- elif test -r $place/libtcl.a ; then
- AC_MSG_RESULT($place/libtcl.a)
-+ if test -r $place/libtcl82.a ; then
-+ AC_MSG_RESULT($place/libtcl82.a)
++ if test -r $place/libtcl83.a ; then
++ AC_MSG_RESULT($place/libtcl83.a)
LDFLAGS="$LDFLAGS -L$place"
- libtcl="-ltcl"
-+ libtcl="-ltcl82"
++ libtcl="-ltcl83"
fi
fi
@@ -120,7 +120,7 @@
- $prefix/lib/tcl7.5 \
- $prefix/share/lib/tcl7.5 \
- $x_libraries/tcl7.5"
-+places="/usr/local/lib/tcl8.2"
++places="/usr/local/lib/tcl8.3"
for place in $places; do
if test -r $place/init.tcl ; then
@@ -161,7 +161,7 @@
- /usr/contrib/include \
- $prefix/include \
- $x_includes"
-+ places="/usr/local/include/tk8.2"
++ places="/usr/local/include/tk8.3"
for place in $places; do
if test -r $place/tk.h ; then
@@ -206,8 +206,8 @@
- if test "$libtk" = "no" ; then
- if test -r $place/libtk4.2.a ; then
- AC_MSG_RESULT($place/libtk4.2.a)
-+ if test -r $place/libtk82.a ; then
-+ AC_MSG_RESULT($place/libtk82.a)
++ if test -r $place/libtk83.a ; then
++ AC_MSG_RESULT($place/libtk83.a)
LDFLAGS="$LDFLAGS -L$place"
- libtk="-ltk4.2"
- elif test -r $place/libtk4.1.a ; then
@@ -218,7 +218,7 @@
- AC_MSG_RESULT($place/libtk.a)
- LDFLAGS="$LDFLAGS -L$place"
- libtk="-ltk"
-+ libtk="-ltk82"
++ libtk="-ltk83"
fi
- fi
@@ -262,7 +262,7 @@
- $prefix/lib/tk4.1 \
- $prefix/share/lib/tk4.1 \
- $x_libraries/tk4.1"
-+places="/usr/local/lib/tk8.2"
++places="/usr/local/lib/tk8.3"
for place in $places; do
if test -r $place/tk.tcl ; then
diff --git a/mbone/rtpmon/files/patch-config.h b/mbone/rtpmon/files/patch-config.h
new file mode 100644
index 000000000000..bf3829c2236d
--- /dev/null
+++ b/mbone/rtpmon/files/patch-config.h
@@ -0,0 +1,23 @@
+--- config.h.orig Sun Sep 29 10:53:58 2002
++++ config.h Sun Sep 29 10:54:13 2002
+@@ -43,20 +43,6 @@
+ # include <sys/bitypes.h>
+ #endif
+
+-#ifndef __BIT_TYPES_DEFINED__
+-/*XXX*/
+-# ifdef sco
+-typedef char int8_t;
+-# else
+-typedef signed char int8_t;
+-# endif
+-typedef unsigned char u_int8_t;
+-typedef short int16_t;
+-typedef unsigned short u_int16_t;
+-typedef unsigned int u_int32_t;
+-typedef int int32_t;
+-#endif
+-
+ #ifdef _AIX41
+ typedef int bool;
+ #define true 1