aboutsummaryrefslogtreecommitdiff
path: root/mbone
diff options
context:
space:
mode:
authorRong-En Fan <rafan@FreeBSD.org>2006-11-30 11:42:08 +0000
committerRong-En Fan <rafan@FreeBSD.org>2006-11-30 11:42:08 +0000
commit053e370b710b3e131709e349cd725996deb5b508 (patch)
tree012443b2030e72ff276e550e2c5ccd43ec521bb1 /mbone
parent787e8dbf9e5c040e891cf07590b2907847ffccb1 (diff)
downloadports-053e370b710b3e131709e349cd725996deb5b508.tar.gz
ports-053e370b710b3e131709e349cd725996deb5b508.zip
- Respect CC, CFLAGS
- Respect X11BASE [1] Reported by: pointyhat [1]
Notes
Notes: svn path=/head/; revision=178327
Diffstat (limited to 'mbone')
-rw-r--r--mbone/wbd/Makefile5
1 files changed, 5 insertions, 0 deletions
diff --git a/mbone/wbd/Makefile b/mbone/wbd/Makefile
index 45122e9fa1bb..feec97af1079 100644
--- a/mbone/wbd/Makefile
+++ b/mbone/wbd/Makefile
@@ -20,4 +20,9 @@ PLIST_FILES= bin/wbd
WRKSRC= ${WRKDIR}/wbd
MAKEFILE= makefile
+post-patch:
+ @${REINPLACE_CMD} -e 's,^CC.*=,CC ?=,' -e 's,^CFLAGS.*=,CFLAGS +=,' \
+ -e 's,/usr/X11R6,${X11BASE},g' \
+ ${WRKSRC}/${MAKEFILE}
+
.include <bsd.port.mk>