aboutsummaryrefslogtreecommitdiff
path: root/mbone
diff options
context:
space:
mode:
authorTilman Keskinoz <arved@FreeBSD.org>2007-03-17 17:21:18 +0000
committerTilman Keskinoz <arved@FreeBSD.org>2007-03-17 17:21:18 +0000
commita5bec496c62396740a8e011b7370e327432e1b0b (patch)
tree6653ddf066f0c55fc740a200e32b1dba91b2ffcc /mbone
parentb2a1c34d609e25404cf985d41d633848494347a5 (diff)
downloadports-a5bec496c62396740a8e011b7370e327432e1b0b.tar.gz
ports-a5bec496c62396740a8e011b7370e327432e1b0b.zip
Fix build on FreeBSD 7 by using one OS dependant Makefile for all versions
of FreeBSD
Notes
Notes: svn path=/head/; revision=187584
Diffstat (limited to 'mbone')
-rw-r--r--mbone/rat30/Makefile4
-rw-r--r--mbone/rat30/files/patch-Makefile13
-rw-r--r--mbone/rat30/files/patch-Makefile_FreeBSD_59
-rw-r--r--mbone/rat30/files/patch-Makefile_FreeBSD_69
4 files changed, 11 insertions, 24 deletions
diff --git a/mbone/rat30/Makefile b/mbone/rat30/Makefile
index 4440a9b86c25..636213f08b19 100644
--- a/mbone/rat30/Makefile
+++ b/mbone/rat30/Makefile
@@ -27,10 +27,6 @@ LATEST_LINK= rat30
.include <bsd.port.pre.mk>
-.if ${OSVERSION} >= 700000
-BROKEN= Does not compile on FreeBSD 7.X
-.endif
-
do-build:
(cd ${WRKSRC};${SETENV} ${MAKE_ENV} MAKE=${GMAKE} ${SH} ./Build rat)
diff --git a/mbone/rat30/files/patch-Makefile b/mbone/rat30/files/patch-Makefile
index 1141401cb3de..b244344647c8 100644
--- a/mbone/rat30/files/patch-Makefile
+++ b/mbone/rat30/files/patch-Makefile
@@ -1,5 +1,5 @@
---- Makefile.orig Tue Sep 14 03:39:00 1999
-+++ Makefile Sun Oct 20 14:06:27 2002
+--- Makefile.orig Tue Sep 14 12:39:00 1999
++++ Makefile Sat Mar 17 18:16:04 2007
@@ -10,8 +10,8 @@
# -DDEBUG_RTP -DREPEAT
@@ -11,6 +11,15 @@
LDFLAGS=
LDLIBS= $(LDLIBS) -lm
RANLIB = ranlib
+@@ -19,7 +19,7 @@
+
+ GSMFLAGS = -DSASR -DFAST -DUSE_FLOAT_MUL
+
+-include Makefile_$(OSTYPE)_$(OSMVER)
++include Makefile_$(OSTYPE)_4
+
+ BINDIR = bin/$(USER)
+ SRCDIR = src
@@ -82,6 +82,7 @@
$(BINDIR)/rat-$(OSTYPE)-$(OSVERS): $(OBJS) $(GSMOBJS) $(CRYPTOBJS) $(RATOBJS)
rm -f $(BINDIR)/rat-$(OSTYPE)-$(OSVERS)
diff --git a/mbone/rat30/files/patch-Makefile_FreeBSD_5 b/mbone/rat30/files/patch-Makefile_FreeBSD_5
deleted file mode 100644
index 2118d537d70a..000000000000
--- a/mbone/rat30/files/patch-Makefile_FreeBSD_5
+++ /dev/null
@@ -1,9 +0,0 @@
---- Makefile_FreeBSD_5.orig Sun Oct 20 14:03:11 2002
-+++ Makefile_FreeBSD_5 Sun Oct 20 14:03:06 2002
-@@ -0,0 +1,6 @@
-+TCL_INC = ${LOCALBASE}/include/tcl8.2
-+TK_INC = ${LOCALBASE}/include/tk8.2
-+INCS = -I${X11BASE}/include \
-+ -I$(TCL_INC)/generic -I$(TK_INC)/generic
-+LDLIBS = -L${LOCALBASE}/lib \
-+ -L${X11BASE}/lib -ltk82 -ltcl82 -lXext -lX11 -lm
diff --git a/mbone/rat30/files/patch-Makefile_FreeBSD_6 b/mbone/rat30/files/patch-Makefile_FreeBSD_6
deleted file mode 100644
index d609f4e44245..000000000000
--- a/mbone/rat30/files/patch-Makefile_FreeBSD_6
+++ /dev/null
@@ -1,9 +0,0 @@
---- /dev/null Thu Nov 30 19:11:00 2006
-+++ Makefile_FreeBSD_6 Thu Nov 30 19:12:50 2006
-@@ -0,0 +1,6 @@
-+TCL_INC = ${LOCALBASE}/include/tcl8.2
-+TK_INC = ${LOCALBASE}/include/tk8.2
-+INCS = -I${X11BASE}/include \
-+ -I$(TCL_INC)/generic -I$(TK_INC)/generic
-+LDLIBS = -L${LOCALBASE}/lib \
-+ -L${X11BASE}/lib -ltk82 -ltcl82 -lXext -lX11 -lm