aboutsummaryrefslogtreecommitdiff
path: root/mbone
diff options
context:
space:
mode:
authorMartin Matuska <mm@FreeBSD.org>2007-07-30 16:43:29 +0000
committerMartin Matuska <mm@FreeBSD.org>2007-07-30 16:43:29 +0000
commitdc93abf5c032f119858c4c736127a15011e65b0b (patch)
tree19af0a4669597fc911e11946a879fe812ac6e221 /mbone
parent5563545f24f2b4d4bc0392ec9c2ae2607cde44f6 (diff)
downloadports-dc93abf5c032f119858c4c736127a15011e65b0b.tar.gz
ports-dc93abf5c032f119858c4c736127a15011e65b0b.zip
- Unbreak with WITH_XORG= x11 xext sm ice
- Cleanup of USE_TK - Other small fixes Approved by: garga (mentor, implicit)
Notes
Notes: svn path=/head/; revision=196734
Diffstat (limited to 'mbone')
-rw-r--r--mbone/rat/Makefile30
1 files changed, 18 insertions, 12 deletions
diff --git a/mbone/rat/Makefile b/mbone/rat/Makefile
index 1282f9036d8e..3c2472b95698 100644
--- a/mbone/rat/Makefile
+++ b/mbone/rat/Makefile
@@ -16,12 +16,11 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= IPv4/v6 Multicast and unicast audio conferencing tool
USE_TK= yes
-USE_TK_BUILD= yes
-USE_TCL= yes
-USE_TCL_BUILD= yes
+USE_XORG= x11 xext sm ice
USE_AUTOTOOLS= autoconf:213
USE_GMAKE= yes
-CONFIGURE_ARGS= --x-libraries=${X11BASE}/lib --x-includes=${X11BASE}/include --enable-ipv6
+CONFIGURE_ARGS= --x-libraries=${X11BASE}/lib --x-includes=${X11BASE}/include \
+ --enable-ipv6
MAN1= rat.1
MANCOMPRESSED= no
@@ -33,13 +32,19 @@ PLIST_SUB= PORTVERSION=${PORTVERSION}
.include <bsd.port.pre.mk>
+CONFIGURE_ARGS+= --with-tcltk-version=${TK_VER}
+
.if ${OSVERSION} >= 700011
EXTRA_PATCHES= ${FILESDIR}/timet.patch
.endif
post-patch:
- @${REINPLACE_CMD} -e "s,-Werror,," ${WRKSRC}/common/configure.in \
- ${WRKSRC}/rat/configure.in
+ @${REINPLACE_CMD} -e "s,-Werror,," \
+ -e 's,^TCL_INC=$${PARENT}.*,TCL_INC=${TCL_INCLUDEDIR},g' \
+ -e 's,^TCL_LIB=$${PARENT}.*,TCL_LIB=${LOCALBASE}/lib,g' \
+ -e 's,^TK_INC=$${PARENT}.*,TK_INC=${TK_INCLUDEDIR},g' \
+ -e 's,^TK_LIB=$${PARENT}.*,TK_LIB=${LOCALBASE}/lib,g' \
+ ${WRKSRC}/common/configure.in ${WRKSRC}/rat/configure.in
do-install:
@${REINPLACE_CMD} 's|#/|#!/|' ${WRKSRC}/rat/${RAT_SCRIPT}
@@ -51,16 +56,17 @@ do-install:
${MKDIR} ${LOCALBASE}/etc/sdr/plugins
${INSTALL_DATA} ${WRKSRC}/rat/sdr2.plugin.S02.audio.rtp.*.${RAT} ${LOCALBASE}/etc/sdr/plugins
+pre-configure:
+ cd ${WRKSRC}/common && ${AUTOCONF} && ./configure ${CONFIGURE_ARGS}
+ cd ${WRKSRC}/common && ${GMAKE}
+
+do-configure:
+ cd ${WRKSRC}/rat && ${AUTOCONF} && ./configure ${CONFIGURE_ARGS}
+
do-build:
- cd ${WRKSRC}/common/src && ${GMAKE}
cd ${WRKSRC}/rat && ${GMAKE}
run-autotools::
@${DO_NADA}
-do-configure:
- cd ${WRKSRC}/common && ${AUTOCONF} && ./configure ${CONFIGURE_ARGS}
- cd ${WRKSRC}/rat && ${AUTOCONF} && ./configure ${CONFIGURE_ARGS} \
- --with-tcl=${LOCALBASE} --with-tk=${LOCALBASE} --with-tcltk-version=${TK_VER}
-
.include <bsd.port.post.mk>