aboutsummaryrefslogtreecommitdiff
path: root/mbone
diff options
context:
space:
mode:
authorKiriyama Kazuhiko <kiri@FreeBSD.org>2001-06-07 02:21:53 +0000
committerKiriyama Kazuhiko <kiri@FreeBSD.org>2001-06-07 02:21:53 +0000
commit69a4d18f23d9eaf0dedd3cf85c16920ea08fe62d (patch)
tree0e7c89404d72773eccf5a9a878796b90b4ab1d25 /mbone
parentc422afbe87c53e1fc5d798ed61dcdbe8c9fdedad (diff)
downloadports-69a4d18f23d9eaf0dedd3cf85c16920ea08fe62d.tar.gz
ports-69a4d18f23d9eaf0dedd3cf85c16920ea08fe62d.zip
New port for multicast AV tool.
PR: 27329 Submitted by:Takeshi MUTOH<mutoh@bovine.info.nara-k.ac.jp>
Notes
Notes: svn path=/head/; revision=43574
Diffstat (limited to 'mbone')
-rw-r--r--mbone/Makefile1
-rw-r--r--mbone/relate/Makefile23
-rw-r--r--mbone/relate/distinfo1
-rw-r--r--mbone/relate/files/patch-Makefile41
-rw-r--r--mbone/relate/files/patch-main.c20
-rw-r--r--mbone/relate/files/patch-relate.tcl11
-rw-r--r--mbone/relate/pkg-comment1
-rw-r--r--mbone/relate/pkg-descr14
-rw-r--r--mbone/relate/pkg-plist1
9 files changed, 113 insertions, 0 deletions
diff --git a/mbone/Makefile b/mbone/Makefile
index ccdc1af7002f..1d1665b6687e 100644
--- a/mbone/Makefile
+++ b/mbone/Makefile
@@ -6,6 +6,7 @@
SUBDIR += nte
SUBDIR += rat
SUBDIR += rat30
+ SUBDIR += relate
SUBDIR += rqm
SUBDIR += rtpmon
SUBDIR += rtptools
diff --git a/mbone/relate/Makefile b/mbone/relate/Makefile
new file mode 100644
index 000000000000..7874f786d7f5
--- /dev/null
+++ b/mbone/relate/Makefile
@@ -0,0 +1,23 @@
+# New ports collection makefile for: relate
+# Date created: 6 June 2001
+# Whom: Takeshi MUTOH <mutoh@info.nara-k.ac.jp>
+#
+# $FreeBSD$
+#
+
+PORTNAME= relate
+PORTVERSION= 2.1
+CATEGORIES= mbone
+MASTER_SITES= http://www-mice.cs.ucl.ac.uk/multimedia/software/relate-ui/${PORTVERSION}/
+
+MAINTAINER= mutoh@info.nara-k.ac.jp
+
+LIB_DEPENDS= tk82:${PORTSDIR}/x11-toolkits/tk82
+RUN_DEPENDS= rat30:${PORTSDIR}/mbone/rat30 \
+ wbd:${PORTSDIR}/mbone/wbd \
+ nte:${PORTSDIR}/mbone/nte \
+ vic:${PORTSDIR}/mbone/vic
+
+WRKSRC= ${WRKDIR}/relate
+
+.include <bsd.port.mk>
diff --git a/mbone/relate/distinfo b/mbone/relate/distinfo
new file mode 100644
index 000000000000..f327281e04a7
--- /dev/null
+++ b/mbone/relate/distinfo
@@ -0,0 +1 @@
+MD5 (relate-2.1.tar.gz) = 97a3963e2bd54435c36b7e0a9361a2b1
diff --git a/mbone/relate/files/patch-Makefile b/mbone/relate/files/patch-Makefile
new file mode 100644
index 000000000000..396333d68c64
--- /dev/null
+++ b/mbone/relate/files/patch-Makefile
@@ -0,0 +1,41 @@
+--- Makefile.orig Mon May 7 11:59:32 2001
++++ Makefile Mon May 7 12:02:13 2001
+@@ -0,0 +1,38 @@
++YFLAGS = -dv
++CFLAGS = -g $(LIBFLAGS) $(IFLAGS) -DNDEBUG -DRELATE_INT
++LIBDIR = /usr/local/lib
++INCDIR = /usr/local/include
++
++# for FreeBSD
++CC = cc
++LIBFLAGS = -L$(LIBDIR) -L/usr/X11R6/lib
++IFLAGS = -I$(INCDIR)/tk8.2 -I$(INCDIR)/tcl8.2 -I/usr/X11R6/include
++LIBS = -ltk82 -ltcl82 -lm -lX11
++
++TCL_FILES = \
++ ui_audiotool.tcl \
++ relate.tcl
++
++# The Make rules.
++INC = util.h mbus.h mbus_ui.h config.h net_udp.h
++SRC = tcllibs.c main.c mbus.c mbus_ui.c util.c lbl_confbus.c tcltk.c net_udp.c
++OBJ = tcllibs.o main.o mbus.o mbus_ui.o util.o lbl_confbus.o tcltk.o net_udp.o
++
++all : relate
++
++relate : $(OBJ) $(INC)
++ $(CC) $(CFLAGS) $(OBJ) $(LIBS) -o relate
++
++clean :
++ rm -f *.o tcl2c relate core
++
++tcl2c : tcl2c.o
++ $(CC) $(CFLAGS) tcl2c.o $(LIBS) -o tcl2c
++
++# Tcl library files are turned into a single object file.
++tcllibs.o: $(TCL_FILES) tcl2c
++ rm -f $@ tcllibs.c; \
++ ./tcl2c 1 $(TCL_FILES) > tcllibs.c ; \
++ $(CC) -c $(CFLAGS) tcllibs.c ; rm -f tcllibs.c
++install: all
++ install -c -s -m 755 -o bin -g bin relate ${PREFIX}/bin
diff --git a/mbone/relate/files/patch-main.c b/mbone/relate/files/patch-main.c
new file mode 100644
index 000000000000..40737a3b36d2
--- /dev/null
+++ b/mbone/relate/files/patch-main.c
@@ -0,0 +1,20 @@
+--- main.c.orig Wed Mar 1 21:56:27 2000
++++ main.c Tue May 15 14:44:34 2001
+@@ -20,7 +20,7 @@
+
+ #include <tcl.h>
+ #include <tk.h>
+-#include <malloc.h>
++#include <stdlib.h>
+ #include <locale.h>
+ #include <assert.h>
+ #include <time.h>
+@@ -145,7 +145,7 @@
+ char buffer[128];
+ FILE *file;
+ int v1, v2, v3;
+- if ( ( file=popen( "rat -version", "rt") )!=NULL ) {
++ if ( ( file=popen( "rat30 -version", "rt") )!=NULL ) {
+ fgets(buffer, sizeof(buffer), file);
+ pclose(file);
+ /* get version */
diff --git a/mbone/relate/files/patch-relate.tcl b/mbone/relate/files/patch-relate.tcl
new file mode 100644
index 000000000000..c0df71d08a1f
--- /dev/null
+++ b/mbone/relate/files/patch-relate.tcl
@@ -0,0 +1,11 @@
+--- relate.tcl.org Tue May 15 14:45:03 2001
++++ relate.tcl Tue May 15 14:46:10 2001
+@@ -550,7 +550,7 @@
+ frame .r.b.rat -container true
+ pack .r.b.rat -side left
+ set ratwin [winfo id .r.b.rat]
+- set commandline "exec rat -lbl_channel $channel -smallui -use $ratwin [set "audio.arguments"]"
++ set commandline "exec rat30 -lbl_channel $channel -smallui -use $ratwin [set "audio.arguments"]"
+ catch {set ratproc [eval $commandline &] }
+
+ pack .r.b.rat -side left
diff --git a/mbone/relate/pkg-comment b/mbone/relate/pkg-comment
new file mode 100644
index 000000000000..4b324e5ffa5f
--- /dev/null
+++ b/mbone/relate/pkg-comment
@@ -0,0 +1 @@
+Mbone integrated interface, audio, video, editor, and whiteboard
diff --git a/mbone/relate/pkg-descr b/mbone/relate/pkg-descr
new file mode 100644
index 000000000000..6edde26f6044
--- /dev/null
+++ b/mbone/relate/pkg-descr
@@ -0,0 +1,14 @@
+Relate: Remote Language Teaching.
+
+The integrated interface, which brings together the audio, video and
+ shared workspace tools, has been designed to be as simple and easy
+ to use as possible.
+Particular emphasis has been given to reducing screen clutter and
+ to minimising the number of things that need to be done
+ to use the different parts of the software.
+ There is minimal need to manipulate, move or uncover windows,
+ and all necessary tools and controls are readily to hand.
+Although basic keyboard and mouse skills are required,
+ little else is needed for students and teachers to use the software.
+
+WWW: http://www-mice.cs.ucl.ac.uk/multimedia/software/relate-ui/
diff --git a/mbone/relate/pkg-plist b/mbone/relate/pkg-plist
new file mode 100644
index 000000000000..a5eecf96c63f
--- /dev/null
+++ b/mbone/relate/pkg-plist
@@ -0,0 +1 @@
+bin/relate