aboutsummaryrefslogtreecommitdiff
path: root/mbone
diff options
context:
space:
mode:
authorMunechika SUMIKAWA <sumikawa@FreeBSD.org>2000-01-25 10:43:01 +0000
committerMunechika SUMIKAWA <sumikawa@FreeBSD.org>2000-01-25 10:43:01 +0000
commit92700a69ffdd24ab6f1a47191f2c5b9dc41df450 (patch)
treefff2480c5825a255ff0b298c16a534c99d59dd79 /mbone
parent46027f2fdbbced6642383ceef2a8546381ac50ae (diff)
downloadports-92700a69ffdd24ab6f1a47191f2c5b9dc41df450.tar.gz
ports-92700a69ffdd24ab6f1a47191f2c5b9dc41df450.zip
fix building error on FreeBSD-current.
now this port supports IPv6. Reviewed by: maintainer
Notes
Notes: svn path=/head/; revision=25051
Diffstat (limited to 'mbone')
-rw-r--r--mbone/rat/Makefile2
-rw-r--r--mbone/rat/files/patch-ad13
2 files changed, 14 insertions, 1 deletions
diff --git a/mbone/rat/Makefile b/mbone/rat/Makefile
index 046307711d9b..04d99ac5e66e 100644
--- a/mbone/rat/Makefile
+++ b/mbone/rat/Makefile
@@ -7,7 +7,7 @@
#
DISTNAME= rat-4.0.4
-CATEGORIES= mbone audio
+CATEGORIES= mbone audio ipv6
MASTER_SITES= http://www-mice.cs.ucl.ac.uk/multimedia/software/rat/4.0.4/ \
http://www.freebsd.org/~cpiazza/distfiles/
diff --git a/mbone/rat/files/patch-ad b/mbone/rat/files/patch-ad
new file mode 100644
index 000000000000..b1756adb31a2
--- /dev/null
+++ b/mbone/rat/files/patch-ad
@@ -0,0 +1,13 @@
+--- common/net_udp.c.orig Tue Jun 22 10:54:05 1999
++++ common/net_udp.c Mon Jan 24 17:14:12 2000
+@@ -335,6 +335,10 @@
+ }
+ }
+
++#ifndef IPV6_ADD_MEMBERSHIP
++#define IPV6_ADD_MEMBERSHIP IPV6_JOIN_GROUP
++#endif
++
+ if (IN6_IS_ADDR_MULTICAST(&(s->addr6))) {
+ unsigned int loop = 1;
+ struct ipv6_mreq imr;