aboutsummaryrefslogtreecommitdiff
path: root/mbone
diff options
context:
space:
mode:
authorSteve Price <steve@FreeBSD.org>1999-12-31 22:40:28 +0000
committerSteve Price <steve@FreeBSD.org>1999-12-31 22:40:28 +0000
commit111ed17a0b2916f3adf2e55241d7796bd92c508b (patch)
treeed42f11ad57dc0af9f71cea47cb61524181820e7 /mbone
parent00002884a2d72e79e8aba416c1ac9c09dd74239f (diff)
downloadports-111ed17a0b2916f3adf2e55241d7796bd92c508b.tar.gz
ports-111ed17a0b2916f3adf2e55241d7796bd92c508b.zip
Update to version 7.1.
PR: 14838 Submitted by: Thomas V. Crimi <tcrimi@procida.res.cmu.edu>
Notes
Notes: svn path=/head/; revision=24323
Diffstat (limited to 'mbone')
-rw-r--r--mbone/speak_freely/Makefile6
-rw-r--r--mbone/speak_freely/distinfo2
-rw-r--r--mbone/speak_freely/files/patch-aa254
-rw-r--r--mbone/speak_freely/files/patch-ac77
-rw-r--r--mbone/speak_freely/files/patch-ad85
-rw-r--r--mbone/speak_freely/files/patch-ae136
6 files changed, 153 insertions, 407 deletions
diff --git a/mbone/speak_freely/Makefile b/mbone/speak_freely/Makefile
index 9872f021e49f..1d76a6cfed47 100644
--- a/mbone/speak_freely/Makefile
+++ b/mbone/speak_freely/Makefile
@@ -1,14 +1,14 @@
# New ports collection makefile for: speak_freely
# Original WWW site: http://www.fourmilab.ch/speakfree/unix/index.html
-# Version required: 6.1c
+# Version required: 7.1
# Date created: 18 Apr 1996
#
# $FreeBSD$
#
-DISTNAME= speak_freely-6.1c
+DISTNAME= speak_freely-7.1
CATEGORIES= mbone audio security
-MASTER_SITES= http://www.fourmilab.ch/speakfree/unix/prior-releases/6.1/
+MASTER_SITES= http://www.fourmilab.ch/speakfree/unix/
MAINTAINER= ports@FreeBSD.org
diff --git a/mbone/speak_freely/distinfo b/mbone/speak_freely/distinfo
index fe1bdb3ce777..1e09161e5bf1 100644
--- a/mbone/speak_freely/distinfo
+++ b/mbone/speak_freely/distinfo
@@ -1 +1 @@
-MD5 (speak_freely-6.1c.tar.gz) = 52f42e45bd78ddd069c8ef81d8bc8e83
+MD5 (speak_freely-7.1.tar.gz) = f06e4115c7139f7e30ea57064b324558
diff --git a/mbone/speak_freely/files/patch-aa b/mbone/speak_freely/files/patch-aa
index 0e10b0d18e94..10ed5fbf8055 100644
--- a/mbone/speak_freely/files/patch-aa
+++ b/mbone/speak_freely/files/patch-aa
@@ -1,191 +1,63 @@
-*** Makefile.orig Mon Jul 21 17:06:21 1997
---- Makefile Wed Sep 24 02:36:37 1997
-***************
-*** 32,40 ****
- # THREADS, you can also remove the "-lpthread" library specification
- # from the LFLAGS line, which may cause an error if the system does
- # not include the POSIX threads library.
-! CC = cc -fsingle # for Sun Compiler
-! CCFLAGS = -DSolaris -DTHREADS
-! LFLAGS = -lcurses -lsocket -lnsl -lm -lpthread
-
- # FreeBSD 2.2 courtesy of Andrey A. Chernov
- #
---- 32,40 ----
- # THREADS, you can also remove the "-lpthread" library specification
- # from the LFLAGS line, which may cause an error if the system does
- # not include the POSIX threads library.
-! #CC = cc -fsingle # for Sun Compiler
-! #CCFLAGS = -DSolaris -DTHREADS
-! #LFLAGS = -lcurses -lsocket -lnsl -lm -lpthread
-
- # FreeBSD 2.2 courtesy of Andrey A. Chernov
- #
-***************
-*** 46,53 ****
- # Depending on how your driver handles non-blocking I/O,
- # you may also have to add -DAUDIO_BLOCKING to the
- # CCFLAGS line.
-! #CCFLAGS = -DM_LITTLE_ENDIAN
-! #LFLAGS = -lcurses -ltermcap -lcompat -lm
-
- # ** Linux users please note: many Linux audio drivers are
- # half-duplex, even through your sound card may actually
---- 46,54 ----
- # Depending on how your driver handles non-blocking I/O,
- # you may also have to add -DAUDIO_BLOCKING to the
- # CCFLAGS line.
-! PREFIX=/usr/local
-! CCFLAGS = -DM_LITTLE_ENDIAN
-! LFLAGS = -L${PREFIX}/lib -lcurses -ltermcap -lcompat -lm
-
- # ** Linux users please note: many Linux audio drivers are
- # half-duplex, even through your sound card may actually
-***************
-*** 78,87 ****
-
- # Where Perl is located on your system. This is used to make
- # a directly-executable version of sfvod.
-! PERL = /usr/local/bin/perl
-
- # If your audio hardware is half duplex, uncomment the next line
-! #DUPLEX = -DHALF_DUPLEX
-
- # If your getdomainname() does not return the DNS domainname, define:
- #DOMAIN=-DMYDOMAIN=\"somedomain.net\"
---- 79,88 ----
-
- # Where Perl is located on your system. This is used to make
- # a directly-executable version of sfvod.
-! PERL = /usr/bin/perl
-
- # If your audio hardware is half duplex, uncomment the next line
-! DUPLEX = -DHALF_DUPLEX
-
- # If your getdomainname() does not return the DNS domainname, define:
- #DOMAIN=-DMYDOMAIN=\"somedomain.net\"
-***************
-*** 108,118 ****
- CARGS = -DInternet_Port=$(INTERNET_PORT)
-
- #DEBUG = -g -DHEXDUMP
-! DEBUG = -O
-
- # Compiler flags
-
-! CFLAGS = $(DEBUG) -Iadpcm -Ilpc -Igsm/inc -Imd5 -Iidea -Ilibdes $(CARGS) $(DUPLEX) $(CCFLAGS) $(DOMAIN)
-
- PROGRAMS = sfspeaker sfmike sflwld sflwl sfecho sfvod
-
---- 109,127 ----
- CARGS = -DInternet_Port=$(INTERNET_PORT)
-
- #DEBUG = -g -DHEXDUMP
-! #DEBUG = -O
-!
-! .if exists(/usr/lib/libdes.a)
-! LDES=-ldes
-! IDES=
-! .else
-! LDES=libdes/libdes.a
-! IDES=-Ilibdes
-! .endif
-
- # Compiler flags
-
-! CFLAGS += $(DEBUG) -Iadpcm -Ilpc -Iidea $(IDES) -I/usr/include -I${PREFIX}/include $(CARGS) $(DUPLEX) $(CCFLAGS) $(DOMAIN)
-
- PROGRAMS = sfspeaker sfmike sflwld sflwl sfecho sfvod
-
-***************
-*** 120,132 ****
-
- SPKROBJS = speaker.o codecs.o deskey.o g711.o rate.o rtpacket.o soundbyte.o ulaw.o usleep.o vatpkt.o vox.o hp_audio.o
-
-! sfspeaker: $(SPKROBJS) adpcmlib.o lpclib.o lpc10lib.o gsmlib.o deslib.o md5lib.o idealib.o libdes.o xdsub.o
-! $(CC) $(SPKROBJS) adpcm/adpcm-u.o des/des.o md5/md5.o idea/idea.o lpc10/liblpc10.a gsm/lib/libgsm.a lpc/lpc.o xdsub.o libdes/libdes.a $(LFLAGS) -o sfspeaker
-
- MIKEOBJS = mike.o codecs.o deskey.o g711.o rate.o rtpacket.o soundbyte.o ulaw.o usleep.o vatpkt.o xdsub.o hp_audio.o
-
-! sfmike: $(MIKEOBJS) adpcmlib.o lpclib.o lpc10lib.o gsmlib.o deslib.o md5lib.o idealib.o libdes.o
-! $(CC) $(MIKEOBJS) adpcm/adpcm-u.o des/des.o md5/md5.o idea/idea.o -lm lpc10/liblpc10.a gsm/lib/libgsm.a lpc/lpc.o libdes/libdes.a $(LFLAGS) -o sfmike
-
- LWLDOBJS = lwld.o xdsub.o
-
---- 129,141 ----
-
- SPKROBJS = speaker.o codecs.o deskey.o g711.o rate.o rtpacket.o soundbyte.o ulaw.o usleep.o vatpkt.o vox.o hp_audio.o
-
-! sfspeaker: $(SPKROBJS) adpcmlib.o lpclib.o lpc10lib.o deslib.o idealib.o libdes.o xdsub.o
-! $(CC) $(SPKROBJS) adpcm/adpcm-u.o des/des.o idea/idea.o lpc10/liblpc10.a -lgsm lpc/lpc.o xdsub.o -lmd $(LDES) $(LFLAGS) -o sfspeaker
-
- MIKEOBJS = mike.o codecs.o deskey.o g711.o rate.o rtpacket.o soundbyte.o ulaw.o usleep.o vatpkt.o xdsub.o hp_audio.o
-
-! sfmike: $(MIKEOBJS) adpcmlib.o lpclib.o lpc10lib.o deslib.o idealib.o libdes.o
-! $(CC) $(MIKEOBJS) adpcm/adpcm-u.o des/des.o idea/idea.o -lm lpc10/liblpc10.a -lgsm lpc/lpc.o -lmd $(LDES) $(LFLAGS) -o sfmike
-
- LWLDOBJS = lwld.o xdsub.o
-
-***************
-*** 140,147 ****
-
- ECHOOBJS = echo.o codecs.o g711.o rtpacket.o ulaw.o xdsub.o
-
-! sfecho: $(ECHOOBJS) md5lib.o
-! $(CC) $(ECHOOBJS) md5/md5.o adpcm/adpcm-u.o lpc/lpc.o $(LFLAGS) -o sfecho
-
- sfvod: sfvod.pl
- echo \#\! $(PERL) >sfvod
---- 149,156 ----
-
- ECHOOBJS = echo.o codecs.o g711.o rtpacket.o ulaw.o xdsub.o
-
-! sfecho: $(ECHOOBJS)
-! $(CC) $(ECHOOBJS) adpcm/adpcm-u.o lpc/lpc.o -lmd $(LFLAGS) -o sfecho
-
- sfvod: sfvod.pl
- echo \#\! $(PERL) >sfvod
-***************
-*** 157,167 ****
- chmod 755 sfvod
-
- adpcmlib.o:
-! ( echo "Building ADPCM library."; cd adpcm ; make CC="$(CC)" )
- echo "ADPCM" >adpcmlib.o
-
- libdes.o:
- ( echo "Building LIBDES library."; cd libdes ; make -f Makefile.sf CC="$(CC) $(CCFLAGS) $(DEBUG)" )
- echo "LIBDES" >libdes.o
-
- lpclib.o:
---- 166,178 ----
- chmod 755 sfvod
-
- adpcmlib.o:
-! ( echo "Building ADPCM library."; cd adpcm ; make CC="$(CC) $(CCFLAGS)" )
- echo "ADPCM" >adpcmlib.o
-
- libdes.o:
-+ .if !exists(/usr/lib/libdes.a)
- ( echo "Building LIBDES library."; cd libdes ; make -f Makefile.sf CC="$(CC) $(CCFLAGS) $(DEBUG)" )
-+ .endif
- echo "LIBDES" >libdes.o
-
- lpclib.o:
-***************
-*** 185,191 ****
- echo "MD5" >md5lib.o
-
- idealib.o:
-! ( echo "Building IDEA library."; cd idea ; make CC="$(CC)" )
- echo "IDEA" >idealib.o
-
- codecs.o: codecs.c speakfree.h
---- 196,202 ----
- echo "MD5" >md5lib.o
-
- idealib.o:
-! ( echo "Building IDEA library."; cd idea ; make CC="$(CC) $(CCFLAGS)" )
- echo "IDEA" >idealib.o
-
- codecs.o: codecs.c speakfree.h
+--- Makefile.orig Sat Sep 18 10:29:44 1999
++++ Makefile Fri Dec 31 15:40:34 1999
+@@ -3,7 +3,7 @@
+
+ # Debugging options
+
+-DEBUG = -g -DHEXDUMP
++#DEBUG = -g -DHEXDUMP
+ #DEBUG = -g -DHEXDUMP -DNOCRYPTO
+ #DEBUG = -O
+
+@@ -38,9 +38,9 @@
+ # functionality is working. Please see the detailed description
+ # of the available flags which follows these declarations.
+ #
+-CCFLAGS = -DAUDIO_BLOCKING -DLINUX -DHALF_DUPLEX -DM_LITTLE_ENDIAN
+-CC = gcc -O3 # for GNU's gcc compiler
+-LFLAGS = -lncurses -lm
++#CCFLAGS = -DAUDIO_BLOCKING -DLINUX -DHALF_DUPLEX -DM_LITTLE_ENDIAN
++#CC = gcc -O3 # for GNU's gcc compiler
++#LFLAGS = -lncurses -lm
+ #
+ # If the above LFLAGS doesn't work, try the one below.
+ #LFLAGS = -lcurses -lm
+@@ -220,8 +220,8 @@
+ # Depending on how your driver handles non-blocking I/O,
+ # you may also have to add -DAUDIO_BLOCKING to the
+ # CCFLAGS line.
+-#CCFLAGS = -DM_LITTLE_ENDIAN
+-#LFLAGS = -lcurses -ltermcap -lcompat -lm
++CCFLAGS = -O2 -DM_LITTLE_ENDIAN -DHALF_DUPLEX
++LFLAGS = -lcurses -ltermcap -lcompat -lm
+
+ # Hewlett-Packard
+ # (courtesy of Marc Kilian)
+@@ -337,7 +337,7 @@
+ # in make not necessarily available on all platforms.
+
+ adpcmlib.o:
+- ( echo "Building ADPCM library."; cd adpcm ; make CC="$(CC)" )
++ ( echo "Building ADPCM library."; cd adpcm ; make CC="$(CC) $(CCFLAGS)" )
+ echo "ADPCM" >adpcmlib.o
+
+ deslib.o:
+@@ -361,15 +361,15 @@
+ echo "LPC" >lpc10lib.o
+
+ gsmlib.o:
+- ( echo "Building GSM library."; cd gsm ; make CC="$(CC)" )
++ ( echo "Building GSM library."; cd gsm ; make CC="$(CC) $(CCFLAGS)" )
+ echo "GSM" >gsmlib.o
+
+ md5lib.o:
+- ( echo "Building MD5 library."; cd md5 ; make CC="$(CC)" )
++ ( echo "Building MD5 library."; cd md5 ; make CC="$(CC) $(CCFLAGS)" )
+ echo "MD5" >md5lib.o
+
+ idealib.o:
+- ( echo "Building IDEA library."; cd idea ; make CC="$(CC)" )
++ ( echo "Building IDEA library."; cd idea ; make CC="$(CC) $(CCFLAGS)" )
+ echo "IDEA" >idealib.o
+
+ # Object file dependencies
diff --git a/mbone/speak_freely/files/patch-ac b/mbone/speak_freely/files/patch-ac
index 94ed40050744..999b8335bb16 100644
--- a/mbone/speak_freely/files/patch-ac
+++ b/mbone/speak_freely/files/patch-ac
@@ -1,20 +1,69 @@
---- mike.c.orig Wed Mar 5 14:08:20 1997
-+++ mike.c Tue Dec 15 22:21:32 1998
-@@ -8,6 +8,7 @@
- */
+--- mike.c.orig Tue Sep 14 08:27:51 1999
++++ mike.c Fri Dec 31 15:29:10 1999
+@@ -132,8 +132,8 @@
+ #endif /* UNIX420 */
- #include "speakfree.h"
-+#define sendfile sf_sendfile
+ #ifdef UNIX5
+-#include <termio.h>
+-static struct termio old_term_params;
++#include <termios.h>
++static struct termios old_term_params;
+ #endif /* UNIX5 */
- /* Destination host descriptor. */
+ /* Set raw mode on terminal file. Basically, get the terminal into a
+@@ -152,16 +152,16 @@
+ #endif /* UNIX420 */
-@@ -687,6 +688,9 @@
- (sb->buffer.buffer_len > 16)) {
- pktlen += sizeof(sb->sendinghost);
+ #ifdef UNIX5
+- struct termio term_params;
++ struct termios term_params;
+
+- ioctl(fileno(stdin), TCGETA, &old_term_params);
++ tcgetattr(fileno(stdin), &old_term_params);
+ term_params = old_term_params;
+ term_params.c_iflag &= ~(ICRNL|IXON|IXOFF); /* no cr translation */
+ term_params.c_iflag &= ~(ISTRIP); /* no stripping of high order bit */
+ term_params.c_oflag &= ~(OPOST); /* no output processing */
+ term_params.c_lflag &= ~(ISIG|ICANON|ECHO); /* raw mode */
+ term_params.c_cc[4] = 1; /* satisfy read after 1 char */
+- ioctl(fileno(stdin), TCSETAF, &term_params);
++ tcsetattr(fileno(stdin), TCSAFLUSH, &term_params);
+ #endif /* UNIX5 */
+ /*printf("\n(raw)\n");*/
+ }
+@@ -180,7 +180,7 @@
+ #endif /* UNIX420 */
+
+ #ifdef UNIX5
+- ioctl(fileno(stdin), TCSETAF, &old_term_params);
++ tcsetattr(fileno(stdin), TCSAFLUSH, &old_term_params);
+ #endif /* UNIX5 */
+ /*printf("\n(cooked)\n");*/
+ }
+@@ -1144,7 +1144,7 @@
+ /* SENDFILE -- Send a file or, if the file name is NULL or a
+ single period, send real-time sound input. */
+
+-static int sendfile(f)
++static int sfsendfile(f)
+ char *f;
+ {
+ soundbuf netbuf;
+@@ -2306,7 +2306,7 @@
+ return 1;
}
-+ /* must stay in network order for debugging output */
-+ sb->compression = htonl(sb->compression);
-+ sb->buffer.buffer_len = htonl(sb->buffer.buffer_len);
- }
+ } else {
+- int ok = sendfile(op);
++ int ok = sfsendfile(op);
+ if (ok != 0)
+ return ok;
+ sentfile++;
+@@ -2318,7 +2318,7 @@
+ usage();
+ } else {
+ if (sentfile == 0) {
+- return sendfile(NULL);
++ return sfsendfile(NULL);
}
}
+
diff --git a/mbone/speak_freely/files/patch-ad b/mbone/speak_freely/files/patch-ad
index 4abcc937427b..9fcad35ba658 100644
--- a/mbone/speak_freely/files/patch-ad
+++ b/mbone/speak_freely/files/patch-ad
@@ -1,74 +1,11 @@
-*** adpcm/Makefile.bak Fri Sep 1 14:58:19 1995
---- adpcm/Makefile Fri Oct 25 18:55:46 1996
-***************
-*** 1,7 ****
- #
- # Makefile for adpcm and test programs
- # -------------------
-! CFLAGS=-O -I..
- # May need this on a sun:
- #CFLAGS=-O -I/usr/demo/SOUND
-
---- 1,7 ----
- #
- # Makefile for adpcm and test programs
- # -------------------
-! CFLAGS+=-I..
- # May need this on a sun:
- #CFLAGS=-O -I/usr/demo/SOUND
-
-*** des/Makefile.bak Thu Nov 2 22:38:58 1995
---- des/Makefile Fri Oct 25 18:55:46 1996
-***************
-*** 1,4 ****
-! CFLAGS=-O
-
- all: des.o
-
---- 1,4 ----
-! #CFLAGS=-O
-
- all: des.o
-
-*** idea/Makefile.bak Wed Aug 2 22:39:19 1995
---- idea/Makefile Fri Oct 25 18:55:46 1996
-***************
-*** 6,13 ****
-
- # Compiler flags
-
-! CC = cc
-! CFLAGS = -O
-
- all: idea.o
-
---- 6,13 ----
-
- # Compiler flags
-
-! #CC = cc
-! #CFLAGS = -O
-
- all: idea.o
-
-*** libdes/Makefile.bak Wed Apr 17 23:49:33 1996
---- libdes/Makefile Fri Oct 25 18:55:46 1996
-***************
-*** 30,37 ****
-
- OPTS= $(OPTS0) $(OPTS1) $(OPTS2)
-
-! CC=cc
-! CFLAGS= -O $(OPTS) $(CFLAG)
-
- #CC=gcc
- #CFLAGS= -O3 -fomit-frame-pointer $(OPTS) $(CFLAG)
---- 30,37 ----
-
- OPTS= $(OPTS0) $(OPTS1) $(OPTS2)
-
-! #CC=cc
-! CFLAGS+= $(OPTS) $(CFLAG)
-
- #CC=gcc
- #CFLAGS= -O3 -fomit-frame-pointer $(OPTS) $(CFLAG)
+--- adpcm/Makefile.orig Fri Dec 31 15:34:54 1999
++++ adpcm/Makefile Fri Dec 31 15:35:09 1999
+@@ -1,7 +1,7 @@
+ #
+ # Makefile for adpcm and test programs
+ # -------------------
+-CFLAGS=-O -I..
++CFLAGS+= -I..
+ # May need this on a sun:
+ #CFLAGS=-O -I/usr/demo/SOUND
+
diff --git a/mbone/speak_freely/files/patch-ae b/mbone/speak_freely/files/patch-ae
index eb58a7f980de..4af5b7701d04 100644
--- a/mbone/speak_freely/files/patch-ae
+++ b/mbone/speak_freely/files/patch-ae
@@ -1,124 +1,12 @@
-*** soundbyte.c.orig Wed Mar 5 23:04:49 1997
---- soundbyte.c Wed Sep 24 02:39:23 1997
-***************
-*** 15,21 ****
---- 15,23 ----
- #ifdef Solaris
- #include <sys/filio.h>
- #else
-+ #ifndef __FreeBSD__
- #include <sys/dir.h>
-+ #endif
- #include <sys/file.h>
- #endif
-
-***************
-*** 72,77 ****
---- 74,81 ----
- static unsigned char *playbuf= NULL; /* Current play pointer */
- static int squelch = 0; /* Squelch value */
-
-+ void soundplayvol();
-+
- /* Convert local gain into device parameters */
-
- static unsigned scale_gain(g)
-***************
-*** 96,101 ****
---- 100,110 ----
- }
- #endif
-
-+ #ifndef sun
-+ #ifdef HALF_DUPLEX
-+ static int oldvol = -1;
-+ #endif
-+ #endif
-
- /* SOUNDINIT -- Open the sound peripheral and initialise for
- access. Return TRUE if successful, FALSE
-***************
-*** 145,150 ****
---- 154,174 ----
- }
- ioctl(Audio_fd, AUDIO_SETINFO, &Audio_info);
- #endif
-+ #ifndef sun
-+ #ifdef HALF_DUPLEX
-+ if (iomode == O_RDONLY) {
-+ if (oldvol == -1)
-+ oldvol = soundgetvol();
-+ soundplayvol(0);
-+ } else if ( iomode == O_WRONLY
-+ && oldvol != -1
-+ ) {
-+ if (soundgetvol() == 0)
-+ soundplayvol(oldvol);
-+ oldvol = -1;
-+ }
-+ #endif
-+ #endif
- return TRUE;
- }
- if (errno != EINTR) {
-***************
-*** 160,165 ****
---- 184,198 ----
- void soundterm()
- {
- if (audiof >= 0) {
-+ #ifndef sun
-+ #ifdef HALF_DUPLEX
-+ if (oldvol != -1) {
-+ if (soundgetvol() == 0)
-+ soundplayvol(oldvol);
-+ oldvol = -1;
-+ }
-+ #endif
-+ #endif
- if (close(audiof) < 0) {
- perror("closing audio device");
- }
-***************
-*** 210,219 ****
-
- arg = (value << 8) | value;
-
-! if (ioctl(Audio_fd, MIXER_WRITE(SOUND_MIXER_PCM), &arg) < 0)
-! perror("SOUND_MIXER_PCM");
- #endif
- }
-
- /* SOUNDRECGAIN -- Set recording gain from 0 (minimum) to 100 (maximum). */
-
---- 243,272 ----
-
- arg = (value << 8) | value;
-
-! if (ioctl(Audio_fd, SOUND_MIXER_WRITE_PCM, &arg) < 0)
-! perror("SOUND_MIXER_WRITE_PCM");
- #endif
- }
-+
-+ #ifndef sun
-+ #ifdef HALF_DUPLEX
-+
-+ /* SOUNDGETVOL -- Get current playback volume. */
-+
-+ int soundgetvol()
-+ {
-+ int arg, v1, v2;
-+
-+ if (ioctl(Audio_fd, SOUND_MIXER_READ_PCM, &arg) < 0) {
-+ perror("SOUND_MIXER_READ_PCM");
-+ return -1;
-+ }
-+ v1 = arg & 0xFF;
-+ v2 = (arg >> 8) & 0xFF;
-+ return (v1 > v2) ? v1 : v2;
-+ }
-+ #endif
-+ #endif
-
- /* SOUNDRECGAIN -- Set recording gain from 0 (minimum) to 100 (maximum). */
-
+--- soundbyte.c.orig Fri Dec 31 15:36:07 1999
++++ soundbyte.c Fri Dec 31 15:38:58 1999
+@@ -13,7 +13,9 @@
+ #ifdef Solaris
+ #include <sys/filio.h>
+ #else
++#ifndef __FreeBSD__
+ #include <sys/dir.h>
++#endif
+ #include <sys/file.h>
+ #endif
+