aboutsummaryrefslogtreecommitdiff
path: root/mbone
diff options
context:
space:
mode:
authorAssar Westerlund <assar@FreeBSD.org>2001-05-11 19:31:14 +0000
committerAssar Westerlund <assar@FreeBSD.org>2001-05-11 19:31:14 +0000
commit41802de4596f6bfaa52d8cc41d2e16a0d34efc21 (patch)
treea533e61d2c977127caaa2995692368bd2538f2aa /mbone
parentdf4bb3e2a4f17d07aa7888fd7b7876175432f340 (diff)
downloadports-41802de4596f6bfaa52d8cc41d2e16a0d34efc21.tar.gz
ports-41802de4596f6bfaa52d8cc41d2e16a0d34efc21.zip
wb compatible open source shared whiteboard program
Notes
Notes: svn path=/head/; revision=42535
Diffstat (limited to 'mbone')
-rw-r--r--mbone/Makefile1
-rw-r--r--mbone/wbd/Makefile21
-rw-r--r--mbone/wbd/distinfo1
-rw-r--r--mbone/wbd/files/patch-aa61
-rw-r--r--mbone/wbd/pkg-comment1
-rw-r--r--mbone/wbd/pkg-descr4
-rw-r--r--mbone/wbd/pkg-plist1
7 files changed, 90 insertions, 0 deletions
diff --git a/mbone/Makefile b/mbone/Makefile
index f64c9f779708..ec2378c24bc0 100644
--- a/mbone/Makefile
+++ b/mbone/Makefile
@@ -1,5 +1,6 @@
# $FreeBSD$
#
+ SUBDIR += wbd
SUBDIR += imm
SUBDIR += nte
diff --git a/mbone/wbd/Makefile b/mbone/wbd/Makefile
new file mode 100644
index 000000000000..e3519336402b
--- /dev/null
+++ b/mbone/wbd/Makefile
@@ -0,0 +1,21 @@
+# New ports collection makefile for: wbd
+# Date created: 11 May 2001
+# Whom: assar
+#
+# $FreeBSD$
+#
+
+PORTNAME= wbd
+PORTVERSION= 1.0u4
+CATEGORIES= mbone
+MASTER_SITES= http://www-mice.cs.ucl.ac.uk/multimedia/software/wbd/1.0ucl4/
+DISTNAME= wbd-1.0ucl4
+
+MAINTAINER= ports@FreeBSD.org
+
+LIB_DEPENDS= tk80.1:${PORTSDIR}/x11-toolkits/tk80
+
+WRKSRC= ${WRKDIR}/wbd
+MAKEFILE= makefile
+
+.include <bsd.port.mk>
diff --git a/mbone/wbd/distinfo b/mbone/wbd/distinfo
new file mode 100644
index 000000000000..633d44c6c29e
--- /dev/null
+++ b/mbone/wbd/distinfo
@@ -0,0 +1 @@
+MD5 (wbd-1.0ucl4.tar.gz) = 08fe22da79d3b6b0a62bc65fde4fdd57
diff --git a/mbone/wbd/files/patch-aa b/mbone/wbd/files/patch-aa
new file mode 100644
index 000000000000..fd53e111e985
--- /dev/null
+++ b/mbone/wbd/files/patch-aa
@@ -0,0 +1,61 @@
+--- makefile.orig Thu Jan 29 12:46:41 1998
++++ makefile Fri May 11 19:42:18 2001
+@@ -3,12 +3,12 @@
+
+ YFLAGS = -dv
+ CFLAGS = -g $(LIBFLAGS) $(IFLAGS) -DSTAND_ALONE
+-LIBDIR = /cs/research/mice/starship/common/solaris/lib
+-INCDIR = /cs/research/mice/starship/common/solaris/include
++LIBDIR = $(PREFIX)/lib
++INCDIR = $(PREFIX)/include
+
+ # The files needed from the tcl/tk library directories...
+-LIBRARY_TK = $(LIBDIR)/tk4.2
+-LIBRARY_TCL = $(LIBDIR)/tcl7.6
++LIBRARY_TK = $(LIBDIR)/tk8.0
++LIBRARY_TCL = $(LIBDIR)/tcl8.0
+
+
+ # Uncomment these lines for SGI (IRIX 5.3).
+@@ -32,10 +32,10 @@
+ #LIBS = -ll -ltk4.2 -ltcl7.6 -lm -lX11
+
+ # Uncomment these lines for Sun (SunOS 5.5.1).
+-CC = gcc -DFNDELAY=O_NDELAY -DBYTE_ORDER=4321 -ansi
+-LIBFLAGS = -L$(LIBDIR) -L/usr/openwin/lib
+-IFLAGS = -I$(INCDIR) -I/usr/openwin/include
+-LIBS = -ll -ltk4.2 -ltcl7.6 -lm -lX11 -lsocket -lnsl -ldl
++#CC = gcc -DFNDELAY=O_NDELAY -DBYTE_ORDER=4321 -ansi
++#LIBFLAGS = -L$(LIBDIR) -L/usr/openwin/lib
++#IFLAGS = -I$(INCDIR) -I/usr/openwin/include
++#LIBS = -ll -ltk4.2 -ltcl7.6 -lm -lX11 -lsocket -lnsl -ldl
+
+ # Uncomment these lines for NetBSD 1.2.
+ #CC = cc -ansi
+@@ -43,6 +43,12 @@
+ #IFLAGS = -I$(INCDIR)
+ #LIBS = -ll -ltk4.2 -ltcl7.6 -lm -lX11
+
++# Uncomment these lines for FreeBSD
++CC = cc
++LIBFLAGS = -L$(LIBDIR) -L/usr/X11R6/lib
++IFLAGS = -I$(INCDIR)/tk8.0 -I$(INCDIR)/tcl8.0 -I/usr/X11R6/include
++LIBS = -ll -ltk80 -ltcl80 -lm -lX11
++
+ # Tcl initialisation files to be compiled into a C string.
+ TCL_FILES = \
+ $(LIBRARY_TCL)/init.tcl \
+@@ -74,8 +80,13 @@
+ SRC = main.c comms.c db.c wbd.tcl
+ OBJ = main.o comms.o db.o tcllibs.o
+
++all : wbd
++
+ wbd : $(OBJ) $(INC)
+ $(CC) $(CFLAGS) $(OBJ) $(LIBS) -o wbd
++
++install : wbd
++ install -c wbd $(PREFIX)/bin/wbd
+
+ clean :
+ rm -f *.o tcl2c wbd core
diff --git a/mbone/wbd/pkg-comment b/mbone/wbd/pkg-comment
new file mode 100644
index 000000000000..33b258f29d82
--- /dev/null
+++ b/mbone/wbd/pkg-comment
@@ -0,0 +1 @@
+A shared drawing (whiteboard) tool using multicast, compatible with wb
diff --git a/mbone/wbd/pkg-descr b/mbone/wbd/pkg-descr
new file mode 100644
index 000000000000..f7cd91b44b7f
--- /dev/null
+++ b/mbone/wbd/pkg-descr
@@ -0,0 +1,4 @@
+This is a port of wbd, a open-source program compatible with the LBL
+program wb, which is multicast-based whiteboard program.
+
+WWW: http://www-mice.cs.ucl.ac.uk/multimedia/software/wbd/
diff --git a/mbone/wbd/pkg-plist b/mbone/wbd/pkg-plist
new file mode 100644
index 000000000000..69f16d4f50e7
--- /dev/null
+++ b/mbone/wbd/pkg-plist
@@ -0,0 +1 @@
+bin/wbd