aboutsummaryrefslogtreecommitdiff
path: root/mbone
diff options
context:
space:
mode:
authorBill Fenner <fenner@FreeBSD.org>2000-01-19 02:53:45 +0000
committerBill Fenner <fenner@FreeBSD.org>2000-01-19 02:53:45 +0000
commit6ba81458b21c347bc0a37fcf0ab6d1ae3a4259b8 (patch)
tree9370d0386b19ee59938b71d5353b84e38c9325b9 /mbone
parent47be594a53ad26fb4242719776b628de7f487004 (diff)
downloadports-6ba81458b21c347bc0a37fcf0ab6d1ae3a4259b8.tar.gz
ports-6ba81458b21c347bc0a37fcf0ab6d1ae3a4259b8.zip
Update to version 1.14
Notes
Notes: svn path=/head/; revision=24829
Diffstat (limited to 'mbone')
-rw-r--r--mbone/rtptools/Makefile14
-rw-r--r--mbone/rtptools/distinfo2
-rw-r--r--mbone/rtptools/files/patch-ab46
-rw-r--r--mbone/rtptools/pkg-plist2
4 files changed, 30 insertions, 34 deletions
diff --git a/mbone/rtptools/Makefile b/mbone/rtptools/Makefile
index e5c22145a5ed..c643af60de03 100644
--- a/mbone/rtptools/Makefile
+++ b/mbone/rtptools/Makefile
@@ -1,26 +1,22 @@
# New ports collection makefile for: rtptools
-# Version required: 1.9
+# Version required: 1.14
# Date created: 5 January 1998
# Whom: fenner
#
# $FreeBSD$
#
-DISTNAME= rtptools-1.9
+DISTNAME= rtptools-1.14
CATEGORIES= mbone
-MASTER_SITES= ftp://ftp.cs.columbia.edu/pub/schulzrinne/rtptools/
+MASTER_SITES= http://www.cs.columbia.edu/~hgs/rtptools/src/
MAINTAINER= fenner@FreeBSD.org
-MAKE_ENV= ARCH=freebsd CC=cc
+GNU_CONFIGURE= yes
-BINFILES= rtpdump rtpplay rtpsend rtptrans
DOCFILES= README CHANGES.html rtptools.html
-do-install:
-.for i in ${BINFILES}
- ${INSTALL_PROGRAM} ${WRKSRC}/freebsd/${i} ${PREFIX}/bin
-.endfor
+post-install:
.if !defined(NOPORTDOCS)
${MKDIR} ${PREFIX}/share/doc/rtptools
.for i in ${DOCFILES}
diff --git a/mbone/rtptools/distinfo b/mbone/rtptools/distinfo
index ee742b63edb4..07f0dfd19bb1 100644
--- a/mbone/rtptools/distinfo
+++ b/mbone/rtptools/distinfo
@@ -1 +1 @@
-MD5 (rtptools-1.9.tar.gz) = c459423c37451ffe1e52423b3eebcb09
+MD5 (rtptools-1.14.tar.gz) = 1b88a89d4fbf32fd54e8508d84ece62e
diff --git a/mbone/rtptools/files/patch-ab b/mbone/rtptools/files/patch-ab
index 2e991789f5b9..90f2b19065a9 100644
--- a/mbone/rtptools/files/patch-ab
+++ b/mbone/rtptools/files/patch-ab
@@ -1,7 +1,7 @@
Index: rtp.h
--- 1.1.1.2 1997/12/17 03:37:05
+++ rtp.h 1997/12/17 04:26:01
-@@ -93,13 +93,18 @@
+@@ -94,13 +94,18 @@
#define RTCP_VALID_MASK (0xc000 | 0x2000 | 0xfe)
#define RTCP_VALID_VALUE ((RTP_VERSION << 14) | RTCP_SR)
@@ -26,39 +26,39 @@ Index: rtp.h
Index: rtpdump.c
--- 1.1.1.2 1997/12/17 03:37:07
+++ rtpdump.c 1997/12/17 04:26:00
-@@ -395,10 +395,10 @@
- ntohl(r->r.sr.psent),
- ntohl(r->r.sr.osent));
+@@ -400,10 +400,10 @@
+ (unsigned long)ntohl(r->r.sr.psent),
+ (unsigned long)ntohl(r->r.sr.osent));
for (i = 0; i < r->common.count; i++) {
- printf(" (ssrc=%0lx fraction=%g lost=%lu last_seq=%lu jit=%lu lsr=%lu dlsr=%lu)\n",
-+ printf(" (ssrc=0x%lx fraction=%g lost=%ld last_seq=%lu jit=%lu lsr=%lu dlsr=%lu)\n",
- ntohl(r->r.sr.rr[i].ssrc),
++ printf(" (ssrc=0x%0lx fraction=%g lost=%lu last_seq=%lu jit=%lu lsr=%lu dlsr=%lu)\n",
+ (unsigned long)ntohl(r->r.sr.rr[i].ssrc),
- r->r.sr.rr[i].fraction / 256.,
-- ntohl(r->r.sr.rr[i].lost), /* XXX I'm pretty sure this is wrong */
+- (unsigned long)ntohl(r->r.sr.rr[i].lost), /* XXX I'm pretty sure this is wrong */
+ RTCP_FRACTION(ntohl(r->r.sr.rr[i].fraclost)) / 256.,
+ RTCP_LOST(ntohl(r->r.sr.rr[i].fraclost)),
- ntohl(r->r.sr.rr[i].last_seq),
- ntohl(r->r.sr.rr[i].jitter),
- ntohl(r->r.sr.rr[i].lsr),
-@@ -412,10 +412,10 @@
- ntohl(r->r.rr.ssrc), r->common.p, r->common.count,
- ntohs(r->common.length));
+ (unsigned long)ntohl(r->r.sr.rr[i].last_seq),
+ (unsigned long)ntohl(r->r.sr.rr[i].jitter),
+ (unsigned long)ntohl(r->r.sr.rr[i].lsr),
+@@ -417,10 +417,10 @@
+ (unsigned long)ntohl(r->r.rr.ssrc), r->common.p, r->common.count,
+ ntohs(r->common.length));
for (i = 0; i < r->common.count; i++) {
- printf("(ssrc=%0lx fraction=%g lost=%lu last_seq=%lu jit=%lu lsr=%lu dlsr=%lu)\n",
-+ printf(" (ssrc=0x%lx fraction=%g lost=%ld last_seq=%lu jit=%lu lsr=%lu dlsr=%lu)\n",
- ntohl(r->r.rr.rr[i].ssrc),
-- r->r.rr.rr[i].fraction / 256.,
-- ntohl(r->r.rr.rr[i].lost),
-+ RTCP_FRACTION(ntohl(r->r.rr.rr[i].fraclost)) / 256.,
-+ RTCP_LOST(ntohl(r->r.rr.rr[i].fraclost)),
- ntohl(r->r.rr.rr[i].last_seq),
- ntohl(r->r.rr.rr[i].jitter),
- ntohl(r->r.rr.rr[i].lsr),
++ printf(" (ssrc=0x%0lx fraction=%g lost=%lu last_seq=%lu jit=%lu lsr=%lu dlsr=%lu)\n",
+ (unsigned long)ntohl(r->r.rr.rr[i].ssrc),
+- r->r.rr.rr[i].fraction / 256.,
+- (unsigned long)ntohl(r->r.rr.rr[i].lost),
++ RTCP_FRACTION(ntohl(r->r.rr.rr[i].fraclost)) / 256.,
++ RTCP_LOST(ntohl(r->r.rr.rr[i].fraclost)),
+ (unsigned long)ntohl(r->r.rr.rr[i].last_seq),
+ (unsigned long)ntohl(r->r.rr.rr[i].jitter),
+ (unsigned long)ntohl(r->r.rr.rr[i].lsr),
===================================================================
Index: rtpsend.c
--- 1.1.1.2 1997/12/17 03:37:11
+++ rtpsend.c 1997/12/17 04:25:11
-@@ -599,6 +599,8 @@
+@@ -601,6 +601,8 @@
if (optind < argc) {
if (hpt(argv[optind], (struct sockaddr *)&sin, &ttl) < 0) usage(argv[0]);
diff --git a/mbone/rtptools/pkg-plist b/mbone/rtptools/pkg-plist
index acb3252439be..8283c955a1fe 100644
--- a/mbone/rtptools/pkg-plist
+++ b/mbone/rtptools/pkg-plist
@@ -3,6 +3,6 @@ bin/rtpplay
bin/rtpsend
bin/rtptrans
share/doc/rtptools/README
-share/doc/rtptools/CHANGES.html
+share/doc/rtptools/ChangeLog.html
share/doc/rtptools/rtptools.html
@dirrm share/doc/rtptools