aboutsummaryrefslogtreecommitdiff
path: root/mbone
diff options
context:
space:
mode:
authorBill Fenner <fenner@FreeBSD.org>2001-04-22 04:59:46 +0000
committerBill Fenner <fenner@FreeBSD.org>2001-04-22 04:59:46 +0000
commitcb1b258cb8b17269ee219bb927424337f010501f (patch)
tree5b2aa9d6881a722589e63c7611a05036529e196a /mbone
parent910b98bb83b1ca590f84b214e365961285b8f63a (diff)
downloadports-cb1b258cb8b17269ee219bb927424337f010501f.tar.gz
ports-cb1b258cb8b17269ee219bb927424337f010501f.zip
Update to rtptools 1.17
Notes
Notes: svn path=/head/; revision=41786
Diffstat (limited to 'mbone')
-rw-r--r--mbone/rtptools/Makefile4
-rw-r--r--mbone/rtptools/distinfo2
-rw-r--r--mbone/rtptools/files/patch-ab52
-rw-r--r--mbone/rtptools/files/patch-ac24
-rw-r--r--mbone/rtptools/files/patch-ad24
5 files changed, 54 insertions, 52 deletions
diff --git a/mbone/rtptools/Makefile b/mbone/rtptools/Makefile
index a926a4843282..8dfa5d3d8d07 100644
--- a/mbone/rtptools/Makefile
+++ b/mbone/rtptools/Makefile
@@ -6,9 +6,9 @@
#
PORTNAME= rtptools
-PORTVERSION= 1.14
+PORTVERSION= 1.17
CATEGORIES= mbone
-MASTER_SITES= http://www.cs.columbia.edu/~hgs/rtptools/src/
+MASTER_SITES= http://www.cs.columbia.edu/IRT/software/rtptools/src/
MAINTAINER= fenner@FreeBSD.org
diff --git a/mbone/rtptools/distinfo b/mbone/rtptools/distinfo
index 07f0dfd19bb1..d558546e5784 100644
--- a/mbone/rtptools/distinfo
+++ b/mbone/rtptools/distinfo
@@ -1 +1 @@
-MD5 (rtptools-1.14.tar.gz) = 1b88a89d4fbf32fd54e8508d84ece62e
+MD5 (rtptools-1.17.tar.gz) = 4af6ef6ba430f659d3d6478719911b65
diff --git a/mbone/rtptools/files/patch-ab b/mbone/rtptools/files/patch-ab
index 90f2b19065a9..c1d142b4a914 100644
--- a/mbone/rtptools/files/patch-ab
+++ b/mbone/rtptools/files/patch-ab
@@ -1,7 +1,6 @@
-Index: rtp.h
---- 1.1.1.2 1997/12/17 03:37:05
-+++ rtp.h 1997/12/17 04:26:01
-@@ -94,13 +94,18 @@
+--- rtp.h.orig Thu Mar 9 07:35:26 2000
++++ rtp.h Sat Apr 21 21:52:49 2001
+@@ -110,13 +110,18 @@
#define RTCP_VALID_MASK (0xc000 | 0x2000 | 0xfe)
#define RTCP_VALID_VALUE ((RTP_VERSION << 14) | RTCP_SR)
@@ -22,48 +21,3 @@ Index: rtp.h
u_int32 last_seq; /* extended last seq. no. received */
u_int32 jitter; /* interarrival jitter */
u_int32 lsr; /* last SR packet from this source */
-===================================================================
-Index: rtpdump.c
---- 1.1.1.2 1997/12/17 03:37:07
-+++ rtpdump.c 1997/12/17 04:26:00
-@@ -400,10 +400,10 @@
- (unsigned long)ntohl(r->r.sr.psent),
- (unsigned long)ntohl(r->r.sr.osent));
- for (i = 0; i < r->common.count; i++) {
-- printf(" (ssrc=%0lx fraction=%g lost=%lu last_seq=%lu jit=%lu lsr=%lu dlsr=%lu)\n",
-+ printf(" (ssrc=0x%0lx fraction=%g lost=%lu last_seq=%lu jit=%lu lsr=%lu dlsr=%lu)\n",
- (unsigned long)ntohl(r->r.sr.rr[i].ssrc),
-- r->r.sr.rr[i].fraction / 256.,
-- (unsigned long)ntohl(r->r.sr.rr[i].lost), /* XXX I'm pretty sure this is wrong */
-+ RTCP_FRACTION(ntohl(r->r.sr.rr[i].fraclost)) / 256.,
-+ RTCP_LOST(ntohl(r->r.sr.rr[i].fraclost)),
- (unsigned long)ntohl(r->r.sr.rr[i].last_seq),
- (unsigned long)ntohl(r->r.sr.rr[i].jitter),
- (unsigned long)ntohl(r->r.sr.rr[i].lsr),
-@@ -417,10 +417,10 @@
- (unsigned long)ntohl(r->r.rr.ssrc), r->common.p, r->common.count,
- ntohs(r->common.length));
- for (i = 0; i < r->common.count; i++) {
-- printf("(ssrc=%0lx fraction=%g lost=%lu last_seq=%lu jit=%lu lsr=%lu dlsr=%lu)\n",
-+ printf(" (ssrc=0x%0lx fraction=%g lost=%lu last_seq=%lu jit=%lu lsr=%lu dlsr=%lu)\n",
- (unsigned long)ntohl(r->r.rr.rr[i].ssrc),
-- r->r.rr.rr[i].fraction / 256.,
-- (unsigned long)ntohl(r->r.rr.rr[i].lost),
-+ RTCP_FRACTION(ntohl(r->r.rr.rr[i].fraclost)) / 256.,
-+ RTCP_LOST(ntohl(r->r.rr.rr[i].fraclost)),
- (unsigned long)ntohl(r->r.rr.rr[i].last_seq),
- (unsigned long)ntohl(r->r.rr.rr[i].jitter),
- (unsigned long)ntohl(r->r.rr.rr[i].lsr),
-===================================================================
-Index: rtpsend.c
---- 1.1.1.2 1997/12/17 03:37:11
-+++ rtpsend.c 1997/12/17 04:25:11
-@@ -601,6 +601,8 @@
-
- if (optind < argc) {
- if (hpt(argv[optind], (struct sockaddr *)&sin, &ttl) < 0) usage(argv[0]);
-+ } else {
-+ usage(argv[0]);
- }
-
- /* create/connect sockets */
diff --git a/mbone/rtptools/files/patch-ac b/mbone/rtptools/files/patch-ac
new file mode 100644
index 000000000000..28056951ca69
--- /dev/null
+++ b/mbone/rtptools/files/patch-ac
@@ -0,0 +1,24 @@
+--- rtpdump.c.orig Sat Apr 7 08:02:13 2001
++++ rtpdump.c Sat Apr 21 21:54:10 2001
+@@ -429,8 +429,8 @@
+ for (i = 0; i < r->common.count; i++) {
+ fprintf(out, " (ssrc=0x%lx fraction=%g lost=%lu last_seq=%lu jit=%lu lsr=%lu dlsr=%lu )\n",
+ (unsigned long)ntohl(r->r.sr.rr[i].ssrc),
+- r->r.sr.rr[i].fraction / 256.,
+- (unsigned long)ntohl(r->r.sr.rr[i].lost), /* XXX I'm pretty sure this is wrong */
++ RTCP_FRACTION(ntohl(r->r.sr.rr[i].fraclost)) / 256.,
++ RTCP_LOST(ntohl(r->r.sr.rr[i].fraclost)),
+ (unsigned long)ntohl(r->r.sr.rr[i].last_seq),
+ (unsigned long)ntohl(r->r.sr.rr[i].jitter),
+ (unsigned long)ntohl(r->r.sr.rr[i].lsr),
+@@ -446,8 +446,8 @@
+ for (i = 0; i < r->common.count; i++) {
+ fprintf(out, " (ssrc=0x%lx fraction=%g lost=%lu last_seq=%lu jit=%lu lsr=%lu dlsr=%lu )\n",
+ (unsigned long)ntohl(r->r.rr.rr[i].ssrc),
+- r->r.rr.rr[i].fraction / 256.,
+- (unsigned long)ntohl(r->r.rr.rr[i].lost),
++ RTCP_FRACTION(ntohl(r->r.rr.rr[i].fraclost)) / 256.,
++ RTCP_LOST(ntohl(r->r.rr.rr[i].fraclost)),
+ (unsigned long)ntohl(r->r.rr.rr[i].last_seq),
+ (unsigned long)ntohl(r->r.rr.rr[i].jitter),
+ (unsigned long)ntohl(r->r.rr.rr[i].lsr),
diff --git a/mbone/rtptools/files/patch-ad b/mbone/rtptools/files/patch-ad
new file mode 100644
index 000000000000..e7bbdd966728
--- /dev/null
+++ b/mbone/rtptools/files/patch-ad
@@ -0,0 +1,24 @@
+--- rtpsend.c.orig Fri Apr 6 18:18:26 2001
++++ rtpsend.c Sat Apr 21 21:59:35 2001
+@@ -351,9 +351,9 @@
+ if (strcmp(n->type, "ssrc") == 0)
+ rr->ssrc = htonl(n->num);
+ else if (strcmp(n->type, "fraction") == 0)
+- rr->fraction = (n->num)*256;
+- else if (strcmp(n->type, "lost") == 0) /* PP: alignment OK? */
+- rr->lost = htonl(n->num);
++ rr->fraclost = htonl((ntohl(rr->fraclost) & 0x00ffffff) | ((n->num)*256 << 24));
++ else if (strcmp(n->type, "lost") == 0)
++ rr->fraclost = htonl((ntohl(rr->fraclost) & 0xff000000) | n->num);
+ else if (strcmp(n->type, "last_seq") == 0)
+ rr->last_seq = htonl(n->num);
+ else if (strcmp(n->type, "jit") == 0)
+@@ -899,6 +899,8 @@
+
+ if (optind < argc) {
+ if (hpt(argv[optind], (struct sockaddr *)&sin, &ttl) < 0) usage(argv[0]);
++ } else {
++ usage(argv[0]);
+ }
+
+ /* create/connect sockets */