aboutsummaryrefslogtreecommitdiff
path: root/mbone
diff options
context:
space:
mode:
authorBill Fenner <fenner@FreeBSD.org>1997-09-25 00:10:59 +0000
committerBill Fenner <fenner@FreeBSD.org>1997-09-25 00:10:59 +0000
commit7d19bc81ee19a7aba959f8666f92b4dc432b8a7e (patch)
tree1a154a287295f158f578a0229f391b56afb9d88e /mbone
parentc3169a276e26cb3b12363424a20f91ed35652c81 (diff)
downloadports-7d19bc81ee19a7aba959f8666f92b4dc432b8a7e.tar.gz
ports-7d19bc81ee19a7aba959f8666f92b4dc432b8a7e.zip
Use tcl7.6 and tk4.2, and use autoconf instead of patching configure script.
Notes
Notes: svn path=/head/; revision=8020
Diffstat (limited to 'mbone')
-rw-r--r--mbone/rtpmon/Makefile10
-rw-r--r--mbone/rtpmon/files/patch-aa63
2 files changed, 47 insertions, 26 deletions
diff --git a/mbone/rtpmon/Makefile b/mbone/rtpmon/Makefile
index 6d5533d63eee..21a203ee88de 100644
--- a/mbone/rtpmon/Makefile
+++ b/mbone/rtpmon/Makefile
@@ -3,21 +3,25 @@
# Date created: 1 November 1996
# Whom: Bill Fenner <fenner@FreeBSD.ORG>
#
-# $Id: Makefile,v 1.3 1997/04/20 13:19:24 wosch Exp $
+# $Id: Makefile,v 1.4 1997/05/22 05:37:55 fenner Exp $
#
DISTNAME= rtpmon-1.0a7
-CATEGORIES= mbone tk41
+CATEGORIES= mbone
MASTER_SITES= ftp://mm-ftp.cs.berkeley.edu/pub/rtpmon/
MAINTAINER= fenner@FreeBSD.org
-LIB_DEPENDS= tk41\\.1:${PORTSDIR}/x11/tk41
+LIB_DEPENDS= tk42\\.1:${PORTSDIR}/x11/tk42
+BUILD_DEPENDS= autoconf:${PORTSDIR}/devel/autoconf
GNU_CONFIGURE= yes
USE_X11= yes
MAN1= rtpmon.1
+pre-configure:
+ @cd ${WRKSRC}; autoconf
+
post-install:
strip ${PREFIX}/bin/rtpmon
diff --git a/mbone/rtpmon/files/patch-aa b/mbone/rtpmon/files/patch-aa
index 21c999ab8d8a..39dbb2a57514 100644
--- a/mbone/rtpmon/files/patch-aa
+++ b/mbone/rtpmon/files/patch-aa
@@ -1,23 +1,40 @@
---- configure.orig Tue Oct 22 22:32:09 1996
-+++ configure Wed Nov 6 22:57:53 1996
-@@ -1609,6 +1609,7 @@
- $prefix/lib/tcl7.6 \
- $prefix/share/lib/tcl7.6 \
- $x_libraries/tcl7.6 \
-+ /usr/libdata/tcl \
- $dir/lib/tcl7.5 \
- $dir/share/lib/tcl7.5 \
- ../tcl7.5/library \
-@@ -1951,6 +1952,12 @@
- LDFLAGS="$LDFLAGS -L$place"
- libtk="-ltk41"
- fi
-+
-+ if test -r $place/libtk41.so.1.0 ; then
-+ echo "$ac_t""$place/libtk41.so.1.0" 1>&6
-+ LDFLAGS="$LDFLAGS -L$place"
-+ libtk="-ltk41"
-+ fi
-
- if test "$libtk" = "no" ; then
- if test -r $place/libtk4.2.a ; then
+--- configure.in.orig Wed Jan 15 14:44:04 1997
++++ configure.in Wed Sep 24 17:09:03 1997
+@@ -109,6 +109,7 @@
+ /usr/src/tcl7.6/generic \
+ /usr/local/src/tcl7.6/generic \
+ /usr/src/local/tcl7.6/generic \
++ /usr/local/include/tcl7.6 \
+ ../tcl7.5/generic \
+ /usr/src/tcl7.5/generic \
+ /usr/local/src/tcl7.5/generic \
+@@ -189,6 +190,10 @@
+ AC_MSG_RESULT($place/libtcl7.6.a)
+ LDFLAGS="$LDFLAGS -L$place"
+ libtcl="-ltcl7.6"
++ elif test -r $place/libtcl76.a ; then
++ AC_MSG_RESULT($place/libtcl7.6.a)
++ LDFLAGS="$LDFLAGS -L$place"
++ libtcl="-ltcl76"
+ elif test -r $place/libtcl7.5.a ; then
+ AC_MSG_RESULT($place/libtcl7.5.a)
+ LDFLAGS="$LDFLAGS -L$place"
+@@ -287,6 +292,7 @@
+ if test "$found_tk_h" = "no" ; then
+ AC_MSG_CHECKING(for tk.h)
+ places="$dir/include \
++ /usr/local/include/tk4.2 \
+ ../tk4.1/generic \
+ /usr/src/tk4.1/generic \
+ /usr/local/src/tk4.1/generic \
+@@ -349,6 +355,10 @@
+ AC_MSG_RESULT($place/libtk4.2.a)
+ LDFLAGS="$LDFLAGS -L$place"
+ libtk="-ltk4.2"
++ elif test -r $place/libtk42.a ; then
++ AC_MSG_RESULT($place/libtk42.a)
++ LDFLAGS="$LDFLAGS -L$place"
++ libtk="-ltk42"
+ elif test -r $place/libtk4.1.a ; then
+ AC_MSG_RESULT($place/libtk4.1.a)
+ LDFLAGS="$LDFLAGS -L$place"