aboutsummaryrefslogtreecommitdiff
path: root/misc/boxes/Makefile
diff options
context:
space:
mode:
authorVolker Stolz <vs@FreeBSD.org>2005-04-22 09:00:37 +0000
committerVolker Stolz <vs@FreeBSD.org>2005-04-22 09:00:37 +0000
commit3ed5971f4927f1c9cdd7cff97ed09888b528b542 (patch)
tree0301ffd93231928aa16588dafaee630cce5784de /misc/boxes/Makefile
parent4d74133072d76f8deab50c98d7194ba2d97b4d53 (diff)
downloadports-3ed5971f4927f1c9cdd7cff97ed09888b528b542.tar.gz
ports-3ed5971f4927f1c9cdd7cff97ed09888b528b542.zip
- Fix runtime error by regenerating path in config.h
- Use MAKE_ARGS instead of patches
Notes
Notes: svn path=/head/; revision=133919
Diffstat (limited to 'misc/boxes/Makefile')
-rw-r--r--misc/boxes/Makefile5
1 files changed, 4 insertions, 1 deletions
diff --git a/misc/boxes/Makefile b/misc/boxes/Makefile
index 36c2bdf5fe0d..99910b39b93d 100644
--- a/misc/boxes/Makefile
+++ b/misc/boxes/Makefile
@@ -21,12 +21,15 @@ MAN1= boxes.1
USE_GMAKE= yes
USE_BISON= yes
ALL_TARGET= boxes
-MAKE_ARGS= GLOBALCONF=${GLOBALCONF} CFLAGS_ADDTL="${CFLAGS}"
+MAKE_ARGS= CC="${CC}" GLOBALCONF=${GLOBALCONF} CFLAGS="${CFLAGS} -ansi -I. -Iregexp"
GLOBALCONF= ${DATADIR}/boxes-config
PLIST_FILES= bin/boxes share/boxes/boxes-config
PLIST_DIRS= share/boxes
+do-configure:
+ ${RM} ${WRKSRC}/src/boxes.h ${WRKSRC}/doc/boxes.1
+
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/src/boxes ${PREFIX}/bin
${MKDIR} ${DATADIR}