aboutsummaryrefslogtreecommitdiff
path: root/misc/boxes
diff options
context:
space:
mode:
authorKris Kennaway <kris@FreeBSD.org>2002-10-21 01:00:52 +0000
committerKris Kennaway <kris@FreeBSD.org>2002-10-21 01:00:52 +0000
commita735943d25bc4fdb0f88a6ba6b02db5e6f839e51 (patch)
treecdb19b8e2bc1f04ac519ea597aeb460df2756070 /misc/boxes
parent258e006f52a2e57513b3115a54e4b54b9d4a7499 (diff)
downloadports-a735943d25bc4fdb0f88a6ba6b02db5e6f839e51.tar.gz
ports-a735943d25bc4fdb0f88a6ba6b02db5e6f839e51.zip
Fix build on -current (don't try and build with cc -traditional).
Respect CC and CFLAGS
Notes
Notes: svn path=/head/; revision=68465
Diffstat (limited to 'misc/boxes')
-rw-r--r--misc/boxes/Makefile3
-rw-r--r--misc/boxes/files/patch-aa11
-rw-r--r--misc/boxes/files/patch-ab13
3 files changed, 24 insertions, 3 deletions
diff --git a/misc/boxes/Makefile b/misc/boxes/Makefile
index 9747271d1a7a..6eaa616467f2 100644
--- a/misc/boxes/Makefile
+++ b/misc/boxes/Makefile
@@ -23,9 +23,6 @@ MAKE_ARGS= GLOBALCONF=${GLOBALCONF} CFLAGS_ADDTL="${CFLAGS}"
GLOBALCONF= ${PREFIX}/share/boxes/boxes-config
-do-patch:
- ${TOUCH} ${WRKSRC}/Makefile
-
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/src/boxes ${PREFIX}/bin
${MKDIR} ${PREFIX}/share/boxes
diff --git a/misc/boxes/files/patch-aa b/misc/boxes/files/patch-aa
new file mode 100644
index 000000000000..fba8cd8bb141
--- /dev/null
+++ b/misc/boxes/files/patch-aa
@@ -0,0 +1,11 @@
+--- ./src/regexp/Makefile.orig Sun Oct 20 17:56:12 2002
++++ ./src/regexp/Makefile Sun Oct 20 17:56:19 2002
+@@ -32,7 +32,7 @@
+ #============================================================================
+
+
+-CFLAGS = -traditional -O -I. $(CFLAGS_ADDTL)
++CFLAGS += -I. $(CFLAGS_ADDTL)
+
+ ALL_CL = regexp/regexp.c regexp/regsub.c
+ C_SRC = $(notdir $(ALL_CL))
diff --git a/misc/boxes/files/patch-ab b/misc/boxes/files/patch-ab
new file mode 100644
index 000000000000..55497855b01c
--- /dev/null
+++ b/misc/boxes/files/patch-ab
@@ -0,0 +1,13 @@
+--- ./src/Makefile.orig Sun Oct 20 17:58:59 2002
++++ ./src/Makefile Sun Oct 20 17:59:05 2002
+@@ -78,8 +78,8 @@
+
+ LEX = flex
+ YACC = bison
+-CC = gcc
+-CFLAGS = -ansi -I. -Iregexp -Wall -W $(CFLAGS_ADDTL)
++CC ?= cc
++CFLAGS += -ansi -I. -Iregexp -Wall -W $(CFLAGS_ADDTL)
+ LDFLAGS = -Lregexp
+
+ GEN_HDR = parser.h boxes.h