aboutsummaryrefslogtreecommitdiff
path: root/misc/brs
diff options
context:
space:
mode:
authorKevin Lo <kevlo@FreeBSD.org>2000-07-12 15:37:32 +0000
committerKevin Lo <kevlo@FreeBSD.org>2000-07-12 15:37:32 +0000
commit887b1c5f4718ee6d6ca98d3734663533cffabd34 (patch)
tree7c75a6d05123a879697d321c6897d10f8e4d842b /misc/brs
parente1d0f1ba74f7a49e5c9769d731e8364441592f11 (diff)
downloadports-887b1c5f4718ee6d6ca98d3734663533cffabd34.tar.gz
ports-887b1c5f4718ee6d6ca98d3734663533cffabd34.zip
Initial import of brs.
brs is an interactive King James Bible. PR: 19836 Submitted by: Kim Scarborough <sluggo@unknown.nu>
Notes
Notes: svn path=/head/; revision=30526
Diffstat (limited to 'misc/brs')
-rw-r--r--misc/brs/Makefile24
-rw-r--r--misc/brs/distinfo1
-rw-r--r--misc/brs/files/patch-aa38
-rw-r--r--misc/brs/files/patch-ab39
-rw-r--r--misc/brs/pkg-comment1
-rw-r--r--misc/brs/pkg-descr7
-rw-r--r--misc/brs/pkg-plist3
7 files changed, 113 insertions, 0 deletions
diff --git a/misc/brs/Makefile b/misc/brs/Makefile
new file mode 100644
index 000000000000..0cfe316e9da1
--- /dev/null
+++ b/misc/brs/Makefile
@@ -0,0 +1,24 @@
+# New ports collection makefile for: brs
+# Date created: 10 July 2000
+# Whom: Kim Scarborough <user@unknown.nu>
+#
+# $FreeBSD$
+#
+
+PORTNAME= brs
+PORTVERSION= 4.0
+DISTNAME= brs.4.00.l1
+CATEGORIES= misc
+MASTER_SITES= ${MASTER_SITE_SUNSITE} \
+ http://www.unknown.nu/ports/
+MASTER_SITE_SUBDIR= apps/religion
+
+MAINTAINER= user@unknown.nu
+
+WRKSRC= ${WRKDIR}/bible
+ALL_TARGET=
+
+MAN1= bible.1
+MANCOMPRESSED= no
+
+.include <bsd.port.mk>
diff --git a/misc/brs/distinfo b/misc/brs/distinfo
new file mode 100644
index 000000000000..1ab52ccd74bf
--- /dev/null
+++ b/misc/brs/distinfo
@@ -0,0 +1 @@
+MD5 (brs.4.00.l1.tar.gz) = 260b789e0ff401293ef05809fc42581b
diff --git a/misc/brs/files/patch-aa b/misc/brs/files/patch-aa
new file mode 100644
index 000000000000..8ea4cda6b904
--- /dev/null
+++ b/misc/brs/files/patch-aa
@@ -0,0 +1,38 @@
+--- Makefile.orig Wed Jul 12 23:30:36 2000
++++ Makefile Wed Jul 12 23:32:29 2000
+@@ -46,7 +46,7 @@
+ NINSTPKG = $(PROGRAM).pkg
+
+ # where to install this stuff
+-DEST = /usr
++DEST = $(PREFIX)
+ #DEST = $(HOME)/local
+ DESTBIN = $(DEST)/bin
+ DESTLIB = $(DEST)/lib
+@@ -405,23 +405,20 @@
+ @if [ $(DESTBIN) != . ]; then \
+ ((cd $(DESTBIN);rm -f $(PROGRAM)); \
+ cp $(PROGRAM) $(DESTBIN)); \
+- chown bin $(DESTBIN)/$(PROGRAM); \
+- chgrp bin $(DESTBIN)/$(PROGRAM); \
++ chown root:wheel $(DESTBIN)/$(PROGRAM); \
+ chmod 755 $(DESTBIN)/$(PROGRAM); fi
+ @echo Installing $(DATA) and $(DATA).conc in $(DESTLIB)
+ @if [ ! -r $(DESTLIB) ]; then mkdir $(DESTLIB); fi
+ @if [ $(DESTLIB) != . ]; then \
+ cp $(DATA) $(DATA).conc $(DESTLIB); \
+- chown bin $(DESTLIB)/$(DATA) $(DESTLIB)/$(DATA).conc; \
+- chgrp bin $(DESTLIB)/$(DATA) $(DESTLIB)/$(DATA).conc; \
++ chown root:wheel $(DESTLIB)/$(DATA) $(DESTLIB)/$(DATA).conc; \
+ chmod 644 $(DESTLIB)/$(DATA) $(DESTLIB)/$(DATA).conc; fi
+ @if [ ! -r $(DESTMAN) ]; then mkdir $(DESTMAN); fi
+ @echo Installing $(MAN) in $(DESTMAN1)
+ @if [ ! -r $(DESTMAN1) ]; then mkdir $(DESTMAN1); fi
+ @if [ $(DESTMAN1) != . ]; then \
+ cp $(MAN) $(DESTMAN1)/$(MAN); \
+- chown bin $(DESTMAN1)/$(MAN); \
+- chgrp bin $(DESTMAN1)/$(MAN); \
++ chown root:wheel $(DESTMAN1)/$(MAN); \
+ chmod 644 $(DESTMAN1)/$(MAN); fi
+
+ uninstall:; @echo Un-installing $(PROGRAM), $(DATA) and $(MAN)
diff --git a/misc/brs/files/patch-ab b/misc/brs/files/patch-ab
new file mode 100644
index 000000000000..a6294b5b92a0
--- /dev/null
+++ b/misc/brs/files/patch-ab
@@ -0,0 +1,39 @@
+*** bible.1.orig Mon Dec 12 13:05:28 1994
+--- bible.1 Mon Jul 10 13:34:08 2000
+***************
+*** 314,330 ****
+ Miscellaneous program control commands:
+
+ .TP 15 "\w'\-t\ prefix\ \ 'u"
+! .B \?, ?h, ?help
+ Prints help text.
+ .TP
+! .B \?f
+ Toggles output formatting modes.
+ .TP
+! .BI \?w file
+ Begin writing program output to a file. If file exists, output is
+ appended to what's there already.
+ .TP
+! .B \?w
+ Stop writing to a file.
+ .TP
+ .B \>, \<
+--- 314,330 ----
+ Miscellaneous program control commands:
+
+ .TP 15 "\w'\-t\ prefix\ \ 'u"
+! .B ?, ?h, ?help
+ Prints help text.
+ .TP
+! .B ?f
+ Toggles output formatting modes.
+ .TP
+! .BI ?w file
+ Begin writing program output to a file. If file exists, output is
+ appended to what's there already.
+ .TP
+! .B ?w
+ Stop writing to a file.
+ .TP
+ .B \>, \<
diff --git a/misc/brs/pkg-comment b/misc/brs/pkg-comment
new file mode 100644
index 000000000000..66b5e4ae21e5
--- /dev/null
+++ b/misc/brs/pkg-comment
@@ -0,0 +1 @@
+An interactive King James Bible
diff --git a/misc/brs/pkg-descr b/misc/brs/pkg-descr
new file mode 100644
index 000000000000..5091ae830d9b
--- /dev/null
+++ b/misc/brs/pkg-descr
@@ -0,0 +1,7 @@
+Bible Retrieval System (BRS) consists of a textual database of the
+Authorized ("King James") Version of the Old and New Testaments, a set
+of libraries for finding and retrieving text, and a program ("bible")
+which uses the libraries to retrieve Bible passages given references
+on the command line or from standard input.
+
+WWW: http://bible.theverge.com/brs.html
diff --git a/misc/brs/pkg-plist b/misc/brs/pkg-plist
new file mode 100644
index 000000000000..d127cd53958d
--- /dev/null
+++ b/misc/brs/pkg-plist
@@ -0,0 +1,3 @@
+bin/bible
+lib/bible.data
+lib/bible.data.conc