aboutsummaryrefslogtreecommitdiff
path: root/misc/dahdi-kmod
diff options
context:
space:
mode:
authorMax Khon <fjoe@FreeBSD.org>2010-09-01 15:22:32 +0000
committerMax Khon <fjoe@FreeBSD.org>2010-09-01 15:22:32 +0000
commit95f3227edc19bda5846859444340894b2114d1b5 (patch)
tree45bbcdab81303e61f86d57612aa939881c2f2901 /misc/dahdi-kmod
parent5137b410453ee8c7547f833fc9fe6158ec5e8ba5 (diff)
downloadports-95f3227edc19bda5846859444340894b2114d1b5.tar.gz
ports-95f3227edc19bda5846859444340894b2114d1b5.zip
Fix wctdm driver parameters declaration.
Sponsored by: The FreeBSD Foundation
Notes
Notes: svn path=/head/; revision=260371
Diffstat (limited to 'misc/dahdi-kmod')
-rw-r--r--misc/dahdi-kmod/Makefile2
-rw-r--r--misc/dahdi-kmod/files/patch-freebsd-drivers-dahdi-wctdm.c36
2 files changed, 37 insertions, 1 deletions
diff --git a/misc/dahdi-kmod/Makefile b/misc/dahdi-kmod/Makefile
index c8af029fb3ab..f77482bf6580 100644
--- a/misc/dahdi-kmod/Makefile
+++ b/misc/dahdi-kmod/Makefile
@@ -7,7 +7,7 @@
PORTNAME= dahdi
PORTVERSION= ${DAHDI_VERSION:S/-//g}
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= misc kld
MASTER_SITES= ${MASTER_SITE_LOCAL}\
http://downloads.digium.com/pub/telephony/firmware/releases/:firmware
diff --git a/misc/dahdi-kmod/files/patch-freebsd-drivers-dahdi-wctdm.c b/misc/dahdi-kmod/files/patch-freebsd-drivers-dahdi-wctdm.c
new file mode 100644
index 000000000000..ae8499a5aba5
--- /dev/null
+++ b/misc/dahdi-kmod/files/patch-freebsd-drivers-dahdi-wctdm.c
@@ -0,0 +1,36 @@
+--- freebsd/drivers/dahdi/wctdm.c.orig 2010-09-01 22:06:31.000000000 +0700
++++ freebsd/drivers/dahdi/wctdm.c 2010-09-01 22:17:48.000000000 +0700
+@@ -341,7 +341,11 @@
+ static int boostringer = 0;
+ static int fastringer = 0;
+ static int _opermode = 0;
++#if defined(__FreeBSD__)
++static char opermode[16] = "FCC";
++#else
+ static char *opermode = "FCC";
++#endif
+ static int fxshonormode = 0;
+ static int alawoverride = 0;
+ static int fastpickup = 0;
+@@ -3141,6 +3145,7 @@
+ {
+ pci_unregister_driver(&wctdm_driver);
+ }
++#endif /* !__FreeBSD__ */
+
+ module_param(debug, int, 0600);
+ module_param(fxovoltage, int, 0600);
+@@ -3166,6 +3171,7 @@
+ module_param(fxstxgain, int, 0600);
+ module_param(fxsrxgain, int, 0600);
+
++#if !defined(__FreeBSD__)
+ MODULE_DESCRIPTION("Wildcard TDM400P Driver");
+ MODULE_AUTHOR("Mark Spencer <markster@digium.com>");
+ MODULE_ALIAS("wcfxs");
+@@ -3173,4 +3179,4 @@
+
+ module_init(wctdm_init);
+ module_exit(wctdm_cleanup);
+-#endif /* !__FreeBSD__ */
++#endif