aboutsummaryrefslogtreecommitdiff
path: root/misc/dejagnu/Makefile
diff options
context:
space:
mode:
authorMark Murray <markm@FreeBSD.org>1996-10-31 19:53:40 +0000
committerMark Murray <markm@FreeBSD.org>1996-10-31 19:53:40 +0000
commitcfa6d6025cf961f5103e5ff59e69393cf1038243 (patch)
tree8033c31945d4faac1a69f5bb750f1f81fe7b5101 /misc/dejagnu/Makefile
parente7643e3110196b39d90ac92ef725fb6ee4b04bdb (diff)
downloadports-cfa6d6025cf961f5103e5ff59e69393cf1038243.tar.gz
ports-cfa6d6025cf961f5103e5ff59e69393cf1038243.zip
DejaGNU is an automated testing tool. It uses expect to run your tests.
Notes
Notes: svn path=/head/; revision=4223
Diffstat (limited to 'misc/dejagnu/Makefile')
-rw-r--r--misc/dejagnu/Makefile29
1 files changed, 29 insertions, 0 deletions
diff --git a/misc/dejagnu/Makefile b/misc/dejagnu/Makefile
new file mode 100644
index 000000000000..710a71e87efe
--- /dev/null
+++ b/misc/dejagnu/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: dejagnu
+# Version required: 1.3
+# Date created: 12 October 1996
+# Whom: markm
+#
+# $Id$
+#
+
+DISTNAME= dejagnu-1.3
+PKGNAME= dejagnu-1.3
+CATEGORIES+= devel
+MASTER_SITES= ftp://prep.ai.mit.edu/pub/gnu/
+
+WRKSRC= ${WRKDIR}/${DISTNAME}/dejagnu
+
+MAINTAINER= markm@FreeBSD.ORG
+
+RUN_DEPENDS= expect:${PORTSDIR}/lang/expect
+
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= i386-freebsd --prefix=${PREFIX}
+STRIP=
+
+post-install:
+.if !defined(NOMANCOMPRESS)
+ gzip -9nf ${PREFIX}/man/man1/runtest.1
+.endif
+
+.include <bsd.port.mk>