aboutsummaryrefslogtreecommitdiff
path: root/misc/gkrellweather2/Makefile
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2005-03-01 23:35:17 +0000
committerPav Lucistnik <pav@FreeBSD.org>2005-03-01 23:35:17 +0000
commit28eaef1ec7bae7a75a36f01293c649e3e3d1a135 (patch)
treecfe5a1a0fd67b1ea1740aa9111bd2e1ba76686b0 /misc/gkrellweather2/Makefile
parentf018d5629aa7e9d8d87e3a38f34661dd6a670da5 (diff)
downloadports-28eaef1ec7bae7a75a36f01293c649e3e3d1a135.tar.gz
ports-28eaef1ec7bae7a75a36f01293c649e3e3d1a135.zip
- Update to 2.0.7
- Use own copy of GrabWeather instead of wmweather's, which disappeared in latest revision of that port - Bandaid lack of C99 builtins in gcc in FreeBSD 4 (untested - runtesting welcome!)
Notes
Notes: svn path=/head/; revision=130135
Diffstat (limited to 'misc/gkrellweather2/Makefile')
-rw-r--r--misc/gkrellweather2/Makefile16
1 files changed, 11 insertions, 5 deletions
diff --git a/misc/gkrellweather2/Makefile b/misc/gkrellweather2/Makefile
index a1fec3731d6e..ebc60fd1b22a 100644
--- a/misc/gkrellweather2/Makefile
+++ b/misc/gkrellweather2/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= gkrellweather
-PORTVERSION= 2.0.6
-PORTREVISION= 3
+PORTVERSION= 2.0.7
CATEGORIES= misc
MASTER_SITES= http://kmlinux.fjfi.cvut.cz/~makovick/gkrellm/
EXTRACT_SUFX= .tgz
@@ -16,8 +15,7 @@ MAINTAINER= pav@FreeBSD.org
COMMENT= GKrellWeather is a weather plugin for GKrellM
BUILD_DEPENDS= ${X11BASE}/include/gkrellm2/gkrellm.h:${PORTSDIR}/sysutils/gkrellm2
-RUN_DEPENDS= gkrellm:${PORTSDIR}/sysutils/gkrellm2 \
- ${X11BASE}/bin/GrabWeather:${PORTSDIR}/misc/wmweather
+RUN_DEPENDS= gkrellm:${PORTSDIR}/sysutils/gkrellm2
USE_GMAKE= yes
USE_X_PREFIX= yes
@@ -25,10 +23,18 @@ ALL_TARGET= gkrellweather.so
MAKE_ENV= enable_nls=1 PTHREAD_LIBS=${PTHREAD_LIBS}
+.include <bsd.port.pre.mk>
+
+# uses C99 builtin lrintf
+.if ${OSVERSION} < 500000
+EXTRA_PATCHES= ${FILESDIR}/extra-patch-lrintf
+.endif
+
do-install:
${MKDIR} ${PREFIX}/libexec/gkrellm2/plugins
${INSTALL_DATA} ${WRKSRC}/gkrellweather.so ${PREFIX}/libexec/gkrellm2/plugins
${MKDIR} ${PREFIX}/share/locale/ru/
${INSTALL_DATA} ${WRKSRC}/po/ru.mo ${PREFIX}/share/locale/ru/LC_MESSAGES/gkrellweather.mo
+ ${INSTALL_SCRIPT} ${WRKSRC}/GrabWeather ${PREFIX}/bin
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>