aboutsummaryrefslogtreecommitdiff
path: root/misc/gkx86info2
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2004-12-23 09:41:54 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2004-12-23 09:41:54 +0000
commitad1d89d5a647dceb5d83297ff670363b8bb7c0bb (patch)
tree31ff4908b6b5e61c71bc9cedc2c1ce9ea0fb7807 /misc/gkx86info2
parent986259ccbf6d91e2ff075b2a491de68be4947b1d (diff)
downloadports-ad1d89d5a647dceb5d83297ff670363b8bb7c0bb.tar.gz
ports-ad1d89d5a647dceb5d83297ff670363b8bb7c0bb.zip
[New Port] misc/gkx86info2 - GKrellM2 plugin printing current clock speed
GKrellM2 plugin that simply prints the current clock speed PR: ports/68919 Submitted by: Tobias Roth <ports@fsck.ch>
Notes
Notes: svn path=/head/; revision=124939
Diffstat (limited to 'misc/gkx86info2')
-rw-r--r--misc/gkx86info2/Makefile48
-rw-r--r--misc/gkx86info2/distinfo4
-rw-r--r--misc/gkx86info2/files/patch-MHz.c19
-rw-r--r--misc/gkx86info2/pkg-descr13
-rw-r--r--misc/gkx86info2/pkg-plist7
5 files changed, 30 insertions, 61 deletions
diff --git a/misc/gkx86info2/Makefile b/misc/gkx86info2/Makefile
index 1d61cde46e68..c2d30c66cdb2 100644
--- a/misc/gkx86info2/Makefile
+++ b/misc/gkx86info2/Makefile
@@ -1,46 +1,42 @@
-# New ports collection makefile for: gkx86info
-# Date created: Thu Aug 8 01:49:15 UTC 2002
-# Whom: Mario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>
+# New ports collection makefile for: gkx86info2
+# Date created: Tue Apr 27 14:15:53 CEST 2004
+# Whom: Tobias Roth <ports@fsck.ch>
#
# $FreeBSD$
#
-PORTNAME= gkx86info
+PORTNAME= gkx86info2
PORTVERSION= 0.0.2
-PORTREVISION= 1
CATEGORIES= misc
-MASTER_SITES= http://asdfnews.org/yargon/
-DISTNAME= ${PORTNAME}${PORTVERSION}
+MASTER_SITES= http://anchois.free.fr/ \
+ http://depot.fsck.ch/mirror/distfiles/
-MAINTAINER= lioux@FreeBSD.org
-COMMENT= GKrellM plugin that simply prints the current clock speed
+MAINTAINER= ports@fsck.ch
+COMMENT= GKrellM2 plugin that simply prints the current clock speed
-BUILD_DEPENDS= ${X11BASE}/include/gkrellm/gkrellm.h:${PORTSDIR}/sysutils/gkrellm
-RUN_DEPENDS= gkrellm:${PORTSDIR}/sysutils/gkrellm
+BUILD_DEPENDS= ${X11BASE}/include/gkrellm2/gkrellm.h:${PORTSDIR}/sysutils/gkrellm2
+RUN_DEPENDS= gkrellm:${PORTSDIR}/sysutils/gkrellm2
-ONLY_FOR_ARCHS= i386
USE_X_PREFIX= yes
-USE_GNOME= gtk12 imlib
-USE_SIZE= yes
+USE_GNOME= gtk20
-DOC_FILES= COPYING README
+WRKSRC= ${WRKDIR}/gkx86info${PORTVERSION}
do-build:
@cd ${WRKSRC} && eval ${CC} ${CFLAGS} -o MHz.o -c MHz.c
- @cd ${WRKSRC} && eval ${CC} -fPIC ${CFLAGS} \
- `${GTK_CONFIG} --cflags` \
- `${IMLIB_CONFIG} --cflags-gdk` -c gkx86info.c
- @cd ${WRKSRC} && eval ${CC} -shared ${CFLAGS} ${LDFLAGS} \
- -o ${PORTNAME}.so MHz.o gkx86info.o
+ @cd ${WRKSRC} && eval ${CC} ${CFLAGS} -fPIC \
+ `pkg-config gtk+-2.0 --cflags` -c gkx86info.c
+ @cd ${WRKSRC} && eval ${CC} ${CFLAGS} -shared \
+ -o ${PORTNAME}.so MHz.o gkx86info.o
do-install:
+ @${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME}.so \
+ ${PREFIX}/libexec/gkrellm2/plugins/
+
+post-install:
.ifndef(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
-.for file in ${DOC_FILES}
- @${INSTALL_DATA} ${WRKSRC}/${file} ${DOCSDIR}
-.endfor
-.endif #NOPORTDOCS
- @${INSTALL_DATA} ${WRKSRC}/${PORTNAME}.so \
- ${PREFIX}/libexec/gkrellm/plugins/
+ @${INSTALL_MAN} ${WRKSRC}/README ${DOCSDIR}
+.endif
.include <bsd.port.mk>
diff --git a/misc/gkx86info2/distinfo b/misc/gkx86info2/distinfo
index 17332de89250..894f6d443720 100644
--- a/misc/gkx86info2/distinfo
+++ b/misc/gkx86info2/distinfo
@@ -1,2 +1,2 @@
-MD5 (gkx86info0.0.2.tar.gz) = ad855b4f4e4556efee1ec9ac0871e215
-SIZE (gkx86info0.0.2.tar.gz) = 9429
+MD5 (gkx86info2-0.0.2.tar.gz) = e893ac5db865b4621c9f880686d30a99
+SIZE (gkx86info2-0.0.2.tar.gz) = 9570
diff --git a/misc/gkx86info2/files/patch-MHz.c b/misc/gkx86info2/files/patch-MHz.c
deleted file mode 100644
index 0bd1afcea79e..000000000000
--- a/misc/gkx86info2/files/patch-MHz.c
+++ /dev/null
@@ -1,19 +0,0 @@
---- MHz.c.orig Sat Oct 6 05:41:06 2001
-+++ MHz.c Wed Aug 7 23:01:05 2002
-@@ -11,6 +11,7 @@
- */
-
- #include <stdio.h>
-+#include <stdlib.h>
- #include <sys/time.h>
- #include <string.h>
- #include <unistd.h>
-@@ -45,7 +46,7 @@
- microseconds = ((tvstop.tv_sec-tvstart.tv_sec)*1000000) +
- (tvstop.tv_usec-tvstart.tv_usec);
-
-- buffer = malloc(sizeof(char)*512);
-+ buffer = (char *) malloc(sizeof(char)*512);
- sprintf(buffer, "%lldMHz",
- (cycles[1]-cycles[0])/microseconds);
-
diff --git a/misc/gkx86info2/pkg-descr b/misc/gkx86info2/pkg-descr
index 4cf2f5b33877..88dd24f10dcc 100644
--- a/misc/gkx86info2/pkg-descr
+++ b/misc/gkx86info2/pkg-descr
@@ -1,13 +1,6 @@
-[ excerpt from developer's www site ]
-
-This is a plugin for gkrellm that simply prints the current clock
+This is a plugin for gkrellm2 that simply prints the current clock
speed for users that own speed stepping processors.
-It works on normal non-stepping processors also, but there is not any
-point in mesuring the clock if it is the same every time you mesure
-it, now is there?
-
-Included code from x86info to calculate an estimate clock speed.
+This is the gkrellm2 version of this plugin, done by anchois.
-Author: Jake Richardson <jake@asdfnews.org>
-WWW: http://asdfnews.org/yargon/
+WWW: http://anchois.free.fr/
diff --git a/misc/gkx86info2/pkg-plist b/misc/gkx86info2/pkg-plist
index 6599095a4358..1e2151b32729 100644
--- a/misc/gkx86info2/pkg-plist
+++ b/misc/gkx86info2/pkg-plist
@@ -1,4 +1,3 @@
-libexec/gkrellm/plugins/gkx86info.so
-%%PORTDOCS%%share/doc/gkx86info/COPYING
-%%PORTDOCS%%share/doc/gkx86info/README
-%%PORTDOCS%%@dirrm share/doc/gkx86info
+libexec/gkrellm2/plugins/gkx86info2.so
+%%PORTDOCS%%%%DOCSDIR%%/README
+%%PORTDOCS%%@dirrm %%DOCSDIR%%